summaryrefslogtreecommitdiff
path: root/lib/sanitizer_common/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'lib/sanitizer_common/CMakeLists.txt')
-rw-r--r--lib/sanitizer_common/CMakeLists.txt12
1 files changed, 0 insertions, 12 deletions
diff --git a/lib/sanitizer_common/CMakeLists.txt b/lib/sanitizer_common/CMakeLists.txt
index 7f7f23a7..3b4ce221 100644
--- a/lib/sanitizer_common/CMakeLists.txt
+++ b/lib/sanitizer_common/CMakeLists.txt
@@ -100,18 +100,6 @@ else()
endforeach()
endif()
-# Add target to check code style for sanitizer runtimes.
-if(UNIX)
- set(SANITIZER_LINT_SCRIPT ${CMAKE_CURRENT_SOURCE_DIR}/scripts/check_lint.sh)
- add_custom_target(SanitizerLintCheck ALL
- COMMAND LLVM_CHECKOUT=${LLVM_MAIN_SRC_DIR} SILENT=1 TMPDIR=
- PYTHON_EXECUTABLE=${PYTHON_EXECUTABLE}
- ${SANITIZER_LINT_SCRIPT}
- DEPENDS ${SANITIZER_LINT_SCRIPT}
- COMMENT "Running lint check for sanitizer sources..."
- VERBATIM)
-endif()
-
# Unit tests for common sanitizer runtime.
if(LLVM_INCLUDE_TESTS)
add_subdirectory(tests)