summaryrefslogtreecommitdiff
path: root/packages/audio/libsamplerate/libsamplerate.mk
diff options
context:
space:
mode:
authorRicardo Crudo <ricardo.crudo@gmail.com>2014-11-01 13:32:15 -0200
committerAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2014-11-01 18:17:20 +0100
commit6540a52f3b50e178fef80a03c871384a05df49b8 (patch)
tree5a0e64dd40bb0251d39ac85727f554b4eb98d9e1 /packages/audio/libsamplerate/libsamplerate.mk
parenta280a152d06fdcd5ec2dde79e2b3bfbc91da6048 (diff)
downloadembtoolkit-6540a52f3b50e178fef80a03c871384a05df49b8.tar.gz
embtoolkit-6540a52f3b50e178fef80a03c871384a05df49b8.tar.bz2
embtoolkit-6540a52f3b50e178fef80a03c871384a05df49b8.tar.xz
Packages/audio: New libsamplerate v0.1.8
Signed-off-by: Ricardo Crudo <ricardo.crudo@gmail.com>
Diffstat (limited to 'packages/audio/libsamplerate/libsamplerate.mk')
-rw-r--r--packages/audio/libsamplerate/libsamplerate.mk42
1 files changed, 42 insertions, 0 deletions
diff --git a/packages/audio/libsamplerate/libsamplerate.mk b/packages/audio/libsamplerate/libsamplerate.mk
new file mode 100644
index 0000000..fdfe154
--- /dev/null
+++ b/packages/audio/libsamplerate/libsamplerate.mk
@@ -0,0 +1,42 @@
+################################################################################
+# Embtoolkit
+# Copyright(C) 2009-2014 Abdoulaye Walsimou GAYE.
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+################################################################################
+#
+# \file libsamplerate.mk
+# \brief libsamplerate.mk of Embtoolkit.
+# \author Ricardo Crudo <ricardo.crudo@gmail.com>
+# \date May 2014
+################################################################################
+
+LIBSAMPLERATE_NAME := libsamplerate
+LIBSAMPLERATE_VERSION := $(call embtk_get_pkgversion,libsamplerate)
+LIBSAMPLERATE_SITE := http://www.mega-nerd.com/SRC
+LIBSAMPLERATE_PACKAGE := libsamplerate-$(LIBSAMPLERATE_VERSION).tar.gz
+LIBSAMPLERATE_SRC_DIR := $(embtk_pkgb)/libsamplerate-$(LIBSAMPLERATE_VERSION)
+LIBSAMPLERATE_BUILD_DIR := $(embtk_pkgb)/libsamplerate-$(LIBSAMPLERATE_VERSION)
+
+LIBSAMPLERATE_BINS := sndfile-resample
+LIBSAMPLERATE_INCLUDES := samplerate.h
+LIBSAMPLERATE_LIBS := libsamplerate.*
+LIBSAMPLERATE_PKGCONFIGS := samplerate.pc
+LIBSAMPLERATE_SHARE := doc/libsamplerate0-dev
+
+LIBSAMPLERATE_CONFIGURE_OPTS := --program-transform-name='s;$(STRICT_GNU_TARGET)-;;'
+
+LIBSAMPLERATE_DEPS := $(if $(CONFIG_EMBTK_HAVE_FFTW),fftw_install)
+LIBSAMPLERATE_DEPS += $(if $(CONFIG_EMBTK_HAVE_LIBSNDFILE),libsndfile_install)