summaryrefslogtreecommitdiff
path: root/packages/audio/lv2
diff options
context:
space:
mode:
authorRicardo Crudo <ricardo.crudo@gmail.com>2014-05-16 23:16:50 +0200
committerAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2014-05-16 23:18:55 +0200
commit49bce85534212c58f6b77272bca6f036db1ec6cc (patch)
tree12a09f4106fad3cafc76733afd687e4ee430beea /packages/audio/lv2
parent37a86a63a339d78d676903bc35aa99a054e62409 (diff)
downloadembtoolkit-49bce85534212c58f6b77272bca6f036db1ec6cc.tar.gz
embtoolkit-49bce85534212c58f6b77272bca6f036db1ec6cc.tar.bz2
embtoolkit-49bce85534212c58f6b77272bca6f036db1ec6cc.tar.xz
Packages/audio: New lv2 v1.8.0
Signed-off-by: Ricardo Crudo <ricardo.crudo@gmail.com> Signed-off-by: Abdoulaye Walsimou Gaye <awg@embtoolkit.org>
Diffstat (limited to 'packages/audio/lv2')
-rw-r--r--packages/audio/lv2/lv2.kconfig56
-rw-r--r--packages/audio/lv2/lv2.mk40
2 files changed, 96 insertions, 0 deletions
diff --git a/packages/audio/lv2/lv2.kconfig b/packages/audio/lv2/lv2.kconfig
new file mode 100644
index 0000000..741f040
--- /dev/null
+++ b/packages/audio/lv2/lv2.kconfig
@@ -0,0 +1,56 @@
+################################################################################
+# Embtoolkit
+# Copyright(C) 2010-2014 Abdoulaye Walsimou GAYE.
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+################################################################################
+#
+# \file lv2.kconfig
+# \brief lv2.kconfig of Embtoolkit.
+# \author Ricardo Crudo <ricardo.crudo@gmail.com>
+# \date May 2014
+################################################################################
+
+config EMBTK_HAVE_LV2
+ bool "Have lv2"
+ help
+ LV2 is a portable plugin standard for audio systems, similar in scope
+ to LADSPA VST, AU, and others. It defines a C API for code and a format
+ for data files which collectively describe a plugin. LV2 consists of a
+ simple core (roughly equivalent in power to LADSPA) which can be
+ extended to support more advanced functionality.
+ This allows the interface to be "grown" to accommodate the needs of
+ real software as they arise.
+
+choice
+ prompt "lv2 version to use"
+ depends on EMBTK_HAVE_LV2
+ help
+ lv2 version to use
+
+ config EMBTK_LV2_VERSION_1_8_0
+ bool "lv2-1.8.0"
+endchoice
+
+config EMBTK_LV2_USE_WAF
+ bool
+ default y
+
+config EMBTK_LV2_VERSION_STRING
+ string
+ default "1.8.0" if EMBTK_LV2_VERSION_1_8_0
+
+config EMBTK_LV2_NEED_PATCH
+ bool
diff --git a/packages/audio/lv2/lv2.mk b/packages/audio/lv2/lv2.mk
new file mode 100644
index 0000000..052549b
--- /dev/null
+++ b/packages/audio/lv2/lv2.mk
@@ -0,0 +1,40 @@
+################################################################################
+# Embtoolkit
+# Copyright(C) 2009-2014 Abdoulaye Walsimou GAYE.
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+################################################################################
+#
+# \file lv2.mk
+# \brief lv2.mk of Embtoolkit.
+# \author Ricardo Crudo <ricardo.crudo@gmail.com>
+# \date May 2014
+################################################################################
+
+LV2_NAME := lv2
+LV2_VERSION := $(call embtk_get_pkgversion,lv2)
+LV2_SITE := http://lv2plug.in/spec
+LV2_PACKAGE := lv2-$(LV2_VERSION).tar.bz2
+LV2_SRC_DIR := $(embtk_pkgb)/lv2-$(LV2_VERSION)
+LV2_BUILD_DIR := $(embtk_pkgb)/lv2-$(LV2_VERSION)
+
+
+LV2_BINS := lv2specgen.py
+LV2_INCLUDES := lv2 lv2.h
+LV2_LIBS := lv2
+LV2_PKGCONFIGS := lv2.pc lv2core.pc
+LV2_SHARES := lv2specgen
+
+LV2_CONFIGURE_OPTS := --no-plugins