summaryrefslogtreecommitdiff
path: root/packages/development/libevent
diff options
context:
space:
mode:
authorAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2011-08-28 15:37:49 +0200
committerAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2011-08-28 15:37:49 +0200
commit305b54a1a103f33f552c9693fbe1a0b801855c9c (patch)
tree59dc9be69d2b1d16649272efc2dcc5bc8c71ffd3 /packages/development/libevent
parent53b4522531e73e8546592ed5713d6933f35fd6c0 (diff)
downloadembtoolkit-305b54a1a103f33f552c9693fbe1a0b801855c9c.tar.gz
embtoolkit-305b54a1a103f33f552c9693fbe1a0b801855c9c.tar.bz2
embtoolkit-305b54a1a103f33f552c9693fbe1a0b801855c9c.tar.xz
Packages: massively convert to use generic macros and implicit rules
Signed-off-by: Abdoulaye Walsimou Gaye <awg@embtoolkit.org>
Diffstat (limited to 'packages/development/libevent')
-rw-r--r--packages/development/libevent/libevent.mk36
1 files changed, 12 insertions, 24 deletions
diff --git a/packages/development/libevent/libevent.mk b/packages/development/libevent/libevent.mk
index 379fd95..51e53bf 100644
--- a/packages/development/libevent/libevent.mk
+++ b/packages/development/libevent/libevent.mk
@@ -23,28 +23,16 @@
# \date December 2009
################################################################################
-LIBEVENT_NAME := libevent
-LIBEVENT_VERSION := $(call embtk_get_pkgversion,LIBEVENT)
-LIBEVENT_SITE := http://www.monkey.org/~provos
-LIBEVENT_SITE_MIRROR3 := ftp://ftp.embtoolkit.org/embtoolkit.org/packages-mirror
-LIBEVENT_PATCH_SITE := ftp://ftp.embtoolkit.org/embtoolkit.org/libevent/$(LIBEVENT_VERSION)
-LIBEVENT_PACKAGE := libevent-$(LIBEVENT_VERSION).tar.gz
-LIBEVENT_SRC_DIR := $(PACKAGES_BUILD)/libevent-$(LIBEVENT_VERSION)
-LIBEVENT_BUILD_DIR := $(PACKAGES_BUILD)/libevent-$(LIBEVENT_VERSION)
+LIBEVENT_NAME := libevent
+LIBEVENT_VERSION := $(call embtk_get_pkgversion,LIBEVENT)
+LIBEVENT_SITE := http://www.monkey.org/~provos
+LIBEVENT_SITE_MIRROR3 := ftp://ftp.embtoolkit.org/embtoolkit.org/packages-mirror
+LIBEVENT_PACKAGE := libevent-$(LIBEVENT_VERSION).tar.gz
+LIBEVENT_SRC_DIR := $(PACKAGES_BUILD)/libevent-$(LIBEVENT_VERSION)
+LIBEVENT_BUILD_DIR := $(PACKAGES_BUILD)/libevent-$(LIBEVENT_VERSION)
-LIBEVENT_BINS = event_rpcgen.py
-LIBEVENT_SBINS =
-LIBEVENT_INCLUDES = evdns.h event-config.h event.h evhttp.h evrpc.h evutil.h
-LIBEVENT_LIBS = libevent*
-LIBEVENT_PKGCONFIGS =
-
-LIBEVENT_DEPS :=
-
-libevent_install:
- $(call embtk_install_pkg,LIBEVENT)
-
-download_libevent:
- $(call embtk_download_pkg,LIBEVENT)
-
-libevent_clean:
- $(call embtk_cleanup_pkg,LIBEVENT)
+LIBEVENT_BINS = event_rpcgen.py
+LIBEVENT_SBINS =
+LIBEVENT_INCLUDES = evdns.h event-config.h event.h evhttp.h evrpc.h evutil.h
+LIBEVENT_LIBS = libevent*
+LIBEVENT_PKGCONFIGS =