summaryrefslogtreecommitdiff
path: root/packages/development
diff options
context:
space:
mode:
authorAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2011-03-26 21:47:25 +0100
committerAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2011-03-26 21:47:25 +0100
commit2399bfe4ebfe3639d86db7f81acd0b740408ae3b (patch)
tree57d44e7f75de1c38073c3f746be0a6e7cde31be0 /packages/development
parent9208accec4aa8436efb66e9ccd1d41c1cf2fb2db (diff)
downloadembtoolkit-2399bfe4ebfe3639d86db7f81acd0b740408ae3b.tar.gz
embtoolkit-2399bfe4ebfe3639d86db7f81acd0b740408ae3b.tar.bz2
embtoolkit-2399bfe4ebfe3639d86db7f81acd0b740408ae3b.tar.xz
Packages: NEW libsigsegv: add libsigsegv-2.6
Signed-off-by: Abdoulaye Walsimou Gaye <awg@embtoolkit.org>
Diffstat (limited to 'packages/development')
-rw-r--r--packages/development/development.kconfig3
-rw-r--r--packages/development/development.mk4
-rw-r--r--packages/development/libsigsegv/libsigsegv.kconfig61
-rw-r--r--packages/development/libsigsegv/libsigsegv.mk55
4 files changed, 123 insertions, 0 deletions
diff --git a/packages/development/development.kconfig b/packages/development/development.kconfig
index 5daa19e..f12e035 100644
--- a/packages/development/development.kconfig
+++ b/packages/development/development.kconfig
@@ -28,3 +28,6 @@ source packages/development/libevent/libevent.kconfig
#libnih
source packages/development/libnih/libnih.kconfig
+
+#libsigsegv
+source packages/development/libsigsegv/libsigsegv.kconfig
diff --git a/packages/development/development.mk b/packages/development/development.mk
index 94c5ba5..97025fa 100644
--- a/packages/development/development.mk
+++ b/packages/development/development.mk
@@ -30,3 +30,7 @@ ROOTFS_COMPONENTS-$(CONFIG_EMBTK_HAVE_LIBEVENT) += libevent_install
#libnih
include $(EMBTK_ROOT)/packages/development/libnih/libnih.mk
ROOTFS_COMPONENTS-$(CONFIG_EMBTK_HAVE_LIBNIH) += libnih_install
+
+#libsigsegv
+include $(EMBTK_ROOT)/packages/development/libsigsegv/libsigsegv.mk
+ROOTFS_COMPONENTS-$(CONFIG_EMBTK_HAVE_LIBSIGSEGV) += libsigsegv_install
diff --git a/packages/development/libsigsegv/libsigsegv.kconfig b/packages/development/libsigsegv/libsigsegv.kconfig
new file mode 100644
index 0000000..2589b9e
--- /dev/null
+++ b/packages/development/libsigsegv/libsigsegv.kconfig
@@ -0,0 +1,61 @@
+################################################################################
+# Embtoolkit
+# Copyright(C) 2011 Abdoulaye Walsimou GAYE.
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+################################################################################
+#
+# \file libsigsegv.kconfig
+# \brief libsigsegv.kconfig of Embtoolkit
+# \author Abdoulaye Walsimou GAYE <awg@embtoolkit.org>
+# \date March 2011
+################################################################################
+
+config EMBTK_HAVE_LIBSIGSEGV
+ bool "Have libsigsegv"
+ help
+ This is a library for handling page faults in user mode.
+ A page fault occurs when a program tries to access to a region
+ of memory that is currently not available. Catching and handling
+ a page fault is a useful technique for implementing:
+ * pageable virtual memory,
+ * memory-mapped access to persistent databases,
+ * generational garbage collectors,
+ * stack overflow handlers,
+ * distributed shared memory,
+ * ...
+choice
+ prompt "libsigsegv version you wish"
+ depends on EMBTK_HAVE_LIBSIGSEGV
+ help
+ Here you can choose which version of libsigsegv you want to use.
+
+ config EMBTK_LIBSIGSEGV_VERSION_2_6
+ bool "libsigsegv-2.6"
+ select EMBTK_LIBSIGSEGV_PKG_IS_TARGZ
+endchoice
+
+config EMBTK_LIBSIGSEGV_VERSION_STRING
+ string
+ default "2.6" if EMBTK_LIBSIGSEGV_VERSION_2_6
+
+config EMBTK_LIBSIGSEGV_NEED_PATCH
+ bool
+config EMBTK_LIBSIGSEGV_NEED_AUTORECONF
+ bool
+config EMBTK_LIBSIGSEGV_PKG_IS_TARGZ
+ bool
+config EMBTK_LIBSIGSEGV_PKG_IS_TARBZ2
+ bool
diff --git a/packages/development/libsigsegv/libsigsegv.mk b/packages/development/libsigsegv/libsigsegv.mk
new file mode 100644
index 0000000..1c59381
--- /dev/null
+++ b/packages/development/libsigsegv/libsigsegv.mk
@@ -0,0 +1,55 @@
+################################################################################
+# Embtoolkit
+# Copyright(C) 2011 Abdoulaye Walsimou GAYE.
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+################################################################################
+#
+# \file libsigsegv.mk
+# \brief libsigsegv.mk of Embtoolkit
+# \author Abdoulaye Walsimou GAYE <awg@embtoolkit.org>
+# \date March 2011
+################################################################################
+
+LIBSIGSEGV_NAME := libsigsegv
+LIBSIGSEGV_VERSION := $(call EMBTK_GET_PKG_VERSION,LIBSIGSEGV)
+LIBSIGSEGV_SITE := ftp://ftp.gnu.org/pub/gnu/libsigsegv
+LIBSIGSEGV_SITE_MIRROR3 := http://ftp.gnu.org/gnu/libsigsegv
+LIBSIGSEGV_SITE_MIRROR3 := ftp://ftp.embtoolkit.org/embtoolkit.org/packages-mirror
+LIBSIGSEGV_PATCH_SITE := ftp://ftp.embtoolkit.org/embtoolkit.org/libsigsegv/$(LIBSIGSEGV_VERSION)
+LIBSIGSEGV_PACKAGE := libsigsegv-$(LIBSIGSEGV_VERSION).tar.gz
+LIBSIGSEGV_SRC_DIR := $(PACKAGES_BUILD)/libsigsegv-$(LIBSIGSEGV_VERSION)
+LIBSIGSEGV_BUILD_DIR := $(PACKAGES_BUILD)/libsigsegv-$(LIBSIGSEGV_VERSION)
+
+LIBSIGSEGV_BINS =
+LIBSIGSEGV_SBINS =
+LIBSIGSEGV_INCLUDES = sigsegv.h
+LIBSIGSEGV_LIBS = libsigsegv.*
+LIBSIGSEGV_LIBEXECS =
+LIBSIGSEGV_PKGCONFIGS =
+
+LIBSIGSEGV_CONFIGURE_ENV :=
+LIBSIGSEGV_CONFIGURE_OPTS :=
+
+LIBSIGSEGV_DEPS :=
+
+libsigsegv_install:
+ $(call EMBTK_INSTALL_PKG,LIBSIGSEGV)
+
+download_libsigsegv:
+ $(call EMBTK_DOWNLOAD_PKG,LIBSIGSEGV)
+
+libsigsegv_clean:
+ $(call EMBTK_CLEANUP_PKG,LIBSIGSEGV)