summaryrefslogtreecommitdiff
path: root/packages/development
diff options
context:
space:
mode:
authorAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2014-10-18 14:42:14 +0200
committerAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2014-10-18 14:42:14 +0200
commit258c21a0f9cdad543ad287c86c7de7170ac546d4 (patch)
treec1a55823ab56af30487aeaad6315422562828c48 /packages/development
parent6423b10b6a6fbcdbe1f7ff66a957b44b2254ccfc (diff)
downloadembtoolkit-258c21a0f9cdad543ad287c86c7de7170ac546d4.tar.gz
embtoolkit-258c21a0f9cdad543ad287c86c7de7170ac546d4.tar.bz2
embtoolkit-258c21a0f9cdad543ad287c86c7de7170ac546d4.tar.xz
Packages: e2fsprogs-libuuid: update to v1.14.12 and split it into host/target packages
Signed-off-by: Abdoulaye Walsimou Gaye <awg@embtoolkit.org>
Diffstat (limited to 'packages/development')
-rw-r--r--packages/development/development.kconfig3
-rw-r--r--packages/development/development.mk3
-rw-r--r--packages/development/e2fsprogs-libuuid/e2fsprogs-libuuid.kconfig48
-rw-r--r--packages/development/e2fsprogs-libuuid/e2fsprogs-libuuid.mk60
4 files changed, 114 insertions, 0 deletions
diff --git a/packages/development/development.kconfig b/packages/development/development.kconfig
index a57e43d..af9a245 100644
--- a/packages/development/development.kconfig
+++ b/packages/development/development.kconfig
@@ -68,6 +68,9 @@ source packages/development/libsigsegv/libsigsegv.kconfig
# libunwind
source packages/development/libunwind/libunwind.kconfig
+# libuuid
+source packages/development/e2fsprogs-libuuid/e2fsprogs-libuuid.kconfig
+
# openblas
source packages/development/openblas/openblas.kconfig
diff --git a/packages/development/development.mk b/packages/development/development.mk
index 2a9d220..7223a4d 100644
--- a/packages/development/development.mk
+++ b/packages/development/development.mk
@@ -71,6 +71,9 @@ $(call embtk_include_pkg,libsigsegv)
# libunwind
$(call embtk_include_pkg,libunwind)
+# libuuid
+$(call embtk_include_pkg,e2fsprogs-libuuid)
+
# openblas
$(call embtk_include_pkg,openblas)
diff --git a/packages/development/e2fsprogs-libuuid/e2fsprogs-libuuid.kconfig b/packages/development/e2fsprogs-libuuid/e2fsprogs-libuuid.kconfig
new file mode 100644
index 0000000..71941ee
--- /dev/null
+++ b/packages/development/e2fsprogs-libuuid/e2fsprogs-libuuid.kconfig
@@ -0,0 +1,48 @@
+################################################################################
+# Embtoolkit
+# Copyright(C) 2009-2014 Abdoulaye Walsimou GAYE.
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+################################################################################
+#
+# \file e2fsprogs-libuuid.kconfig
+# \brief e2fsprogs-libuuid.kconfig of Embtoolkit
+# \author Abdoulaye Walsimou GAYE <awg@embtoolkit.org>
+# \date June 2011
+################################################################################
+
+config EMBTK_HAVE_E2FSPROGS-LIBUUID
+ bool "Have e2fsprogs-libuuid"
+ help
+ Universally unique identifier (UUID) generator from e2fsprogs
+
+choice
+ prompt "e2fsprogs-libuuid version you wish"
+ depends on EMBTK_HAVE_E2FSPROGS-LIBUUID
+ help
+ Here you can choose which version you want to use.
+
+ config EMBTK_E2FSPROGS-LIBUUID_VERSION_1_42_12
+ bool "e2fsprogs-libuuid-1.42.12"
+endchoice
+
+config EMBTK_E2FSPROGS-LIBUUID_VERSION_STRING
+ string
+ default "1.42.12" if EMBTK_E2FSPROGS-LIBUUID_VERSION_1_42_12
+
+config EMBTK_E2FSPROGS-LIBUUID_NEED_PATCH
+ bool
+config EMBTK_E2FSPROGS-LIBUUID_NEED_AUTORECONF
+ bool
diff --git a/packages/development/e2fsprogs-libuuid/e2fsprogs-libuuid.mk b/packages/development/e2fsprogs-libuuid/e2fsprogs-libuuid.mk
new file mode 100644
index 0000000..8b24873
--- /dev/null
+++ b/packages/development/e2fsprogs-libuuid/e2fsprogs-libuuid.mk
@@ -0,0 +1,60 @@
+################################################################################
+# Embtoolkit
+# Copyright(C) 2009-2014 Abdoulaye Walsimou GAYE.
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+################################################################################
+#
+# \file e2fsprogs.mk
+# \brief e2fsprogs.mk of Embtoolkit
+# \author Abdoulaye Walsimou GAYE <awg@embtoolkit.org>
+# \date June 2011
+################################################################################
+
+E2FSPROGS-LIBUUID_NAME := e2fsprogs-libuuid
+E2FSPROGS-LIBUUID_VERSION := $(call embtk_pkg_version,e2fsprogs-libuuid)
+E2FSPROGS-LIBUUID_SITE := http://sourceforge.net/projects/e2fsprogs/files/e2fsprogs/v$(E2FSPROGS-LIBUUID_VERSION)
+E2FSPROGS-LIBUUID_PACKAGE := e2fsprogs-libs-$(E2FSPROGS-LIBUUID_VERSION).tar.gz
+E2FSPROGS-LIBUUID_SRC_DIR := $(embtk_pkgb)/e2fsprogs-libs-$(E2FSPROGS-LIBUUID_VERSION)
+E2FSPROGS-LIBUUID_BUILD_DIR := $(embtk_pkgb)/e2fsprogs-libs-$(E2FSPROGS-LIBUUID_VERSION)-build
+
+E2FSPROGS-LIBUUID_INCLUDES := uuid
+E2FSPROGS-LIBUUID_LIBS := libuuid.*
+E2FSPROGS-LIBUUID_PKGCONFIGS := uuid.pc
+E2FSPROGS-LIBUUID_SHARES := man/man*/uuid*
+
+E2FSPROGS-LIBUUID_MAKE_OPTS := LDCONFIG=true
+E2FSPROGS-LIBUUID_MAKE_DIRS := util lib/uuid
+
+E2FSPROGS-LIBUUID_CONFIGURE_OPTS := --disable-compression
+E2FSPROGS-LIBUUID_CONFIGURE_OPTS += --disable-htree
+E2FSPROGS-LIBUUID_CONFIGURE_OPTS += --enable-elf-shlibs
+E2FSPROGS-LIBUUID_CONFIGURE_OPTS += --disable-bsd-shlibs
+E2FSPROGS-LIBUUID_CONFIGURE_OPTS += --disable-profile
+E2FSPROGS-LIBUUID_CONFIGURE_OPTS += --disable-checker
+E2FSPROGS-LIBUUID_CONFIGURE_OPTS += --disable-jbd-debug
+E2FSPROGS-LIBUUID_CONFIGURE_OPTS += --disable-blkid-debug
+E2FSPROGS-LIBUUID_CONFIGURE_OPTS += --disable-testio-debug
+E2FSPROGS-LIBUUID_CONFIGURE_OPTS += --enable-libuuid
+E2FSPROGS-LIBUUID_CONFIGURE_OPTS += --enable-libblkid
+E2FSPROGS-LIBUUID_CONFIGURE_OPTS += --disable-debugfs
+E2FSPROGS-LIBUUID_CONFIGURE_OPTS += --disable-imager
+E2FSPROGS-LIBUUID_CONFIGURE_OPTS += --disable-resizer
+E2FSPROGS-LIBUUID_CONFIGURE_OPTS += --disable-fsck
+E2FSPROGS-LIBUUID_CONFIGURE_OPTS += --disable-e2initrd-helper
+E2FSPROGS-LIBUUID_CONFIGURE_OPTS += --disable-tls
+E2FSPROGS-LIBUUID_CONFIGURE_OPTS += --disable-nls
+E2FSPROGS-LIBUUID_CONFIGURE_OPTS += --disable-rpath
+E2FSPROGS-LIBUUID_CONFIGURE_OPTS += --with-included-gettext