summaryrefslogtreecommitdiff
path: root/packages/development
diff options
context:
space:
mode:
authorRicardo Crudo <ricardo.crudo@gmail.com>2014-05-16 00:00:55 +0200
committerAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2014-05-16 00:01:28 +0200
commit35ea7a76b1ad641dea11cd2126a7e26824ec4439 (patch)
tree93941311466ea115462fe209b11f83c6d37962d4 /packages/development
parentebe622803c485fe6f69178726f22799e1f98718d (diff)
downloadembtoolkit-35ea7a76b1ad641dea11cd2126a7e26824ec4439.tar.gz
embtoolkit-35ea7a76b1ad641dea11cd2126a7e26824ec4439.tar.bz2
embtoolkit-35ea7a76b1ad641dea11cd2126a7e26824ec4439.tar.xz
Packages/development: New fftw v3.3.4
Signed-off-by: Ricardo Crudo <ricardo.crudo@gmail.com> Signed-off-by: Abdoulaye Walsimou Gaye <awg@embtoolkit.org>
Diffstat (limited to 'packages/development')
-rw-r--r--packages/development/development.kconfig9
-rw-r--r--packages/development/development.mk9
-rw-r--r--packages/development/fftw/fftw.kconfig51
-rw-r--r--packages/development/fftw/fftw.mk45
4 files changed, 108 insertions, 6 deletions
diff --git a/packages/development/development.kconfig b/packages/development/development.kconfig
index 39d35f0..205f823 100644
--- a/packages/development/development.kconfig
+++ b/packages/development/development.kconfig
@@ -26,15 +26,18 @@
# boost
source packages/development/boost/boost.kconfig
+# fftw
+source packages/development/fftw/fftw.kconfig
+
+# gtest
+source packages/development/gtest/gtest.kconfig
+
# libbsd
source packages/development/libbsd/libbsd.kconfig
# libevent
source packages/development/libevent/libevent.kconfig
-# gtest
-source packages/development/gtest/gtest.kconfig
-
# libnih
source packages/development/libnih/libnih.kconfig
diff --git a/packages/development/development.mk b/packages/development/development.mk
index b070ebc..f90971a 100644
--- a/packages/development/development.mk
+++ b/packages/development/development.mk
@@ -28,15 +28,18 @@ embtk_pkgincdir := packages/development
# boost
$(call embtk_include_pkg,boost)
+# fftw
+$(call embtk_include_pkg,fftw)
+
+# gtest
+$(call embtk_include_pkg,gtest)
+
# libbsd
$(call embtk_include_pkg,libbsd)
# libevent
$(call embtk_include_pkg,libevent)
-# gtest
-$(call embtk_include_pkg,gtest)
-
# libnih
$(call embtk_include_pkg,libnih)
diff --git a/packages/development/fftw/fftw.kconfig b/packages/development/fftw/fftw.kconfig
new file mode 100644
index 0000000..56ed8ea
--- /dev/null
+++ b/packages/development/fftw/fftw.kconfig
@@ -0,0 +1,51 @@
+################################################################################
+# Embtoolkit
+# Copyright(C) 2010-2014 Abdoulaye Walsimou GAYE.
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+################################################################################
+#
+# \file fftw.kconfig
+# \brief fftw.kconfig of Embtoolkit.
+# \author Ricardo Crudo <ricardo.crudo@gmail.com>
+# \date April 2014
+################################################################################
+
+config EMBTK_HAVE_FFTW
+ bool "Have fftw"
+ help
+ FFTW is a C subroutine library for computing the discrete Fourier
+ transform (DFT) in one or more dimensions, of arbitrary input size, and
+ of both real and complex data (as well as of even/odd data, i.e. the
+ discrete cosine/sine transforms or DCT/DST).
+
+choice
+ prompt "fftw version to use"
+ depends on EMBTK_HAVE_FFTW
+ help
+ fftw version to use
+
+ config EMBTK_FFTW_VERSION_3_3_4
+ bool "fftw-3.3.4"
+endchoice
+
+config EMBTK_FFTW_VERSION_STRING
+ string
+ default "3.3.4" if EMBTK_FFTW_VERSION_3_3_4
+
+config EMBTK_FFTW_NEED_PATCH
+ bool
+config EMBTK_FFTW_NEED_AUTORECONF
+ bool
diff --git a/packages/development/fftw/fftw.mk b/packages/development/fftw/fftw.mk
new file mode 100644
index 0000000..c419030
--- /dev/null
+++ b/packages/development/fftw/fftw.mk
@@ -0,0 +1,45 @@
+################################################################################
+# Embtoolkit
+# Copyright(C) 2009-2014 Abdoulaye Walsimou GAYE.
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+################################################################################
+#
+# \file fftw.mk
+# \brief fftw.mk of Embtoolkit.
+# \author Ricardo Crudo <ricardo.crudo@gmail.com>
+# \date April 2014
+################################################################################
+
+FFTW_NAME := fftw
+FFTW_VERSION := $(call embtk_get_pkgversion,fftw)
+FFTW_SITE := http://www.fftw.org
+FFTW_PACKAGE := fftw-$(FFTW_VERSION).tar.gz
+FFTW_SRC_DIR := $(embtk_pkgb)/fftw-$(FFTW_VERSION)
+FFTW_BUILD_DIR := $(embtk_pkgb)/fftw-$(FFTW_VERSION)
+
+FFTW_INCLUDES := fftw*.h
+FFTW_LIBS := libfftw*.*
+FFTW_PKGCONFIGS := fftw*.pc
+
+FFTW_CONFIGURE_OPTS := --enable-shared
+FFTW_CONFIGURE_OPTS-y :=
+# check whether is ARM architecture
+FFTW_CONFIGURE_OPTS-$(CONFIG_EMBTK_ARCH_ARM) += --with-slow-timer
+FFTW_CONFIGURE_OPTS-$(CONFIG_EMBTK_ARCH_ARM_FPU_NEON) += --enable-single --enable-neon
+FFTW_CONFIGURE_OPTS-$(CONFIG_EMBTK_ARCH_ARM_FPU_NEON_FP16) += --enable-single --enable-neon
+FFTW_CONFIGURE_OPTS-$(CONFIG_EMBTK_ARCH_ARM_FPU_NEON_VFPV4) += --enable-single --enable-neon
+
+FFTW_CONFIGURE_OPTS += $(FFTW_CONFIGURE_OPTS-y)