summaryrefslogtreecommitdiff
path: root/packages/development
diff options
context:
space:
mode:
authorAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2014-05-17 21:08:31 +0200
committerAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2014-05-17 21:08:31 +0200
commit4ef11d2dd30ff0fffc573879f0a7b9327879c5f2 (patch)
tree5942cfb56efe146ac7198319112ea3b5d1472add /packages/development
parentc6a2550f1f4b745f76dcb6e54d8a1da5eb15f1c8 (diff)
downloadembtoolkit-4ef11d2dd30ff0fffc573879f0a7b9327879c5f2.tar.gz
embtoolkit-4ef11d2dd30ff0fffc573879f0a7b9327879c5f2.tar.bz2
embtoolkit-4ef11d2dd30ff0fffc573879f0a7b9327879c5f2.tar.xz
Packages: boost: give ability to build some optional feature and set dependencies
Signed-off-by: Abdoulaye Walsimou Gaye <awg@embtoolkit.org>
Diffstat (limited to 'packages/development')
-rw-r--r--packages/development/boost/boost.kconfig15
-rw-r--r--packages/development/boost/boost.mk15
2 files changed, 25 insertions, 5 deletions
diff --git a/packages/development/boost/boost.kconfig b/packages/development/boost/boost.kconfig
index 2caff61..af2bd6e 100644
--- a/packages/development/boost/boost.kconfig
+++ b/packages/development/boost/boost.kconfig
@@ -25,6 +25,9 @@
config EMBTK_HAVE_BOOST
bool "Have boost"
+ select EMBTK_HAVE_GETTEXT
+ select EMBTK_HAVE_BZIP2
+ select EMBTK_HAVE_ZLIB
select EMBTK_GCC_LANGUAGE_CPP
select KEMBTK_UCLIBC_UCLIBC_HAS_LOCALE if EMBTK_CLIB_UCLIBC
select KEMBTK_UCLIBC_UCLIBC_HAS_XLOCALE if EMBTK_CLIB_UCLIBC
@@ -44,6 +47,18 @@ choice
bool "boost-1.55.0"
endchoice
+if EMBTK_HAVE_BOOST
+comment "Boost options"
+config EMBTK_BOOST_WITH_ICU
+ bool "Build boot with icu support"
+config EMBTK_BOOST_WITH_ATOMIC
+ bool "Build boot with atomic support"
+config EMBTK_BOOST_WITH_COROUTINE
+ bool "Build boot with coroutine support"
+config EMBTK_BOOST_WITH_LOG
+ bool "Build boot with log support"
+endif
+
config EMBTK_BOOST_VERSION_STRING
string
default "1_55_0" if EMBTK_BOOST_VERSION_1_55_0
diff --git a/packages/development/boost/boost.mk b/packages/development/boost/boost.mk
index 41a6faf..aaf7eac 100644
--- a/packages/development/boost/boost.mk
+++ b/packages/development/boost/boost.mk
@@ -38,17 +38,22 @@ BOOST_CXXFLAGS := $(TARGET_CXXFLAGS)
BOOST_LDFLAGS := -L$(embtk_sysroot)/$(LIBDIR)
BOOST_LDFLAGS += -L$(embtk_sysroot)/usr/$(LIBDIR)
-BOOST_CONFIGURE_OPTS := --without-icu --with-toolset=gcc
-BOOST_MAKE_OPTS := -q variant=release -sNO_BZIP2=1
-BOOST_MAKE_OPTS += --without-atomic --without-coroutine
-BOOST_MAKE_OPTS += --without-log --without-python
+BOOST_CONFIGURE_OPTS := $(if $(CONFIG_EMBTK_BOOST_WITH_ICU),--with-icu,--without-icu)
+BOOST_CONFIGURE_OPTS += --with-toolset=gcc
+
+BOOST_MAKE_OPTS := $(if $(CONFIG_EMBTK_BOOST_WITH_ATOMIC),,--without-atomic)
+BOOST_MAKE_OPTS += $(if $(CONFIG_EMBTK_BOOST_WITH_COROUTINE),,--without-coroutine)
+BOOST_MAKE_OPTS += $(if $(CONFIG_EMBTK_BOOST_WITH_LOG),,--without-log)
+BOOST_MAKE_OPTS += --without-python
+BOOST_MAKE_OPTS += -q variant=release
BOOST_MAKE_OPTS += link=shared runtime-link=shared
BOOST_MAKE_OPTS += threading=multi toolset=gcc
ifeq ($(CONFIG_EMBTK_CLIB_UCLIBC),y)
BOOST_MAKE_OPTS += boost.locale.posix=off
endif
-BOOST_DEPS := zlib_install
+BOOST_DEPS-$(CONFIG_EMBTK_BOOST_WITH_ICU) := icu_install
+BOOST_DEPS := zlib_install bzip2_install gettext_install $(BOOST_DEPS-y)
# FIXME: consider using clang++ when libc++ will be fully integrated
embtk_boost_cxx = using gcc : $(shell $(TARGETGCC) -dumpversion) : $(TARGETGCXX_CACHED)