summaryrefslogtreecommitdiff
path: root/packages/development
diff options
context:
space:
mode:
authorAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2014-05-11 18:22:34 +0200
committerAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2014-05-11 18:22:34 +0200
commit51d2ccf3fcd82f5ff438f6081982e0f7cce708a5 (patch)
tree983e0820f6f422c988295bca31a4e2f56029a4ca /packages/development
parenta2825bc53fb6c116f882c0b252cf7bed0631cb3d (diff)
downloadembtoolkit-51d2ccf3fcd82f5ff438f6081982e0f7cce708a5.tar.gz
embtoolkit-51d2ccf3fcd82f5ff438f6081982e0f7cce708a5.tar.bz2
embtoolkit-51d2ccf3fcd82f5ff438f6081982e0f7cce708a5.tar.xz
Packages: boost: fix build under FreeBSD by build b2 and jam
Signed-off-by: Abdoulaye Walsimou Gaye <awg@embtoolkit.org>
Diffstat (limited to 'packages/development')
-rw-r--r--packages/development/boost/boost.mk17
1 files changed, 10 insertions, 7 deletions
diff --git a/packages/development/boost/boost.mk b/packages/development/boost/boost.mk
index 334fdb8..c02dc9a 100644
--- a/packages/development/boost/boost.mk
+++ b/packages/development/boost/boost.mk
@@ -38,8 +38,8 @@ BOOST_CXXFALGS := $(TARGET_CXXFLAGS)
BOOST_LDFALGS := -L$(embtk_sysroot)/$(LIBDIR)
BOOST_LDFALGS += -L$(embtk_sysroot)/usr/$(LIBDIR)
-BOOST_CONFIGURE_OPTS := --without-icu
-BOOST_MAKE_OPTS := -q variant=release
+BOOST_CONFIGURE_OPTS := --without-icu --with-toolset=gcc
+BOOST_MAKE_OPTS := -q variant=release -sNO_BZIP2=1
BOOST_MAKE_OPTS += --without-atomic --without-coroutine
BOOST_MAKE_OPTS += --without-log --without-python
BOOST_MAKE_OPTS += link=shared runtime-link=shared
@@ -48,16 +48,19 @@ BOOST_MAKE_OPTS += threading=multi toolset=gcc
BOOST_DEPS := zlib_install
# FIXME: consider using clang++ when libc++ will be fully integrated
-embtk_boost_cxx = using gcc:$(shell $(TARGETGCC) -dumpversion):$(TARGETGCC)
+embtk_boost_cxx = using gcc : $(shell $(TARGETGCC) -dumpversion) : $(TARGETGCC)
embtk_boost_flags := <compileflags>\"$(BOOST_CXXFALGS)\"
embtk_boost_flags += <linkflags>\"$(BOOST_LDFALGS)\"
embtk_boost_userjam := $(BOOST_SRC_DIR)/user-config.jam
define embtk_configure_boost
- cd $(BOOST_SRC_DIR); \
- $(CONFIG_EMBTK_SHELL) $(BOOST_SRC_DIR)/bootstrap.sh \
- $(BOOST_CONFIGURE_OPTS)
- echo "$(embtk_boost_cxx):$(embtk_boost_flags);" > $(embtk_boost_userjam)
+ cd $(BOOST_SRC_DIR)/tools/build/v2/engine/; \
+ ./build.sh $(notdir $(HOSTCC))
+ for f in $(BOOST_SRC_DIR)/tools/build/v2/engine/bin.*/*; do \
+ cp $$f $(BOOST_SRC_DIR); \
+ done
+ echo "$(embtk_boost_cxx) : $(embtk_boost_flags) ;" \
+ > $(embtk_boost_userjam)
echo "" >> $(embtk_boost_userjam)
endef