summaryrefslogtreecommitdiff
path: root/packages/development
diff options
context:
space:
mode:
authorAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2014-01-31 23:01:32 +0100
committerAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2014-01-31 23:01:32 +0100
commit5eaaa61ba801661024d0498503ae21b6a37905be (patch)
tree04a65ed174502a7698e4ca8e965483d5148eda52 /packages/development
parentd36923a0f32e4398c2805535529b343d48e6f251 (diff)
downloadembtoolkit-5eaaa61ba801661024d0498503ae21b6a37905be.tar.gz
embtoolkit-5eaaa61ba801661024d0498503ae21b6a37905be.tar.bz2
embtoolkit-5eaaa61ba801661024d0498503ae21b6a37905be.tar.xz
Packages NEW: add popt v1.16
Signed-off-by: Abdoulaye Walsimou Gaye <awg@embtoolkit.org>
Diffstat (limited to 'packages/development')
-rw-r--r--packages/development/development.kconfig11
-rw-r--r--packages/development/development.mk5
-rw-r--r--packages/development/popt/popt.kconfig57
-rw-r--r--packages/development/popt/popt.mk35
4 files changed, 103 insertions, 5 deletions
diff --git a/packages/development/development.kconfig b/packages/development/development.kconfig
index b9409ca..8ccfa12 100644
--- a/packages/development/development.kconfig
+++ b/packages/development/development.kconfig
@@ -1,6 +1,6 @@
################################################################################
# Embtoolkit
-# Copyright(C) 2009-2013 Abdoulaye Walsimou GAYE.
+# Copyright(C) 2009-2014 Abdoulaye Walsimou GAYE.
#
# This program is free software: you can redistribute it and/or modify
# it under the terms of the GNU General Public License as published by
@@ -26,17 +26,20 @@
# libbsd
source packages/development/libbsd/libbsd.kconfig
-#libevent
+# libevent
source packages/development/libevent/libevent.kconfig
# gtest
source packages/development/gtest/gtest.kconfig
-#libnih
+# libnih
source packages/development/libnih/libnih.kconfig
-#libsigsegv
+# libsigsegv
source packages/development/libsigsegv/libsigsegv.kconfig
# libunwind
source packages/development/libunwind/libunwind.kconfig
+
+# popt
+source packages/development/popt/popt.kconfig
diff --git a/packages/development/development.mk b/packages/development/development.mk
index fc67fd3..32ba18e 100644
--- a/packages/development/development.mk
+++ b/packages/development/development.mk
@@ -1,6 +1,6 @@
################################################################################
# Embtoolkit
-# Copyright(C) 2009-2013 Abdoulaye Walsimou GAYE.
+# Copyright(C) 2009-2014 Abdoulaye Walsimou GAYE.
#
# This program is free software: you can redistribute it and/or modify
# it under the terms of the GNU General Public License as published by
@@ -42,3 +42,6 @@ $(call embtk_include_pkg,libsigsegv)
# libunwind
$(call embtk_include_pkg,libunwind)
+
+# popt
+$(call embtk_include_pkg,popt)
diff --git a/packages/development/popt/popt.kconfig b/packages/development/popt/popt.kconfig
new file mode 100644
index 0000000..4248094
--- /dev/null
+++ b/packages/development/popt/popt.kconfig
@@ -0,0 +1,57 @@
+################################################################################
+# Embtoolkit
+# Copyright(C) 2014 Abdoulaye Walsimou GAYE.
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+################################################################################
+#
+# \file popt.kconfig
+# \brief popt.kconfig of Embtoolkit
+# \author Abdoulaye Walsimou GAYE <awg@embtoolkit.org>
+# \date January 2014
+################################################################################
+
+config EMBTK_HAVE_POPT
+ bool "Have popt"
+ help
+ This is the popt command line option parsing library.
+ While it is similar to getopt(3), it contains a number of enhancements,
+ including:
+ 1) popt is fully reentrant
+ 2) popt can parse arbitrary argv[] style arrays while getopt(2) makes
+ this quite difficult
+ 3) popt allows users to alias command line arguments
+ 4) popt provides convenience functions for parsing strings into argv[]
+ style arrays.
+ See http://freshmeat.net/projects/popt
+
+choice
+ prompt "popt version you wish"
+ depends on EMBTK_HAVE_POPT
+ help
+ Here you can choose which version of popt you want to use.
+
+ config EMBTK_POPT_VERSION_1_16
+ bool "popt-1.16"
+endchoice
+
+config EMBTK_POPT_VERSION_STRING
+ string
+ default "1.16" if EMBTK_POPT_VERSION_1_16
+
+config EMBTK_POPT_NEED_PATCH
+ bool
+config EMBTK_POPT_NEED_AUTORECONF
+ bool
diff --git a/packages/development/popt/popt.mk b/packages/development/popt/popt.mk
new file mode 100644
index 0000000..6fb8fa6
--- /dev/null
+++ b/packages/development/popt/popt.mk
@@ -0,0 +1,35 @@
+################################################################################
+# Embtoolkit
+# Copyright(C) 2014 Abdoulaye Walsimou GAYE.
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+################################################################################
+#
+# \file popt.mk
+# \brief popt.mk of Embtoolkit
+# \author Abdoulaye Walsimou GAYE <awg@embtoolkit.org>
+# \date January 2014
+################################################################################
+
+POPT_NAME := popt
+POPT_VERSION := $(call embtk_get_pkgversion,popt)
+POPT_SITE := http://rpm5.org/files/popt
+POPT_PACKAGE := popt-$(POPT_VERSION).tar.gz
+POPT_SRC_DIR := $(embtk_pkgb)/popt-$(POPT_VERSION)
+POPT_BUILD_DIR := $(embtk_pkgb)/popt-$(POPT_VERSION)
+
+POPT_INCLUDES := popt.h
+POPT_LIBS := libpopt.*
+POPT_PKGCONFIGS := popt.pc