summaryrefslogtreecommitdiff
path: root/packages/development
diff options
context:
space:
mode:
authorAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2014-07-25 00:01:43 +0200
committerAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2014-07-25 00:01:43 +0200
commit7c7fb9a7de30c10c199a34e46b95517c6ecff7d9 (patch)
tree1bbd4021bfc88ef8e4d505defde2d4b0524f175f /packages/development
parentaeae0ce299f70f2acb762aa8a5c104d47ff8ed00 (diff)
downloadembtoolkit-7c7fb9a7de30c10c199a34e46b95517c6ecff7d9.tar.gz
embtoolkit-7c7fb9a7de30c10c199a34e46b95517c6ecff7d9.tar.bz2
embtoolkit-7c7fb9a7de30c10c199a34e46b95517c6ecff7d9.tar.xz
Packages: libelf: split into host/target packages
Signed-off-by: Abdoulaye Walsimou Gaye <awg@embtoolkit.org>
Diffstat (limited to 'packages/development')
-rw-r--r--packages/development/development.kconfig3
-rw-r--r--packages/development/development.mk3
-rw-r--r--packages/development/libelf/libelf.kconfig51
-rw-r--r--packages/development/libelf/libelf.mk37
4 files changed, 94 insertions, 0 deletions
diff --git a/packages/development/development.kconfig b/packages/development/development.kconfig
index 2bed20c..80c1e30 100644
--- a/packages/development/development.kconfig
+++ b/packages/development/development.kconfig
@@ -56,6 +56,9 @@ source packages/development/kyua-cli/kyua-cli.kconfig
# libbsd
source packages/development/libbsd/libbsd.kconfig
+# libelf
+source packages/development/libelf/libelf.kconfig
+
# libevent
source packages/development/libevent/libevent.kconfig
diff --git a/packages/development/development.mk b/packages/development/development.mk
index 673f7a7..89afb40 100644
--- a/packages/development/development.mk
+++ b/packages/development/development.mk
@@ -59,6 +59,9 @@ $(call embtk_include_pkg,kyua-cli)
# libbsd
$(call embtk_include_pkg,libbsd)
+# libelf
+$(call embtk_include_pkg,libelf)
+
# libevent
$(call embtk_include_pkg,libevent)
diff --git a/packages/development/libelf/libelf.kconfig b/packages/development/libelf/libelf.kconfig
new file mode 100644
index 0000000..58c443e
--- /dev/null
+++ b/packages/development/libelf/libelf.kconfig
@@ -0,0 +1,51 @@
+################################################################################
+# Embtoolkit
+# Copyright(C) 2010-2014 GAYE Abdoulaye Walsimou.
+#
+# This program is free software; you can distribute it and/or modify it
+# under the terms of the GNU General Public License
+# (Version 2 or later) published by the Free Software Foundation.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+################################################################################
+#
+# \file libelf.kconfig
+# \brief libelf.kconfig of Embtoolkit
+# \author GAYE Abdoulaye Walsimou, <walsimou@walsimou.com>
+# \date January 2010
+################################################################################
+
+config EMBTK_HAVE_LIBELF
+ bool "Have libelf"
+ help
+ libelf lets you read, modify or create ELF files in an
+ architecture-independent way. The library takes care of size and endian
+ issues, e.g. you can process a file for SPARC processors on an
+ Intel-based system.
+
+choice
+ prompt "libelf version you wish"
+ depends on EMBTK_HAVE_LIBELF
+ help
+ Here you can choose which version of libelf you want to use.
+
+ config EMBTK_LIBELF_VERSION_0_8_13
+ bool "libelf-0.8.13"
+ select EMBTK_LIBELF_NEED_PATCH
+endchoice
+
+config EMBTK_LIBELF_VERSION_STRING
+ string
+ default "0.8.13" if EMBTK_LIBELF_VERSION_0_8_13
+
+config EMBTK_LIBELF_NEED_PATCH
+ bool
+config EMBTK_LIBELF_NEED_AUTORECONF
+ bool
diff --git a/packages/development/libelf/libelf.mk b/packages/development/libelf/libelf.mk
new file mode 100644
index 0000000..bd62596
--- /dev/null
+++ b/packages/development/libelf/libelf.mk
@@ -0,0 +1,37 @@
+################################################################################
+# Embtoolkit
+# Copyright(C) 2010-2014 Abdoulaye Walsimou GAYE.
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+################################################################################
+#
+# \file libelf.mk
+# \brief libelf.mk of Embtoolkit
+# \author Abdoulaye Walsimou GAYE <awg@embtoolkit.org>
+# \date January 2010
+################################################################################
+
+LIBELF_NAME := libelf
+LIBELF_VERSION := $(call embtk_get_pkgversion,libelf)
+LIBELF_SITE := http://www.mr511.de/software
+LIBELF_PACKAGE := libelf-$(LIBELF_VERSION).tar.gz
+LIBELF_SRC_DIR := $(embtk_pkgb)/libelf-$(LIBELF_VERSION)
+LIBELF_BUILD_DIR := $(embtk_pkgb)/libelf-$(LIBELF_VERSION)
+
+LIBELF_INCLUDES := libelf gelf.h libelf.h nlist.h
+LIBELF_LIBS := libelf.a
+LIBELF_PKGCONFIGS := libelf.pc
+
+LIBELF_CONFIGURE_OPTS := --enable-elf64 --disable-nls