summaryrefslogtreecommitdiff
path: root/packages/development
diff options
context:
space:
mode:
authorRicardo Crudo <ricardo.crudo@gmail.com>2014-05-17 19:49:02 +0200
committerAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2014-05-17 19:50:01 +0200
commitd8b30ba9aa9af1b5a9d7e556112e387f50b6fe4e (patch)
treed0ac5de3168312ba41c96ce57e84935503b952c8 /packages/development
parent136ddd860cabb806fa7a442d02c784a13300f0c3 (diff)
downloadembtoolkit-d8b30ba9aa9af1b5a9d7e556112e387f50b6fe4e.tar.gz
embtoolkit-d8b30ba9aa9af1b5a9d7e556112e387f50b6fe4e.tar.bz2
embtoolkit-d8b30ba9aa9af1b5a9d7e556112e387f50b6fe4e.tar.xz
Packages/development: New icu v53.1
Signed-off-by: Ricardo Crudo <ricardo.crudo@gmail.com> Signed-off-by: Abdoulaye Walsimou Gaye <awg@embtoolkit.org>
Diffstat (limited to 'packages/development')
-rw-r--r--packages/development/development.kconfig3
-rw-r--r--packages/development/development.mk4
-rw-r--r--packages/development/icu/icu.kconfig65
-rw-r--r--packages/development/icu/icu.mk64
4 files changed, 136 insertions, 0 deletions
diff --git a/packages/development/development.kconfig b/packages/development/development.kconfig
index 205f823..fb840a4 100644
--- a/packages/development/development.kconfig
+++ b/packages/development/development.kconfig
@@ -32,6 +32,9 @@ source packages/development/fftw/fftw.kconfig
# gtest
source packages/development/gtest/gtest.kconfig
+# icu
+source packages/development/icu/icu.kconfig
+
# libbsd
source packages/development/libbsd/libbsd.kconfig
diff --git a/packages/development/development.mk b/packages/development/development.mk
index f90971a..5080938 100644
--- a/packages/development/development.mk
+++ b/packages/development/development.mk
@@ -34,6 +34,10 @@ $(call embtk_include_pkg,fftw)
# gtest
$(call embtk_include_pkg,gtest)
+# icu
+$(call embtk_include_pkg,icu)
+$(call embtk_include_hostpkg,icu_host)
+
# libbsd
$(call embtk_include_pkg,libbsd)
diff --git a/packages/development/icu/icu.kconfig b/packages/development/icu/icu.kconfig
new file mode 100644
index 0000000..d0e4374
--- /dev/null
+++ b/packages/development/icu/icu.kconfig
@@ -0,0 +1,65 @@
+################################################################################
+# Embtoolkit
+# Copyright(C) 2009-2014 Abdoulaye Walsimou GAYE.
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+################################################################################
+#
+# \file icu.kconfig
+# \brief icu.kconfig of Embtoolkit.
+# \author Ricardo Crudo <ricardo.crudo@gmail.com>
+# \date May 2014
+################################################################################
+
+config EMBTK_HOST_HAVE_ICU
+ bool
+
+config EMBTK_HAVE_ICU
+ bool "Have icu"
+ select EMBTK_HOST_HAVE_ICU
+ select EMBTK_GCC_LANGUAGE_CPP
+ select KEMBTK_UCLIBC_UCLIBC_HAS_WCHAR if EMBTK_CLIB_UCLIBC
+ help
+ ICU is a mature, widely used set of C/C++ and Java libraries providing
+ Unicode and Globalization support for software applications.
+ ICU is widely portable and gives applications the same results on all
+ platforms and between C/C++ and Java software.
+ See http://site.icu-project.org
+
+choice
+ prompt "icu version to use"
+ depends on EMBTK_HAVE_ICU || EMBTK_HOST_HAVE_ICU
+ help
+ icu version to use
+
+ config EMBTK_ICU_VERSION_53_1
+ bool "icu-53.1"
+endchoice
+
+config EMBTK_ICU_VERSION_STRING
+ string
+ default "53.1" if EMBTK_ICU_VERSION_53_1
+
+config EMBTK_ICU_NEED_PATCH
+ bool
+ select EMBTK_ICU_HOST_NEED_PATCH
+config EMBTK_ICU_NEED_AUTORECONF
+ bool
+ select EMBTK_ICU_HOST_NEED_AUTORECONF
+
+config EMBTK_ICU_HOST_NEED_PATCH
+ bool
+config EMBTK_ICU_HOST_NEED_AUTORECONF
+ bool
diff --git a/packages/development/icu/icu.mk b/packages/development/icu/icu.mk
new file mode 100644
index 0000000..7a84004
--- /dev/null
+++ b/packages/development/icu/icu.mk
@@ -0,0 +1,64 @@
+################################################################################
+# Embtoolkit
+# Copyright(C) 2009-2014 Abdoulaye Walsimou GAYE.
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+################################################################################
+#
+# \file icu.mk
+# \brief icu.mk of Embtoolkit.
+# \author Ricardo Crudo <ricardo.crudo@gmail.com>
+# \date May 2014
+################################################################################
+
+ICU_NAME := icu
+ICU_VERSION := $(call embtk_get_pkgversion,icu)
+ICU_SITE := http://download.icu-project.org/files/icu4c/$(ICU_VERSION)
+ICU_PACKAGE := icu4c-$(subst .,_,$(ICU_VERSION))-src.tgz
+ICU_SRC_DIR := $(embtk_pkgb)/icu
+ICU_BUILD_DIR := $(embtk_pkgb)/icu-$(ICU_VERSION)-build
+
+ICU_DEPS := icu_host_install
+
+ICU_BINS := derb genbrk gencfu gencnval gendict genrb icu-config icuinfo
+ICU_SBINS := genccode gencmn gennorm2 gensprep icupkg
+ICU_BINS += makeconv pkgdata
+ICU_INCLUDES += layout unicode
+ICU_LIBS := icu libicu*
+ICU_PKGCONFIGS := icu-*.pc
+ICU_SHARES := icu
+
+ICU_CONFIGURE_OPTS := --disable-extras --disable-tests --disable-samples
+ICU_CONFIGURE_OPTS += --enable-release --enable-shared --enable-static
+ICU_CONFIGURE_OPTS += --with-cross-build=$(embtk_toolsb)/icu-$(ICU_VERSION)-build
+
+ICU_CONFIGURE_DIR := source
+
+#
+# icu for host
+#
+ICU_HOST_NAME := $(ICU_NAME)
+ICU_HOST_VERSION := $(ICU_VERSION)
+ICU_HOST_SITE := $(ICU_SITE)
+ICU_HOST_PACKAGE := $(ICU_PACKAGE)
+ICU_HOST_SRC_DIR := $(embtk_toolsb)/icu
+ICU_HOST_BUILD_DIR = $(embtk_toolsb)/icu-$(ICU_VERSION)-build
+
+ICU_HOST_CONFIGURE_OPTS := --disable-extras --enable-tests=no --disable-samples
+ICU_HOST_CONFIGURE_OPTS += --enable-release
+
+ICU_HOST_KEEP_SRC_DIR := y
+ICU_HOST_CONFIGURE_DIR := $(ICU_CONFIGURE_DIR)
+ICU_HOST_SET_RPATH := y