summaryrefslogtreecommitdiff
path: root/packages/development
diff options
context:
space:
mode:
authorAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2013-11-17 15:53:25 +0100
committerAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2013-11-17 15:53:25 +0100
commite900da0e9cdedd96e15b91102a1726790ed7b315 (patch)
treedfe8e96db179718f4dc6635cb329edc707266ff7 /packages/development
parent33404e82af9900c1ec0475bcca710c4ce3e54053 (diff)
downloadembtoolkit-e900da0e9cdedd96e15b91102a1726790ed7b315.tar.gz
embtoolkit-e900da0e9cdedd96e15b91102a1726790ed7b315.tar.bz2
embtoolkit-e900da0e9cdedd96e15b91102a1726790ed7b315.tar.xz
Packages: libvent: add v2.0.21-stable
Signed-off-by: Abdoulaye Walsimou Gaye <awg@embtoolkit.org>
Diffstat (limited to 'packages/development')
-rw-r--r--packages/development/libevent/libevent.kconfig19
-rw-r--r--packages/development/libevent/libevent.mk6
2 files changed, 11 insertions, 14 deletions
diff --git a/packages/development/libevent/libevent.kconfig b/packages/development/libevent/libevent.kconfig
index fceac46..51e68a0 100644
--- a/packages/development/libevent/libevent.kconfig
+++ b/packages/development/libevent/libevent.kconfig
@@ -1,6 +1,6 @@
################################################################################
# Embtoolkit
-# Copyright(C) 2010-2011 Abdoulaye Walsimou GAYE.
+# Copyright(C) 2010-2013 Abdoulaye Walsimou GAYE.
#
# This program is free software: you can redistribute it and/or modify
# it under the terms of the GNU General Public License as published by
@@ -26,30 +26,29 @@
config EMBTK_HAVE_LIBEVENT
bool "Have libevent"
help
- The libevent API provides a mechanism to execute a callback
- function when a specific event occurs on a file descriptor or
- after a timeout has been reached. Furthermore, libevent also
- support callbacks due to signals or regular timeouts.
+ The libevent API provides a mechanism to execute a callback function
+ when a specific event occurs on a file descriptor or after a timeout
+ has been reached. Furthermore, libevent also support callbacks due to
+ signals or regular timeouts.
choice
prompt "libevent version you wish"
depends on EMBTK_HAVE_LIBEVENT
help
- Here you can choose which version of libevent you want to use.
+ Here you can choose which version of libevent you want to use.
+ config EMBTK_LIBEVENT_VERSION_2_0_21_STABLE
+ bool "libevent-2.0.21-stable"
config EMBTK_LIBEVENT_VERSION_1_4_13_STABLE
bool "libevent-1.4.13-stable"
endchoice
config EMBTK_LIBEVENT_VERSION_STRING
string
+ default "2.0.21-stable" if EMBTK_LIBEVENT_VERSION_2_0_21_STABLE
default "1.4.13-stable" if EMBTK_LIBEVENT_VERSION_1_4_13_STABLE
config EMBTK_LIBEVENT_NEED_PATCH
bool
config EMBTK_LIBEVENT_NEED_AUTORECONF
bool
-config EMBTK_LIBEVENT_PKG_IS_TARGZ
- bool
-config EMBTK_LIBEVENT_PKG_IS_TARBZ2
- bool
diff --git a/packages/development/libevent/libevent.mk b/packages/development/libevent/libevent.mk
index 8900d23..557bfe9 100644
--- a/packages/development/libevent/libevent.mk
+++ b/packages/development/libevent/libevent.mk
@@ -1,6 +1,6 @@
################################################################################
# Embtoolkit
-# Copyright(C) 2009-2011 Abdoulaye Walsimou GAYE.
+# Copyright(C) 2009-2013 Abdoulaye Walsimou GAYE.
#
# This program is free software: you can redistribute it and/or modify
# it under the terms of the GNU General Public License as published by
@@ -25,8 +25,7 @@
LIBEVENT_NAME := libevent
LIBEVENT_VERSION := $(call embtk_get_pkgversion,libevent)
-LIBEVENT_SITE := http://www.monkey.org/~provos
-LIBEVENT_SITE_MIRROR3 := ftp://ftp.embtoolkit.org/embtoolkit.org/packages-mirror
+LIBEVENT_SITE := http://github.com/downloads/libevent/libevent
LIBEVENT_PACKAGE := libevent-$(LIBEVENT_VERSION).tar.gz
LIBEVENT_SRC_DIR := $(embtk_pkgb)/libevent-$(LIBEVENT_VERSION)
LIBEVENT_BUILD_DIR := $(embtk_pkgb)/libevent-$(LIBEVENT_VERSION)
@@ -35,4 +34,3 @@ LIBEVENT_BINS = event_rpcgen.py
LIBEVENT_SBINS =
LIBEVENT_INCLUDES = evdns.h event-config.h event.h evhttp.h evrpc.h evutil.h
LIBEVENT_LIBS = libevent*
-LIBEVENT_PKGCONFIGS =