summaryrefslogtreecommitdiff
path: root/packages/graphics/atk/atk.mk
diff options
context:
space:
mode:
authorAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2010-08-22 20:05:12 +0200
committerAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2010-08-22 20:05:12 +0200
commitdbfc9fdc6085a528fc8178ff5ce9960ad8f6a5cd (patch)
treeefb0370771ebdf5143a55cd08ce09942cf213208 /packages/graphics/atk/atk.mk
parent4d4894930a92e5101a0f045dc20be4f6ccb21e1f (diff)
downloadembtoolkit-dbfc9fdc6085a528fc8178ff5ce9960ad8f6a5cd.tar.gz
embtoolkit-dbfc9fdc6085a528fc8178ff5ce9960ad8f6a5cd.tar.bz2
embtoolkit-dbfc9fdc6085a528fc8178ff5ce9960ad8f6a5cd.tar.xz
Embtk: drastically improve packages rebuild duration
Signed-off-by: Abdoulaye Walsimou Gaye <awg@embtoolkit.org>
Diffstat (limited to 'packages/graphics/atk/atk.mk')
-rw-r--r--packages/graphics/atk/atk.mk13
1 files changed, 5 insertions, 8 deletions
diff --git a/packages/graphics/atk/atk.mk b/packages/graphics/atk/atk.mk
index 9f01ee3..6d066c1 100644
--- a/packages/graphics/atk/atk.mk
+++ b/packages/graphics/atk/atk.mk
@@ -35,13 +35,9 @@ ATK_INCLUDES = atk-*
ATK_LIBS = libatk-*
ATK_PKGCONFIGS = atk.pc
-ifeq ($(CONFIG_EMBTK_64BITS_FS_COMPAT32),y)
-PKG_CONFIG_PATH=$(SYSROOT)/usr/lib32/pkgconfig
-else
-PKG_CONFIG_PATH=$(SYSROOT)/usr/lib/pkgconfig
-endif
-
-atk_install: $(ATK_BUILD_DIR)/.installed
+atk_install:
+ @test -e $(ATK_BUILD_DIR)/.installed || \
+ $(MAKE) $(ATK_BUILD_DIR)/.installed
$(ATK_BUILD_DIR)/.installed: glib_install download_atk \
$(ATK_BUILD_DIR)/.decompressed $(ATK_BUILD_DIR)/.configured
@@ -90,10 +86,11 @@ $(ATK_BUILD_DIR)/.configured:
@touch $@
atk_clean:
- $(call EMBTK_GENERIC_MESSAGE,"cleanup atk-$(ATK_VERSION)...")
+ $(call EMBTK_GENERIC_MESSAGE,"cleanup atk...")
$(Q)-cd $(SYSROOT)/usr/bin; rm -rf $(ATK_BINS)
$(Q)-cd $(SYSROOT)/usr/sbin; rm -rf $(ATK_SBINS)
$(Q)-cd $(SYSROOT)/usr/include; rm -rf $(ATK_INCLUDES)
$(Q)-cd $(SYSROOT)/usr/$(LIBDIR); rm -rf $(ATK_LIBS)
$(Q)-cd $(SYSROOT)/usr/$(LIBDIR)/pkgconfig; rm -rf $(ATK_PKGCONFIGS)
+ $(Q)-rm -rf $(ATK_BUILD_DIR)