summaryrefslogtreecommitdiff
path: root/packages/graphics/freetype
diff options
context:
space:
mode:
authorAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2010-08-22 20:05:12 +0200
committerAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2010-08-22 20:05:12 +0200
commitdbfc9fdc6085a528fc8178ff5ce9960ad8f6a5cd (patch)
treeefb0370771ebdf5143a55cd08ce09942cf213208 /packages/graphics/freetype
parent4d4894930a92e5101a0f045dc20be4f6ccb21e1f (diff)
downloadembtoolkit-dbfc9fdc6085a528fc8178ff5ce9960ad8f6a5cd.tar.gz
embtoolkit-dbfc9fdc6085a528fc8178ff5ce9960ad8f6a5cd.tar.bz2
embtoolkit-dbfc9fdc6085a528fc8178ff5ce9960ad8f6a5cd.tar.xz
Embtk: drastically improve packages rebuild duration
Signed-off-by: Abdoulaye Walsimou Gaye <awg@embtoolkit.org>
Diffstat (limited to 'packages/graphics/freetype')
-rw-r--r--packages/graphics/freetype/freetype.mk30
1 files changed, 13 insertions, 17 deletions
diff --git a/packages/graphics/freetype/freetype.mk b/packages/graphics/freetype/freetype.mk
index 83555b6..0c7611c 100644
--- a/packages/graphics/freetype/freetype.mk
+++ b/packages/graphics/freetype/freetype.mk
@@ -34,21 +34,24 @@ FREETYPE_INCLUDES = ft*build.h freetype*
FREETYPE_LIBS = libfreetype*
FREETYPE_PKGCONFIGS = freetype*.pc
-freetype_install: $(FREETYPE_BUILD_DIR)/.installed
+FREETYPE_DEPS := zlib_target_install
-$(FREETYPE_BUILD_DIR)/.installed: zlib_target_install download_freetype \
+freetype_install:
+ @test -e $(FREETYPE_BUILD_DIR)/.installed || \
+ $(MAKE) $(FREETYPE_BUILD_DIR)/.installed
+
+$(FREETYPE_BUILD_DIR)/.installed: $(FREETYPE_DEPS) download_freetype \
$(FREETYPE_BUILD_DIR)/.decompressed $(FREETYPE_BUILD_DIR)/.configured
$(call EMBTK_GENERIC_MESSAGE,"Compiling and installing \
freetype-$(FREETYPE_VERSION) in your root filesystem...")
$(call EMBTK_KILL_LT_RPATH, $(FREETYPE_BUILD_DIR))
- $(Q)$(MAKE) -C $(FREETYPE_BUILD_DIR) $(J) \
+ $(MAKE) -C $(FREETYPE_BUILD_DIR) $(J) \
LIBTOOL=$(FREETYPE_BUILD_DIR)/builds/unix/libtool
- $(Q)$(MAKE) -C $(FREETYPE_BUILD_DIR) \
+ $(MAKE) -C $(FREETYPE_BUILD_DIR) \
LIBTOOL=$(FREETYPE_BUILD_DIR)/builds/unix/libtool \
DESTDIR=$(SYSROOT) install
- $(Q)$(MAKE) libtool_files_adapt
- $(Q)$(MAKE) pkgconfig_files_adapt
- $(Q)$(MAKE) $(FREETYPE_BUILD_DIR)/.freetype-configpatched
+ $(MAKE) libtool_files_adapt
+ $(MAKE) pkgconfig_files_adapt
@touch $@
download_freetype:
@@ -60,7 +63,7 @@ download_freetype:
$(FREETYPE_BUILD_DIR)/.decompressed:
$(call EMBTK_GENERIC_MESSAGE,"Decompressing $(FREETYPE_PACKAGE) ...")
- @tar -C $(PACKAGES_BUILD) -xjvf $(DOWNLOAD_DIR)/$(FREETYPE_PACKAGE)
+ @tar -C $(PACKAGES_BUILD) -xjf $(DOWNLOAD_DIR)/$(FREETYPE_PACKAGE)
@touch $@
$(FREETYPE_BUILD_DIR)/.configured:
@@ -83,19 +86,12 @@ $(FREETYPE_BUILD_DIR)/.configured:
--prefix=/usr --enable-static=no --libdir=/usr/$(LIBDIR)
@touch $@
-$(FREETYPE_BUILD_DIR)/.freetype-configpatched:
- $(Q)cd $(ROOTFS)/usr/bin; \
- cat freetype-config | \
- sed -e 's;prefix=/usr;prefix=$(ROOTFS)/usr;' \
- -e 's;includedir=$${prefix}/include;includedir=$(SYSROOT)/usr/include;' \
- > freetype-config.new;\
- cp freetype-config.new freetype-config; rm freetype-config.new
-
freetype_clean:
- $(call EMBTK_GENERIC_MESSAGE,"cleanup freetype-$(FREETYPE_VERSION)...")
+ $(call EMBTK_GENERIC_MESSAGE,"cleanup freetype...")
$(Q)-cd $(SYSROOT)/usr/bin; rm -rf $(FREETYPE_BINS)
$(Q)-cd $(SYSROOT)/usr/sbin; rm -rf $(FREETYPE_SBINS)
$(Q)-cd $(SYSROOT)/usr/include; rm -rf $(FREETYPE_INCLUDES)
$(Q)-cd $(SYSROOT)/usr/$(LIBDIR); rm -rf $(FREETYPE_LIBS)
$(Q)-cd $(SYSROOT)/usr/$(LIBDIR)/pkgconfig; rm -rf $(FREETYPE_PKGCONFIGS)
+ $(Q)-rm -rf $(FREETYPE_BUILD_DIR)