summaryrefslogtreecommitdiff
path: root/packages/graphics/graphics.mk
diff options
context:
space:
mode:
authorAbdoulaye Walsimou Gaye <walsimou@walsimou.com>2010-02-27 10:53:35 +0100
committerAbdoulaye Walsimou Gaye <walsimou@walsimou.com>2010-02-27 10:53:35 +0100
commit3f12d2e9b4033b77732ce443984bb38604ece6bf (patch)
tree28b6d99e056aa831ce68ffa7a387b827f23c50a6 /packages/graphics/graphics.mk
parent6fdc2e10ef05d09f053dbdd85bd91265d7814335 (diff)
downloadembtoolkit-3f12d2e9b4033b77732ce443984bb38604ece6bf.tar.gz
embtoolkit-3f12d2e9b4033b77732ce443984bb38604ece6bf.tar.bz2
embtoolkit-3f12d2e9b4033b77732ce443984bb38604ece6bf.tar.xz
Packages: no need to test if a package is selected, it is tested by foo-y
Signed-off-by: Abdoulaye Walsimou Gaye <walsimou@walsimou.com>
Diffstat (limited to 'packages/graphics/graphics.mk')
-rw-r--r--packages/graphics/graphics.mk24
1 files changed, 1 insertions, 23 deletions
diff --git a/packages/graphics/graphics.mk b/packages/graphics/graphics.mk
index 97eec8d..1db79e4 100644
--- a/packages/graphics/graphics.mk
+++ b/packages/graphics/graphics.mk
@@ -25,77 +25,55 @@
#atk
include $(EMBTK_ROOT)/packages/graphics/atk/atk.mk
ROOTFS_COMPONENTS_CLEAN += atk_clean
-ifeq ($(CONFIG_EMBTK_HAVE_ATK),y)
ROOTFS_COMPONENTS-$(CONFIG_EMBTK_HAVE_ATK) += atk_install
-endif
#Cairo
include $(EMBTK_ROOT)/packages/graphics/cairo/cairo.mk
ROOTFS_COMPONENTS_CLEAN += cairo_clean
-ifeq ($(CONFIG_EMBTK_HAVE_CAIRO),y)
ROOTFS_COMPONENTS-$(CONFIG_EMBTK_HAVE_CAIRO) += cairo_install
-endif
#DirectFB
include $(EMBTK_ROOT)/packages/graphics/directfb/directfb.mk
ROOTFS_COMPONENTS_CLEAN += directfb_clean
-ifeq ($(CONFIG_EMBTK_HAVE_DIRECTFB),y)
ROOTFS_COMPONENTS-$(CONFIG_EMBTK_HAVE_DIRECTFB) += directfb_install
-endif
#fontconfig
include $(EMBTK_ROOT)/packages/graphics/fontconfig/fontconfig.mk
ROOTFS_COMPONENTS_CLEAN += fontconfig_clean
-ifeq ($(CONFIG_EMBTK_HAVE_FONTCONFIG),y)
ROOTFS_COMPONENTS-$(CONFIG_EMBTK_HAVE_FONTCONFIG) += fontconfig_install
-endif
#FreeFont
include $(EMBTK_ROOT)/packages/graphics/freefont/freefont.mk
ROOTFS_COMPONENTS_CLEAN += ttmkfdir_clean
-ifeq ($(CONFIG_EMBTK_HAVE_FREEFONT_TTF),y)
ROOTFS_COMPONENTS-$(CONFIG_EMBTK_HAVE_FREEFONT_TTF) += freefont_ttf_install
-endif
#FreeType
include $(EMBTK_ROOT)/packages/graphics/freetype/freetype.mk
ROOTFS_COMPONENTS_CLEAN += freetype_clean
-ifeq ($(CONFIG_EMBTK_HAVE_FREETYPE),y)
ROOTFS_COMPONENTS-$(CONFIG_EMBTK_HAVE_FREETYPE) += freetype_install
-endif
#gtk+
include $(EMBTK_ROOT)/packages/graphics/gtk/gtk.mk
ROOTFS_COMPONENTS_CLEAN += gtk_clean
-ifeq ($(CONFIG_EMBTK_HAVE_GTK),y)
ROOTFS_COMPONENTS-$(CONFIG_EMBTK_HAVE_GTK) += gtk_install
-endif
#libjpeg
include $(EMBTK_ROOT)/packages/graphics/libjpeg/libjpeg.mk
ROOTFS_COMPONENTS_CLEAN += libjpeg_clean
-ifeq ($(CONFIG_EMBTK_HAVE_LIBJPEG),y)
ROOTFS_COMPONENTS-$(CONFIG_EMBTK_HAVE_LIBJPEG) += libjpeg_install
-endif
#libpng
include $(EMBTK_ROOT)/packages/graphics/libpng/libpng.mk
ROOTFS_COMPONENTS_CLEAN += libpng_clean
-ifeq ($(CONFIG_EMBTK_HAVE_LIBPNG),y)
-ROOTFS_COMPONENTS-$(CONFIG_EMBTK_HAVE_LIBPNG) += libpng_clean
-endif
+ROOTFS_COMPONENTS-$(CONFIG_EMBTK_HAVE_LIBPNG) += libpng_install
#libtiff
include $(EMBTK_ROOT)/packages/graphics/libtiff/libtiff.mk
ROOTFS_COMPONENTS_CLEAN += libtiff_clean
-ifeq ($(CONFIG_EMBTK_HAVE_LIBTIFF),y)
ROOTFS_COMPONENTS-$(CONFIG_EMBTK_HAVE_LIBTIFF) += libtiff_install
-endif
#pixman
include $(EMBTK_ROOT)/packages/graphics/pixman/pixman.mk
ROOTFS_COMPONENTS_CLEAN += pixman_clean
-ifeq ($(CONFIG_EMBTK_HAVE_PIXMAN),y)
ROOTFS_COMPONENTS-$(CONFIG_EMBTK_HAVE_PIXMAN) += pixman_install
-endif