summaryrefslogtreecommitdiff
path: root/packages/htools/e2fsprogs-libuuid
diff options
context:
space:
mode:
authorAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2014-10-18 14:42:14 +0200
committerAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2014-10-18 14:42:14 +0200
commit258c21a0f9cdad543ad287c86c7de7170ac546d4 (patch)
treec1a55823ab56af30487aeaad6315422562828c48 /packages/htools/e2fsprogs-libuuid
parent6423b10b6a6fbcdbe1f7ff66a957b44b2254ccfc (diff)
downloadembtoolkit-258c21a0f9cdad543ad287c86c7de7170ac546d4.tar.gz
embtoolkit-258c21a0f9cdad543ad287c86c7de7170ac546d4.tar.bz2
embtoolkit-258c21a0f9cdad543ad287c86c7de7170ac546d4.tar.xz
Packages: e2fsprogs-libuuid: update to v1.14.12 and split it into host/target packages
Signed-off-by: Abdoulaye Walsimou Gaye <awg@embtoolkit.org>
Diffstat (limited to 'packages/htools/e2fsprogs-libuuid')
-rw-r--r--packages/htools/e2fsprogs-libuuid/e2fsprogs-libuuid.kconfig46
-rw-r--r--packages/htools/e2fsprogs-libuuid/e2fsprogs-libuuid.mk60
2 files changed, 106 insertions, 0 deletions
diff --git a/packages/htools/e2fsprogs-libuuid/e2fsprogs-libuuid.kconfig b/packages/htools/e2fsprogs-libuuid/e2fsprogs-libuuid.kconfig
new file mode 100644
index 0000000..32416a6
--- /dev/null
+++ b/packages/htools/e2fsprogs-libuuid/e2fsprogs-libuuid.kconfig
@@ -0,0 +1,46 @@
+################################################################################
+# Embtoolkit
+# Copyright(C) 2009-2014 Abdoulaye Walsimou GAYE.
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+################################################################################
+#
+# \file e2fsprogs-libuuid.kconfig
+# \brief e2fsprogs-libuuid.kconfig of Embtoolkit
+# \author Abdoulaye Walsimou GAYE <awg@embtoolkit.org>
+# \date June 2011
+################################################################################
+
+config EMBTK_HOST_HAVE_E2FSPROGS-LIBUUID
+ bool
+
+choice
+ prompt "e2fsprogs-libuuid version you wish"
+ depends on EMBTK_HOST_HAVE_E2FSPROGS-LIBUUID
+ help
+ Here you can choose which version you want to use.
+
+ config EMBTK_E2FSPROGS-LIBUUID_HOST_VERSION_1_42_12
+ bool "e2fsprogs-libuuid-1.42.12"
+endchoice
+
+config EMBTK_E2FSPROGS-LIBUUID_HOST_VERSION_STRING
+ string
+ default "1.42.12" if EMBTK_E2FSPROGS-LIBUUID_HOST_VERSION_1_42_12
+
+config EMBTK_E2FSPROGS-LIBUUID_HOST_NEED_PATCH
+ bool
+config EMBTK_E2FSPROGS-LIBUUID_HOST_NEED_AUTORECONF
+ bool
diff --git a/packages/htools/e2fsprogs-libuuid/e2fsprogs-libuuid.mk b/packages/htools/e2fsprogs-libuuid/e2fsprogs-libuuid.mk
new file mode 100644
index 0000000..3fa91d8
--- /dev/null
+++ b/packages/htools/e2fsprogs-libuuid/e2fsprogs-libuuid.mk
@@ -0,0 +1,60 @@
+################################################################################
+# Embtoolkit
+# Copyright(C) 2009-2014 Abdoulaye Walsimou GAYE.
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+################################################################################
+#
+# \file e2fsprogs.mk
+# \brief e2fsprogs.mk of Embtoolkit
+# \author Abdoulaye Walsimou GAYE <awg@embtoolkit.org>
+# \date June 2011
+################################################################################
+
+E2FSPROGS-LIBUUID_HOST_NAME := e2fsprogs-libuuid
+E2FSPROGS-LIBUUID_HOST_VERSION := $(call embtk_pkg_version,e2fsprogs-libuuid_host)
+E2FSPROGS-LIBUUID_HOST_SITE := http://sourceforge.net/projects/e2fsprogs/files/e2fsprogs/v$(E2FSPROGS-LIBUUID_HOST_VERSION)
+E2FSPROGS-LIBUUID_HOST_PACKAGE := e2fsprogs-libs-$(E2FSPROGS-LIBUUID_HOST_VERSION).tar.gz
+E2FSPROGS-LIBUUID_HOST_SRC_DIR := $(embtk_toolsb)/e2fsprogs-libs-$(E2FSPROGS-LIBUUID_HOST_VERSION)
+E2FSPROGS-LIBUUID_HOST_BUILD_DIR := $(embtk_toolsb)/e2fsprogs-libs-$(E2FSPROGS-LIBUUID_HOST_VERSION)-build
+
+E2FSPROGS-LIBUUID_HOST_MAKE_OPTS := LDCONFIG=true
+E2FSPROGS-LIBUUID_HOST_MAKE_DIRS := util lib/uuid
+
+E2FSPROGS-LIBUUID_HOST_CONFIGURE_OPTS := --disable-compression
+E2FSPROGS-LIBUUID_HOST_CONFIGURE_OPTS += --disable-htree
+ifeq ($(embtk_buildhost_os_type),bsd)
+E2FSPROGS-LIBUUID_HOST_CONFIGURE_OPTS += --disable-elf-shlibs
+E2FSPROGS-LIBUUID_HOST_CONFIGURE_OPTS += --enable-bsd-shlibs
+else
+E2FSPROGS-LIBUUID_HOST_CONFIGURE_OPTS += --enable-elf-shlibs
+E2FSPROGS-LIBUUID_HOST_CONFIGURE_OPTS += --disable-bsd-shlibs
+endif
+E2FSPROGS-LIBUUID_HOST_CONFIGURE_OPTS += --disable-profile
+E2FSPROGS-LIBUUID_HOST_CONFIGURE_OPTS += --disable-checker
+E2FSPROGS-LIBUUID_HOST_CONFIGURE_OPTS += --disable-jbd-debug
+E2FSPROGS-LIBUUID_HOST_CONFIGURE_OPTS += --disable-blkid-debug
+E2FSPROGS-LIBUUID_HOST_CONFIGURE_OPTS += --disable-testio-debug
+E2FSPROGS-LIBUUID_HOST_CONFIGURE_OPTS += --enable-libuuid
+E2FSPROGS-LIBUUID_HOST_CONFIGURE_OPTS += --enable-libblkid
+E2FSPROGS-LIBUUID_HOST_CONFIGURE_OPTS += --disable-debugfs
+E2FSPROGS-LIBUUID_HOST_CONFIGURE_OPTS += --disable-imager
+E2FSPROGS-LIBUUID_HOST_CONFIGURE_OPTS += --disable-resizer
+E2FSPROGS-LIBUUID_HOST_CONFIGURE_OPTS += --disable-fsck
+E2FSPROGS-LIBUUID_HOST_CONFIGURE_OPTS += --disable-e2initrd-helper
+E2FSPROGS-LIBUUID_HOST_CONFIGURE_OPTS += --disable-tls
+E2FSPROGS-LIBUUID_HOST_CONFIGURE_OPTS += --disable-nls
+E2FSPROGS-LIBUUID_HOST_CONFIGURE_OPTS += --disable-rpath
+E2FSPROGS-LIBUUID_HOST_CONFIGURE_OPTS += --with-included-gettext