summaryrefslogtreecommitdiff
path: root/packages/htools/gsed
diff options
context:
space:
mode:
authorAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2014-07-09 23:14:03 +0200
committerAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2014-07-09 23:14:03 +0200
commitcf45ce257cf67a282fd7b46614b49994af6f4957 (patch)
treec5ea528cfd924ad92734012f1fa031e660a3850d /packages/htools/gsed
parent795308c52496f172ca1f354a49a9def48a2d1712 (diff)
downloadembtoolkit-cf45ce257cf67a282fd7b46614b49994af6f4957.tar.gz
embtoolkit-cf45ce257cf67a282fd7b46614b49994af6f4957.tar.bz2
embtoolkit-cf45ce257cf67a282fd7b46614b49994af6f4957.tar.xz
Host tools: move gsed to htools/gsed
Signed-off-by: Abdoulaye Walsimou Gaye <awg@embtoolkit.org>
Diffstat (limited to 'packages/htools/gsed')
-rw-r--r--packages/htools/gsed/gsed.kconfig39
-rw-r--r--packages/htools/gsed/gsed.mk31
2 files changed, 70 insertions, 0 deletions
diff --git a/packages/htools/gsed/gsed.kconfig b/packages/htools/gsed/gsed.kconfig
new file mode 100644
index 0000000..585faac
--- /dev/null
+++ b/packages/htools/gsed/gsed.kconfig
@@ -0,0 +1,39 @@
+################################################################################
+# Embtoolkit
+# Copyright(C) 2013-2014 Abdoulaye Walsimou GAYE.
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+################################################################################
+#
+# \file gsed.kconfig
+# \brief gsed.kconfig of Embtoolkit.
+# \author Abdoulaye Walsimou GAYE <awg@embtoolkit.org>
+# \date March 2013
+################################################################################
+
+config EMBTK_HOST_HAVE_GSED
+ bool
+ default y if EMBTK_HOST_OSTYPE=bsd
+ help
+ gnu sed.
+
+config EMBTK_GSED_HOST_VERSION_STRING
+ string
+ default "4.2.1"
+
+config EMBTK_GSED_HOST_NEED_PATCH
+ bool
+config EMBTK_GSED_HOST_NEED_AUTORECONF
+ bool
diff --git a/packages/htools/gsed/gsed.mk b/packages/htools/gsed/gsed.mk
new file mode 100644
index 0000000..9a5e19e
--- /dev/null
+++ b/packages/htools/gsed/gsed.mk
@@ -0,0 +1,31 @@
+################################################################################
+# Embtoolkit
+# Copyright(C) 2013-2014 Abdoulaye Walsimou GAYE.
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+################################################################################
+#
+# \file gsed.mk
+# \brief gsed.mk of Embtoolkit.
+# \author Abdoulaye Walsimou GAYE <awg@embtoolkit.org>
+# \date March 2013
+################################################################################
+
+GSED_HOST_NAME := gsed
+GSED_HOST_VERSION := $(call embtk_get_pkgversion,gsed_host)
+GSED_HOST_SITE := http://ftp.gnu.org/gnu/sed
+GSED_HOST_PACKAGE := sed-$(GSED_HOST_VERSION).tar.bz2
+GSED_HOST_SRC_DIR := $(embtk_toolsb)/sed-$(GSED_HOST_VERSION)
+GSED_HOST_BUILD_DIR := $(embtk_toolsb)/sed-$(GSED_HOST_VERSION)