summaryrefslogtreecommitdiff
path: root/packages/htools/libelf
diff options
context:
space:
mode:
authorAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2014-07-25 00:01:43 +0200
committerAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2014-07-25 00:01:43 +0200
commit7c7fb9a7de30c10c199a34e46b95517c6ecff7d9 (patch)
tree1bbd4021bfc88ef8e4d505defde2d4b0524f175f /packages/htools/libelf
parentaeae0ce299f70f2acb762aa8a5c104d47ff8ed00 (diff)
downloadembtoolkit-7c7fb9a7de30c10c199a34e46b95517c6ecff7d9.tar.gz
embtoolkit-7c7fb9a7de30c10c199a34e46b95517c6ecff7d9.tar.bz2
embtoolkit-7c7fb9a7de30c10c199a34e46b95517c6ecff7d9.tar.xz
Packages: libelf: split into host/target packages
Signed-off-by: Abdoulaye Walsimou Gaye <awg@embtoolkit.org>
Diffstat (limited to 'packages/htools/libelf')
-rw-r--r--packages/htools/libelf/libelf.kconfig42
-rw-r--r--packages/htools/libelf/libelf.mk37
2 files changed, 79 insertions, 0 deletions
diff --git a/packages/htools/libelf/libelf.kconfig b/packages/htools/libelf/libelf.kconfig
new file mode 100644
index 0000000..4f2acac
--- /dev/null
+++ b/packages/htools/libelf/libelf.kconfig
@@ -0,0 +1,42 @@
+################################################################################
+# Embtoolkit
+# Copyright(C) 2010-2014 GAYE Abdoulaye Walsimou.
+#
+# This program is free software; you can distribute it and/or modify it
+# under the terms of the GNU General Public License
+# (Version 2 or later) published by the Free Software Foundation.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+################################################################################
+#
+# \file libelf.kconfig
+# \brief libelf.kconfig of Embtoolkit
+# \author GAYE Abdoulaye Walsimou, <walsimou@walsimou.com>
+# \date January 2010
+################################################################################
+
+config EMBTK_HOST_HAVE_LIBELF
+ bool
+ select EMBTK_LIBELF_HOST_NEED_PATCH
+ help
+ libelf lets you read, modify or create ELF files in an
+ architecture-independent way. The library takes care of size and
+ endian issues, e.g. you can process a file for SPARC processors on an
+ Intel-based system.
+
+config EMBTK_LIBELF_HOST_VERSION_STRING
+ string
+ depends on EMBTK_HOST_HAVE_LIBELF
+ default "0.8.13"
+
+config EMBTK_LIBELF_HOST_NEED_PATCH
+ bool
+config EMBTK_LIBELF_HOST_NEED_AUTORECONF
+ bool
diff --git a/packages/htools/libelf/libelf.mk b/packages/htools/libelf/libelf.mk
new file mode 100644
index 0000000..c280a02
--- /dev/null
+++ b/packages/htools/libelf/libelf.mk
@@ -0,0 +1,37 @@
+################################################################################
+# Embtoolkit
+# Copyright(C) 2010-2014 Abdoulaye Walsimou GAYE.
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+################################################################################
+#
+# \file libelf.mk
+# \brief libelf.mk of Embtoolkit
+# \author Abdoulaye Walsimou GAYE <awg@embtoolkit.org>
+# \date January 2010
+################################################################################
+
+LIBELF_HOST_NAME := libelf
+LIBELF_HOST_VERSION := $(call embtk_get_pkgversion,libelf)
+LIBELF_HOST_SITE := http://www.mr511.de/software
+LIBELF_HOST_PACKAGE := libelf-$(LIBELF_HOST_VERSION).tar.gz
+LIBELF_HOST_SRC_DIR := $(embtk_toolsb)/libelf-$(LIBELF_HOST_VERSION)
+LIBELF_HOST_BUILD_DIR := $(embtk_toolsb)/libelf-$(LIBELF_HOST_VERSION)
+
+LIBELF_HOST_INCLUDES := libelf gelf.h libelf.h nlist.h
+LIBELF_HOST_LIBS := libelf.a
+LIBELF_HOST_PKGCONFIGS := libelf.pc
+
+LIBELF_HOST_CONFIGURE_OPTS := --enable-elf64 --disable-nls