summaryrefslogtreecommitdiff
path: root/packages/htools
diff options
context:
space:
mode:
authorAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2014-05-20 08:18:18 +0200
committerAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2014-05-20 08:18:18 +0200
commite5a6a3844fa5cca3f88629878684f06b9e297e24 (patch)
treea436ef0771772193a78b937a9f94a0306ccf93b5 /packages/htools
parent0c5e88be4e64203e8fa00ec8af9a22a1bc805a2a (diff)
downloadembtoolkit-e5a6a3844fa5cca3f88629878684f06b9e297e24.tar.gz
embtoolkit-e5a6a3844fa5cca3f88629878684f06b9e297e24.tar.bz2
embtoolkit-e5a6a3844fa5cca3f88629878684f06b9e297e24.tar.xz
Packages: host tools: remove waf as it will likely have no use for waf'ed packages
Signed-off-by: Abdoulaye Walsimou Gaye <awg@embtoolkit.org>
Diffstat (limited to 'packages/htools')
-rw-r--r--packages/htools/hosttools-buildopts.kconfig5
-rw-r--r--packages/htools/hosttools-buildopts.mk4
-rw-r--r--packages/htools/waf/vars.mk1
-rw-r--r--packages/htools/waf/waf.kconfig31
-rw-r--r--packages/htools/waf/waf.mk48
5 files changed, 0 insertions, 89 deletions
diff --git a/packages/htools/hosttools-buildopts.kconfig b/packages/htools/hosttools-buildopts.kconfig
index 55194b5..5dac98a 100644
--- a/packages/htools/hosttools-buildopts.kconfig
+++ b/packages/htools/hosttools-buildopts.kconfig
@@ -143,11 +143,6 @@ source packages/htools/fakeroot/fakeroot.kconfig
source packages/misc/libelf/libelf.kconfig
#
-# waf host tool
-#
-source packages/htools/waf/waf.kconfig
-
-#
# zlib for host
#
source packages/htools/zlib/zlib.kconfig
diff --git a/packages/htools/hosttools-buildopts.mk b/packages/htools/hosttools-buildopts.mk
index 4e20bdb..cb66b4c 100644
--- a/packages/htools/hosttools-buildopts.mk
+++ b/packages/htools/hosttools-buildopts.mk
@@ -42,10 +42,6 @@ $(call embtk_include_hostpkg,pkgconf_host)
# squashfs
$(call embtk_include_hostpkg,squashfs_host)
-# waf
-include packages/htools/waf/vars.mk
-$(call embtk_include_hostpkg,waf_host)
-
# zlib
$(call embtk_include_hostpkg,zlib_host)
diff --git a/packages/htools/waf/vars.mk b/packages/htools/waf/vars.mk
deleted file mode 100644
index 9c35d61..0000000
--- a/packages/htools/waf/vars.mk
+++ /dev/null
@@ -1 +0,0 @@
-embtk_waf := $(embtk_htools)/usr/bin/waf
diff --git a/packages/htools/waf/waf.kconfig b/packages/htools/waf/waf.kconfig
deleted file mode 100644
index debdac7..0000000
--- a/packages/htools/waf/waf.kconfig
+++ /dev/null
@@ -1,31 +0,0 @@
-################################################################################
-# Embtoolkit
-# Copyright(C) 2014 Abdoulaye Walsimou GAYE.
-#
-# This program is free software: you can redistribute it and/or modify
-# it under the terms of the GNU General Public License as published by
-# the Free Software Foundation, either version 2 of the License, or
-# (at your option) any later version.
-#
-# This program is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-# GNU General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License
-# along with this program. If not, see <http://www.gnu.org/licenses/>.
-#
-################################################################################
-#
-# \file waf.kconfig
-# \brief waf.kconfig of Embtoolkit
-# \author Abdoulaye Walsimou GAYE <awg@embtoolkit.org>
-# \date May 2014
-################################################################################
-
-config EMBTK_HOST_HAVE_WAF
- bool
-
-config EMBTK_WAF_HOST_VERSION_STRING
- string
- default "1.7.16"
diff --git a/packages/htools/waf/waf.mk b/packages/htools/waf/waf.mk
deleted file mode 100644
index bd92d1f..0000000
--- a/packages/htools/waf/waf.mk
+++ /dev/null
@@ -1,48 +0,0 @@
-################################################################################
-# Embtoolkit
-# Copyright(C) 2014 Abdoulaye Walsimou GAYE.
-#
-# This program is free software: you can redistribute it and/or modify
-# it under the terms of the GNU General Public License as published by
-# the Free Software Foundation, either version 2 of the License, or
-# (at your option) any later version.
-#
-# This program is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-# GNU General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License
-# along with this program. If not, see <http://www.gnu.org/licenses/>.
-#
-################################################################################
-#
-# \file waf.mk
-# \brief waf.mk of Embtoolkit
-# \author Abdoulaye Walsimou GAYE <awg@embtoolkit.org>
-# \date May 2014
-################################################################################
-
-WAF_HOST_NAME := waf
-WAF_HOST_VERSION := $(call embtk_get_pkgversion,waf_host)
-WAF_HOST_SITE := http://ftp.waf.io/pub/release
-WAF_HOST_PACKAGE := waf-$(WAF_HOST_VERSION)
-WAF_HOST_SRC_DIR := $(embtk_toolsb)/waf-$(WAF_HOST_VERSION)
-WAF_HOST_BUILD_DIR := $(embtk_toolsb)/waf-$(WAF_HOST_VERSION)
-
-define embtk_download_waf_host
- [ -e $(embtk_dldir)/$(WAF_HOST_PACKAGE) ] || \
- $(call embtk_wget,$(WAF_HOST_PACKAGE),$(WAF_HOST_SITE))
-endef
-
-define embtk_install_waf_host
- $(embtk_download_waf_host)
- [ -e $(embtk_waf) ] || $(embtk_postinstallonce_waf_host)
-endef
-
-define embtk_postinstallonce_waf_host
- install -D -m 0755 $(embtk_dldir)/$(WAF_HOST_PACKAGE) $(embtk_waf)
-endef
-
-download_waf_host waf_host_download:
- $(embtk_download_waf_host)