summaryrefslogtreecommitdiff
path: root/packages/misc/foo/foo-autotools.mk
diff options
context:
space:
mode:
authorAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2011-02-27 22:53:30 +0100
committerAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2011-02-27 22:53:30 +0100
commit7341a2218dc7afe0c7709359304d85383578e87a (patch)
tree5efa78d28b58d2b67bb2bb8038d4020950dd688c /packages/misc/foo/foo-autotools.mk
parentba1a4b891a5b93d7223abc3ea6de1d1c48b8b4df (diff)
downloadembtoolkit-7341a2218dc7afe0c7709359304d85383578e87a.tar.gz
embtoolkit-7341a2218dc7afe0c7709359304d85383578e87a.tar.bz2
embtoolkit-7341a2218dc7afe0c7709359304d85383578e87a.tar.xz
Packages: foo dummy package is autotools centric
Signed-off-by: Abdoulaye Walsimou Gaye <awg@embtoolkit.org>
Diffstat (limited to 'packages/misc/foo/foo-autotools.mk')
-rw-r--r--packages/misc/foo/foo-autotools.mk54
1 files changed, 54 insertions, 0 deletions
diff --git a/packages/misc/foo/foo-autotools.mk b/packages/misc/foo/foo-autotools.mk
new file mode 100644
index 0000000..67df0bd
--- /dev/null
+++ b/packages/misc/foo/foo-autotools.mk
@@ -0,0 +1,54 @@
+################################################################################
+# Embtoolkit
+# Copyright(C) 2009-2011 Abdoulaye Walsimou GAYE. All rights reserved.
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+################################################################################
+#
+# \file foo.mk
+# \brief foo.mk of Embtoolkit
+# \author Abdoulaye Walsimou GAYE <awg@embtoolkit.org>
+# \date December 2009
+################################################################################
+
+FOO_NAME := foo
+FOO_VERSION := $(call EMBTK_GET_PKG_VERSION,FOO)
+FOO_SITE := http://www.foo.org/download
+FOO_SITE_MIRROR3 := ftp://ftp.embtoolkit.org/embtoolkit.org/packages-mirror
+FOO_PATCH_SITE := ftp://ftp.embtoolkit.org/embtoolkit.org/foo/$(FOO_VERSION)
+FOO_PACKAGE := foo-$(FOO_VERSION).tar.gz
+FOO_SRC_DIR := $(PACKAGES_BUILD)/foo-$(FOO_VERSION)
+FOO_BUILD_DIR := $(PACKAGES_BUILD)/foo-$(FOO_VERSION)
+
+FOO_BINS =
+FOO_SBINS =
+FOO_INCLUDES =
+FOO_LIBS =
+FOO_LIBEXECS =
+FOO_PKGCONFIGS =
+
+FOO_CONFIGURE_ENV :=
+FOO_CONFIGURE_OPTS :=
+
+FOO_DEPS :=
+
+foo_install:
+ $(call EMBTK_INSTALL_PKG,FOO)
+
+download_foo:
+ $(call EMBTK_DOWNLOAD_PKG,FOO)
+
+foo_clean:
+ $(call EMBTK_CLEANUP_PKG,FOO)