summaryrefslogtreecommitdiff
path: root/packages/misc/gettext
diff options
context:
space:
mode:
authorAbdoulaye Walsimou Gaye <walsimou@walsimou.com>2009-12-28 21:21:11 +0100
committerAbdoulaye Walsimou Gaye <walsimou@walsimou.com>2009-12-28 21:21:11 +0100
commitec3017917cdc497895c86dbf5849391544a6bf42 (patch)
treed317a5fc2c0da61af97dc6db7e9f5dd76cfdba7f /packages/misc/gettext
parent98e96e173c206b95306d2a8b0a1fdedbc1a441f2 (diff)
downloadembtoolkit-ec3017917cdc497895c86dbf5849391544a6bf42.tar.gz
embtoolkit-ec3017917cdc497895c86dbf5849391544a6bf42.tar.bz2
embtoolkit-ec3017917cdc497895c86dbf5849391544a6bf42.tar.xz
Packages: use KILL_LT_RPATH macro for serval packages
Signed-off-by: Abdoulaye Walsimou Gaye <walsimou@walsimou.com>
Diffstat (limited to 'packages/misc/gettext')
-rw-r--r--packages/misc/gettext/gettext.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/packages/misc/gettext/gettext.mk b/packages/misc/gettext/gettext.mk
index e6c2707..3452724 100644
--- a/packages/misc/gettext/gettext.mk
+++ b/packages/misc/gettext/gettext.mk
@@ -42,6 +42,7 @@ $(GETTEXT_BUILD_DIR)/.installed: termcap_target_install download_gettext \
$(GETTEXT_BUILD_DIR)/.decompressed $(GETTEXT_BUILD_DIR)/.configured
$(call EMBTK_GENERIC_MESSAGE,"Compiling and installing \
gettext-$(GETTEXT_VERSION) in your root filesystem...")
+ $(call KILL_LT_RPATH, $(GETTEXT_BUILD_DIR))
$(Q)$(MAKE) -C $(GETTEXT_BUILD_DIR) $(J)
$(Q)$(MAKE) -C $(GETTEXT_BUILD_DIR) install
@touch $@
@@ -67,9 +68,8 @@ $(GETTEXT_BUILD_DIR)/.configured:
CPPFLGAS="-I$(SYSROOT)/usr/include" \
gl_cv_func_wcwidth_works=yes \
am_cv_func_iconv_works=yes \
- gl_cv_func_wcwidth_works=yes \
gt_cv_func_printf_posix=yes \
- gt_cv_int_divbyzero_sigfpe=yes \
+ gt_cv_int_divbyzero_sigfpe=no \
./configure --build=$(HOST_BUILD) --host=$(STRICT_GNU_TARGET) \
--target=$(STRICT_GNU_TARGET) \
--prefix=$(SYSROOT)/usr --with-included-gettext --disable-rpath