summaryrefslogtreecommitdiff
path: root/packages/misc/misc.mk
diff options
context:
space:
mode:
authorAbdoulaye Walsimou Gaye <walsimou@walsimou.com>2010-02-27 10:53:35 +0100
committerAbdoulaye Walsimou Gaye <walsimou@walsimou.com>2010-02-27 10:53:35 +0100
commit3f12d2e9b4033b77732ce443984bb38604ece6bf (patch)
tree28b6d99e056aa831ce68ffa7a387b827f23c50a6 /packages/misc/misc.mk
parent6fdc2e10ef05d09f053dbdd85bd91265d7814335 (diff)
downloadembtoolkit-3f12d2e9b4033b77732ce443984bb38604ece6bf.tar.gz
embtoolkit-3f12d2e9b4033b77732ce443984bb38604ece6bf.tar.bz2
embtoolkit-3f12d2e9b4033b77732ce443984bb38604ece6bf.tar.xz
Packages: no need to test if a package is selected, it is tested by foo-y
Signed-off-by: Abdoulaye Walsimou Gaye <walsimou@walsimou.com>
Diffstat (limited to 'packages/misc/misc.mk')
-rw-r--r--packages/misc/misc.mk12
1 files changed, 0 insertions, 12 deletions
diff --git a/packages/misc/misc.mk b/packages/misc/misc.mk
index 528ab58..9a46670 100644
--- a/packages/misc/misc.mk
+++ b/packages/misc/misc.mk
@@ -25,42 +25,30 @@
#gettext
include $(EMBTK_ROOT)/packages/misc/gettext/gettext.mk
ROOTFS_COMPONENTS_CLEAN += gettext_clean
-ifeq ($(CONFIG_EMBTK_HAVE_GETTEXT),y)
ROOTFS_COMPONENTS-$(CONFIG_EMBTK_HAVE_GETTEXT) += gettext_install
-endif
#GLib
include $(EMBTK_ROOT)/packages/misc/glib/glib.mk
ROOTFS_COMPONENTS_CLEAN += glib_clean
-ifeq ($(CONFIG_EMBTK_HAVE_GLIB),y)
ROOTFS_COMPONENTS-$(CONFIG_EMBTK_HAVE_GLIB) += glib_install
-endif
#libelf
include $(EMBTK_ROOT)/packages/misc/libelf/libelf.mk
ROOTFS_COMPONENTS_CLEAN += libelf_clean
-ifeq ($(CONFIG_EMBTK_HAVE_LIBELF),y)
ROOTFS_COMPONENTS-$(CONFIG_EMBTK_HAVE_LIBELF) += libelf_install
-endif
#libxml2
include $(EMBTK_ROOT)/packages/misc/libxml/libxml.mk
ROOTFS_COMPONENTS_CLEAN += libxml2_clean
-ifeq ($(CONFIG_EMBTK_HAVE_LIBXML2),y)
ROOTFS_COMPONENTS-$(CONFIG_EMBTK_HAVE_LIBXML2) += libxml2_install
-endif
#ncurses
include $(EMBTK_ROOT)/packages/misc/ncurses/ncurses.mk
ROOTFS_COMPONENTS_CLEAN += ncurses_clean
-ifeq ($(CONFIG_EMBTK_HAVE_NCURSES),y)
ROOTFS_COMPONENTS-$(CONFIG_EMBTK_HAVE_NCURSES) += ncurses_install
-endif
#Pango
include $(EMBTK_ROOT)/packages/misc/pango/pango.mk
ROOTFS_COMPONENTS_CLEAN += pango_clean
-ifeq ($(CONFIG_EMBTK_HAVE_PANGO),y)
ROOTFS_COMPONENTS-$(CONFIG_EMBTK_HAVE_PANGO) += pango_install
-endif