summaryrefslogtreecommitdiff
path: root/packages/misc/tslib/tslib.mk
diff options
context:
space:
mode:
authorAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2011-08-28 15:37:49 +0200
committerAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2011-08-28 15:37:49 +0200
commit305b54a1a103f33f552c9693fbe1a0b801855c9c (patch)
tree59dc9be69d2b1d16649272efc2dcc5bc8c71ffd3 /packages/misc/tslib/tslib.mk
parent53b4522531e73e8546592ed5713d6933f35fd6c0 (diff)
downloadembtoolkit-305b54a1a103f33f552c9693fbe1a0b801855c9c.tar.gz
embtoolkit-305b54a1a103f33f552c9693fbe1a0b801855c9c.tar.bz2
embtoolkit-305b54a1a103f33f552c9693fbe1a0b801855c9c.tar.xz
Packages: massively convert to use generic macros and implicit rules
Signed-off-by: Abdoulaye Walsimou Gaye <awg@embtoolkit.org>
Diffstat (limited to 'packages/misc/tslib/tslib.mk')
-rw-r--r--packages/misc/tslib/tslib.mk19
1 files changed, 3 insertions, 16 deletions
diff --git a/packages/misc/tslib/tslib.mk b/packages/misc/tslib/tslib.mk
index 970a89b..b8727ad 100644
--- a/packages/misc/tslib/tslib.mk
+++ b/packages/misc/tslib/tslib.mk
@@ -24,10 +24,9 @@
################################################################################
TSLIB_NAME := tslib
-TSLIB_VERSION := $(call embtk_get_pkgversion,TSLIB)
+TSLIB_VERSION := $(call embtk_get_pkgversion,tslib)
TSLIB_SITE := http://download.berlios.de/tslib
TSLIB_SITE_MIRROR3 := ftp://ftp.embtoolkit.org/embtoolkit.org/packages-mirror
-TSLIB_PATCH_SITE := ftp://ftp.embtoolkit.org/embtoolkit.org/tslib/$(TSLIB_VERSION)
TSLIB_PACKAGE := tslib-$(TSLIB_VERSION).tar.bz2
TSLIB_SRC_DIR := $(PACKAGES_BUILD)/tslib-$(TSLIB_VERSION)
TSLIB_BUILD_DIR := $(PACKAGES_BUILD)/tslib-$(TSLIB_VERSION)
@@ -40,18 +39,6 @@ TSLIB_PKGCONFIGS = tslib*.pc
TSLIB_DEPS =
-tslib_install:
- $(call embtk_install_pkg,TSLIB)
- $(Q)$(MAKE) $(TSLIB_BUILD_DIR)/.special
-
-download_tslib:
- $(call embtk_download_pkg,TSLIB)
-
-tslib_clean:
- $(call embtk_cleanup_pkg,TSLIB)
-
-.PHONY: $(TSLIB_BUILD_DIR)/.special
-
-$(TSLIB_BUILD_DIR)/.special:
+define embtk_postinstall_tslib
$(Q)-cp -R $(SYSROOT)/usr/$(LIBDIR)/ts $(ROOTFS)/usr/$(LIBDIR)/
- @touch $@
+endef