summaryrefslogtreecommitdiff
path: root/packages/misc
diff options
context:
space:
mode:
authorAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2014-05-22 21:35:59 +0200
committerAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2014-05-22 21:35:59 +0200
commit1340537107aef67bcecf7cfaad916b6a05769075 (patch)
treea566186e14ccd8778f95bea740bc2f6bd0c01f94 /packages/misc
parenta70a47b1ca31729e69c54c6d10c3b644a46ed007 (diff)
downloadembtoolkit-1340537107aef67bcecf7cfaad916b6a05769075.tar.gz
embtoolkit-1340537107aef67bcecf7cfaad916b6a05769075.tar.bz2
embtoolkit-1340537107aef67bcecf7cfaad916b6a05769075.tar.xz
Packages: drop gettext package in favor of gettext-intl (which is what is really needed)
Signed-off-by: Abdoulaye Walsimou Gaye <awg@embtoolkit.org>
Diffstat (limited to 'packages/misc')
-rw-r--r--packages/misc/gettext/gettext.kconfig52
-rw-r--r--packages/misc/gettext/gettext.mk75
-rw-r--r--packages/misc/glib/glib.kconfig36
-rw-r--r--packages/misc/glib/glib.mk2
-rw-r--r--packages/misc/misc.mk1
5 files changed, 31 insertions, 135 deletions
diff --git a/packages/misc/gettext/gettext.kconfig b/packages/misc/gettext/gettext.kconfig
index 36b015f..8ae773a 100644
--- a/packages/misc/gettext/gettext.kconfig
+++ b/packages/misc/gettext/gettext.kconfig
@@ -28,57 +28,9 @@ config EMBTK_HOST_HAVE_GETTEXT
help
gettext for host development machine.
-config EMBTK_HAVE_GETTEXT
- bool "Have gettext"
- select EMBTK_HAVE_NCURSES
- select EMBTK_HAVE_LIBXML2
- select KEMBTK_EGLIBC_OPTION_POSIX_C_LANG_WIDE_CHAR if EMBTK_CLIB_EGLIBC
- select KEMBTK_EGLIBC_OPTION_POSIX_WIDE_CHAR_DEVICE_IO if EMBTK_CLIB_EGLIBC
- select KEMBTK_EGLIBC_OPTION_EGLIBC_LOCALE_CODE if EMBTK_CLIB_EGLIBC
- select KEMBTK_UCLIBC_UCLIBC_HAS_WCHAR if EMBTK_CLIB_UCLIBC
- select KEMBTK_UCLIBC_UCLIBC_HAS_LOCALE if EMBTK_CLIB_UCLIBC
- select KEMBTK_UCLIBC_UCLIBC_SUSV4_LEGACY if EMBTK_CLIB_UCLIBC
- help
- GNU `gettext' is an important step for the GNU Translation
- Project, as it is an asset on which we may build many other
- steps. This package offers to programmers, translators, and even
- users, a well integrated set of tools and documentation.
- Specifically, the GNU `gettext' utilities are a set of tools
- that provides a framework to help other GNU packages produce
- multi-lingual messages. These tools include a set of conventions
- about how programs should be written to support message
- catalogs, a directory and file naming organization for the
- message catalogs themselves, a runtime library supporting the
- retrieval of translated messages, and a few stand-alone programs
- to massage in various ways the sets of translatable strings, or
- already translated strings. A special GNU Emacs mode also helps
- interested parties in preparing these sets, or bringing them up
- to date.
- Online Manual is available at:
- www.gnu.org/software/gettext/manual/gettext.html
- The Frequently Asked Questions and their answers are at:
- www.gnu.org/software/gettext/FAQ.html
-
-choice
- prompt "gettext version you wish"
- depends on EMBTK_HAVE_GETTEXT || EMBTK_HOST_HAVE_GETTEXT
- help
- Here you can choose which version of gettext you want to use.
-
- config EMBTK_GETTEXT_VERSION_0_18_3_2
- bool "gettext-0.18.3.2"
-endchoice
-
-config EMBTK_GETTEXT_VERSION_STRING
+config EMBTK_GETTEXT_HOST_VERSION_STRING
string
- default "0.18.3.2" if EMBTK_GETTEXT_VERSION_0_18_3_2
-
-config EMBTK_GETTEXT_NEED_PATCH
- bool
- select EMBTK_GETTEXT_HOST_NEED_PATCH
-config EMBTK_GETTEXT_NEED_AUTORECONF
- bool
- select EMBTK_GETTEXT_HOST_NEED_AUTORECONF
+ default "0.18.3.2"
config EMBTK_GETTEXT_HOST_NEED_PATCH
bool
diff --git a/packages/misc/gettext/gettext.mk b/packages/misc/gettext/gettext.mk
index 126c884..264072b 100644
--- a/packages/misc/gettext/gettext.mk
+++ b/packages/misc/gettext/gettext.mk
@@ -23,64 +23,17 @@
# \date December 2009
################################################################################
-GETTEXT_NAME := gettext
-GETTEXT_VERSION := $(call embtk_get_pkgversion,gettext)
-GETTEXT_SITE := http://ftp.gnu.org/pub/gnu/gettext
-GETTEXT_SITE_MIRROR3 := ftp://ftp.embtoolkit.org/embtoolkit.org/packages-mirror
-GETTEXT_PACKAGE := gettext-$(GETTEXT_VERSION).tar.gz
-GETTEXT_SRC_DIR := $(embtk_pkgb)/gettext-$(GETTEXT_VERSION)
-GETTEXT_BUILD_DIR := $(embtk_pkgb)/gettext-$(GETTEXT_VERSION)
-
-# gettext for target
-GETTEXT_BINS = autopoint gettext gettext.sh msgcat msgcomm msgen \
- msgfilter msggrep msgmerge msguniq recode-sr-latin \
- envsubst gettextize msgattrib msgcmp msgconv msgexec \
- msgfmt msginit msgunfmt ngettext xgettext
-
-GETTEXT_INCLUDES = autosprintf.h gettext-po.h libintl.h
-GETTEXT_LIBS = gettext libgettext* libasprintf* libintl*
-GETTEXT_PKGCONFIGS =
-
-GETTEXT_CONFIGURE_ENV := gl_cv_func_wcwidth_works=yes \
- am_cv_func_iconv_works=yes \
- gt_cv_func_printf_posix=yes \
- gt_cv_int_divbyzero_sigfpe=no
-GETTEXT_CONFIGURE_OPTS := --enable-relocatable --with-included-gettext \
- --disable-rpath --disable-openmp --disable-java \
- --with-libxml2-prefix=$(embtk_sysroot)/usr \
- --disable-openmp --disable-csharp \
- --without-emacs
-
-GETTEXT_DEPS := ncurses_install libxml2_install
-
-define embtk_postinstallonce_gettext
- $(MAKE) $(GETTEXT_BUILD_DIR)/.patchlibtool
-endef
-
-#FIXME: this should be fixed in gettext project
-$(GETTEXT_BUILD_DIR)/.patchlibtool:
- $(Q)sed \
- -i "s;/usr/$(LIBDIR)/libintl.la;$(embtk_sysroot)/$(LIBDIR)/libintl.la;" \
- $(embtk_sysroot)/usr/$(LIBDIR)/libgettextlib.la \
- $(embtk_sysroot)/usr/$(LIBDIR)/libgettextpo.la \
- $(embtk_sysroot)/usr/$(LIBDIR)/libgettextsrc.la
- $(Q)sed \
- -i "s;/usr/$(LIBDIR)/libgettextlib.la;$(embtk_sysroot)/$(LIBDIR)/libgettextlib.la;" \
- $(embtk_sysroot)/usr/$(LIBDIR)/libgettextsrc.la
-
-# gettext for host development machine
-GETTEXT_HOST_NAME := $(GETTEXT_NAME)
-GETTEXT_HOST_VERSION := $(GETTEXT_VERSION)
-GETTEXT_HOST_SITE := $(GETTEXT_SITE)
-GETTEXT_HOST_SITE_MIRROR1 := $(GETTEXT_SITE_MIRROR1)
-GETTEXT_HOST_SITE_MIRROR2 := $(GETTEXT_SITE_MIRROR2)
-GETTEXT_HOST_SITE_MIRROR3 := $(GETTEXT_SITE_MIRROR3)
-GETTEXT_HOST_PATCH_SITE := $(GETTEXT_PATCH_SITE)
-GETTEXT_HOST_PACKAGE := $(GETTEXT_PACKAGE)
-GETTEXT_HOST_SRC_DIR := $(embtk_toolsb)/gettext-$(GETTEXT_VERSION)
-GETTEXT_HOST_BUILD_DIR := $(embtk_toolsb)/gettext-$(GETTEXT_VERSION)
-
-GETTEXT_HOST_CONFIGURE_OPTS := --disable-java --disable-native-java \
- --disable-openmp --with-included-gettext --with-included-glib \
- --with-included-libcroco --with-included-libxml
-
+GETTEXT_HOST_NAME := gettext
+GETTEXT_HOST_VERSION := $(call embtk_get_pkgversion,gettext_host)
+GETTEXT_HOST_SITE := http://ftp.gnu.org/pub/gnu/gettext
+GETTEXT_HOST_PACKAGE := gettext-$(GETTEXT_HOST_VERSION).tar.gz
+GETTEXT_HOST_SRC_DIR := $(embtk_toolsb)/gettext-$(GETTEXT_HOST_VERSION)
+GETTEXT_HOST_BUILD_DIR := $(embtk_toolsb)/gettext-$(GETTEXT_HOST_VERSION)
+
+GETTEXT_HOST_CONFIGURE_OPTS := --disable-java
+GETTEXT_HOST_CONFIGURE_OPTS += --disable-native-java
+GETTEXT_HOST_CONFIGURE_OPTS += --disable-openmp
+GETTEXT_HOST_CONFIGURE_OPTS += --with-included-gettext
+GETTEXT_HOST_CONFIGURE_OPTS += --with-included-glib
+GETTEXT_HOST_CONFIGURE_OPTS += --with-included-libcroco
+GETTEXT_HOST_CONFIGURE_OPTS += --with-included-libxml
diff --git a/packages/misc/glib/glib.kconfig b/packages/misc/glib/glib.kconfig
index 674ff23..55b2e1d 100644
--- a/packages/misc/glib/glib.kconfig
+++ b/packages/misc/glib/glib.kconfig
@@ -1,6 +1,6 @@
################################################################################
# Embtoolkit
-# Copyright(C) 2009-2011 Abdoulaye Walsimou GAYE.
+# Copyright(C) 2009-2014 Abdoulaye Walsimou GAYE.
#
# This program is free software: you can redistribute it and/or modify
# it under the terms of the GNU General Public License as published by
@@ -32,7 +32,7 @@ config EMBTK_HOST_HAVE_GLIB
config EMBTK_HAVE_GLIB
bool "Have GLib"
select EMBTK_HOST_HAVE_GLIB
- select EMBTK_HAVE_GETTEXT
+ select EMBTK_HAVE_GETTEXT-INTL
select EMBTK_HAVE_ZLIB
select KEMBTK_UCLIBC_DO_C99_MATH if EMBTK_CLIB_UCLIBC
select KEMBTK_EGLIBC_OPTION_EGLIBC_INET if EMBTK_CLIB_EGLIBC
@@ -41,22 +41,22 @@ config EMBTK_HAVE_GLIB
select KEMBTK_UCLIBC_UCLIBC_HAS_IPV6 if EMBTK_CLIB_UCLIBC
select KEMBTK_UCLIBC_UCLIBC_HAS_LIBRESOLV_STUB if EMBTK_UCLIBC_VERSION_SERIES_0_9_31_X
help
- GLib is a general-purpose utility library, which provides many
- useful data types, macros, type conversions, string utilities,
- file utilities, a main loop abstraction, and so on. It works on
- many UNIX-like platforms, Windows, OS/2 and BeOS. GLib is
- released under the GNU Library General Public License
- (GNU LGPL).
- The general policy of GLib is that all functions are invisibly
- threadsafe with the exception of data structure manipulation
- functions, where, if you have two threads manipulating the same
- data structure, they must use a lock to synchronize their
- operation.
+ GLib is a general-purpose utility library, which provides many
+ useful data types, macros, type conversions, string utilities,
+ file utilities, a main loop abstraction, and so on. It works on
+ many UNIX-like platforms, Windows, OS/2 and BeOS. GLib is
+ released under the GNU Library General Public License
+ (GNU LGPL).
+ The general policy of GLib is that all functions are invisibly
+ threadsafe with the exception of data structure manipulation
+ functions, where, if you have two threads manipulating the same
+ data structure, they must use a lock to synchronize their
+ operation.
choice
prompt "GLib version you wish"
depends on EMBTK_HAVE_GLIB || EMBTK_HOST_HAVE_GLIB
help
- Here you can choose which version of GLib you want to use.
+ Here you can choose which version of GLib you want to use.
config EMBTK_GLIB_VERSION_2_26_1
bool "GLib-2.26.1"
@@ -84,16 +84,8 @@ config EMBTK_GLIB_NEED_PATCH
config EMBTK_GLIB_NEED_AUTORECONF
bool
select EMBTK_GLIB_HOST_NEED_AUTORECONF
-config EMBTK_GLIB_PKG_IS_TARGZ
- bool
-config EMBTK_GLIB_PKG_IS_TARBZ2
- bool
config EMBTK_GLIB_HOST_NEED_PATCH
bool
config EMBTK_GLIB_HOST_NEED_AUTORECONF
bool
-config EMBTK_GLIB_HOST_PKG_IS_TARGZ
- bool
-config EMBTK_GLIB_HOST_PKG_IS_TARBZ2
- bool
diff --git a/packages/misc/glib/glib.mk b/packages/misc/glib/glib.mk
index 522d0a5..f6d41b2 100644
--- a/packages/misc/glib/glib.mk
+++ b/packages/misc/glib/glib.mk
@@ -49,7 +49,7 @@ GLIB_CONFIGURE_ENV := glib_cv_stack_grows=no \
ac_cv_func_posix_getgrgid_r=yes
GLIB_CONFIGURE_OPTS := --disable-fam
-GLIB_DEPS := zlib_install gettext_install glib_host_install
+GLIB_DEPS := zlib_install gettext-intl_install glib_host_install
#
# glib for host
diff --git a/packages/misc/misc.mk b/packages/misc/misc.mk
index 2bc4f8b..4cc56a7 100644
--- a/packages/misc/misc.mk
+++ b/packages/misc/misc.mk
@@ -29,7 +29,6 @@ embtk_pkgincdir := packages/misc
$(call embtk_include_pkg,expat)
# gettext
-$(call embtk_include_pkg,gettext)
$(call embtk_include_hostpkg,gettext_host)
# glib