summaryrefslogtreecommitdiff
path: root/packages/misc
diff options
context:
space:
mode:
authorAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2014-10-19 11:58:38 +0200
committerAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2014-10-19 11:58:38 +0200
commit1345feebdde712bdc75aae36b1490c2e3496a18d (patch)
tree9c355c0c7444d1b0a5cd15a86bcb572a55c75257 /packages/misc
parent26d93641f30e3586cd16494cc41706b15283cf53 (diff)
downloadembtoolkit-1345feebdde712bdc75aae36b1490c2e3496a18d.tar.gz
embtoolkit-1345feebdde712bdc75aae36b1490c2e3496a18d.tar.bz2
embtoolkit-1345feebdde712bdc75aae36b1490c2e3496a18d.tar.xz
Host tools: move gettext under dir dedicated for host tools
Signed-off-by: Abdoulaye Walsimou Gaye <awg@embtoolkit.org>
Diffstat (limited to 'packages/misc')
-rw-r--r--packages/misc/gettext/gettext.kconfig38
-rw-r--r--packages/misc/gettext/gettext.mk39
-rw-r--r--packages/misc/misc.kconfig3
-rw-r--r--packages/misc/misc.mk3
4 files changed, 0 insertions, 83 deletions
diff --git a/packages/misc/gettext/gettext.kconfig b/packages/misc/gettext/gettext.kconfig
deleted file mode 100644
index 8ae773a..0000000
--- a/packages/misc/gettext/gettext.kconfig
+++ /dev/null
@@ -1,38 +0,0 @@
-################################################################################
-# Embtoolkit
-# Copyright(C) 2009-2014 GAYE Abdoulaye Walsimou.
-#
-# This program is free software: you can redistribute it and/or modify
-# it under the terms of the GNU General Public License as published by
-# the Free Software Foundation, either version 2 of the License, or
-# (at your option) any later version.
-#
-# This program is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-# GNU General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License
-# along with this program. If not, see <http://www.gnu.org/licenses/>.
-#
-################################################################################
-#
-# \file gettext.kconfig
-# \brief gettext.kconfig of Embtoolkit
-# \author GAYE Abdoulaye Walsimou, <walsimou@walsimou.com>
-# \date December 2009
-################################################################################
-
-config EMBTK_HOST_HAVE_GETTEXT
- bool
- help
- gettext for host development machine.
-
-config EMBTK_GETTEXT_HOST_VERSION_STRING
- string
- default "0.18.3.2"
-
-config EMBTK_GETTEXT_HOST_NEED_PATCH
- bool
-config EMBTK_GETTEXT_HOST_NEED_AUTORECONF
- bool
diff --git a/packages/misc/gettext/gettext.mk b/packages/misc/gettext/gettext.mk
deleted file mode 100644
index 264072b..0000000
--- a/packages/misc/gettext/gettext.mk
+++ /dev/null
@@ -1,39 +0,0 @@
-################################################################################
-# Embtoolkit
-# Copyright(C) 2009-2011 Abdoulaye Walsimou GAYE.
-#
-# This program is free software: you can redistribute it and/or modify
-# it under the terms of the GNU General Public License as published by
-# the Free Software Foundation, either version 2 of the License, or
-# (at your option) any later version.
-#
-# This program is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-# GNU General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License
-# along with this program. If not, see <http://www.gnu.org/licenses/>.
-#
-################################################################################
-#
-# \file gettext.mk
-# \brief gettext.mk of Embtoolkit
-# \author Abdoulaye Walsimou GAYE <awg@embtoolkit.org>
-# \date December 2009
-################################################################################
-
-GETTEXT_HOST_NAME := gettext
-GETTEXT_HOST_VERSION := $(call embtk_get_pkgversion,gettext_host)
-GETTEXT_HOST_SITE := http://ftp.gnu.org/pub/gnu/gettext
-GETTEXT_HOST_PACKAGE := gettext-$(GETTEXT_HOST_VERSION).tar.gz
-GETTEXT_HOST_SRC_DIR := $(embtk_toolsb)/gettext-$(GETTEXT_HOST_VERSION)
-GETTEXT_HOST_BUILD_DIR := $(embtk_toolsb)/gettext-$(GETTEXT_HOST_VERSION)
-
-GETTEXT_HOST_CONFIGURE_OPTS := --disable-java
-GETTEXT_HOST_CONFIGURE_OPTS += --disable-native-java
-GETTEXT_HOST_CONFIGURE_OPTS += --disable-openmp
-GETTEXT_HOST_CONFIGURE_OPTS += --with-included-gettext
-GETTEXT_HOST_CONFIGURE_OPTS += --with-included-glib
-GETTEXT_HOST_CONFIGURE_OPTS += --with-included-libcroco
-GETTEXT_HOST_CONFIGURE_OPTS += --with-included-libxml
diff --git a/packages/misc/misc.kconfig b/packages/misc/misc.kconfig
index d1bc85f..dcf5af5 100644
--- a/packages/misc/misc.kconfig
+++ b/packages/misc/misc.kconfig
@@ -26,9 +26,6 @@
# expat
source packages/misc/expat/expat.kconfig
-# gettext
-source packages/misc/gettext/gettext.kconfig
-
# glib
source packages/misc/glib/glib.kconfig
diff --git a/packages/misc/misc.mk b/packages/misc/misc.mk
index b8ffd4f..e5a00bd 100644
--- a/packages/misc/misc.mk
+++ b/packages/misc/misc.mk
@@ -28,9 +28,6 @@ embtk_pkgincdir := packages/misc
# expat
$(call embtk_include_pkg,expat)
-# gettext
-$(call embtk_include_hostpkg,gettext_host)
-
# glib
$(call embtk_include_pkg,glib)
$(call embtk_include_hostpkg,glib_host)