summaryrefslogtreecommitdiff
path: root/packages/misc
diff options
context:
space:
mode:
authorAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2014-01-12 16:37:42 +0100
committerAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2014-01-12 16:37:42 +0100
commit2d68a2f554078f2a77e1fef2f60ed7a216a7557e (patch)
tree5c6c38a60d4179fe3474d07b3c61086c7d9e83bf /packages/misc
parent97bce6f482a5cfa2be2a4e2bcad8875870e769e8 (diff)
downloadembtoolkit-2d68a2f554078f2a77e1fef2f60ed7a216a7557e.tar.gz
embtoolkit-2d68a2f554078f2a77e1fef2f60ed7a216a7557e.tar.bz2
embtoolkit-2d68a2f554078f2a77e1fef2f60ed7a216a7557e.tar.xz
packages/misc: convert to use include macro
Signed-off-by: Abdoulaye Walsimou Gaye <awg@embtoolkit.org>
Diffstat (limited to 'packages/misc')
-rw-r--r--packages/misc/misc.mk39
1 files changed, 17 insertions, 22 deletions
diff --git a/packages/misc/misc.mk b/packages/misc/misc.mk
index 8c28702..daf9be8 100644
--- a/packages/misc/misc.mk
+++ b/packages/misc/misc.mk
@@ -1,6 +1,6 @@
################################################################################
# Embtoolkit
-# Copyright(C) 2010-2012 GAYE Abdoulaye Walsimou.
+# Copyright(C) 2010-2014 GAYE Abdoulaye Walsimou.
#
# This program is free software: you can redistribute it and/or modify
# it under the terms of the GNU General Public License as published by
@@ -23,33 +23,28 @@
# \date February 2010
################################################################################
-#expat
-include packages/misc/expat/expat.mk
-ROOTFS_COMPONENTS-$(CONFIG_EMBTK_HAVE_EXPAT) += expat_install
+embtk_pkgincdir := packages/misc
-#gettext
-include packages/misc/gettext/gettext.mk
-ROOTFS_COMPONENTS-$(CONFIG_EMBTK_HAVE_GETTEXT) += gettext_install
-HOSTTOOLS_COMPONENTS-$(CONFIG_EMBTK_HOST_HAVE_GETTEXT) += gettext_host_install
+# expat
+$(call embtk_include_pkg,expat)
-#GLib
-include packages/misc/glib/glib.mk
-ROOTFS_COMPONENTS-$(CONFIG_EMBTK_HAVE_GLIB) += glib_install
-HOSTTOOLS_COMPONENTS-$(CONFIG_EMBTK_HOST_HAVE_GLIB) += glib_host_install
+# gettext
+$(call embtk_include_pkg,gettext)
+$(call embtk_include_hostpkg,gettext_host)
+
+# glib
+$(call embtk_include_pkg,glib)
+$(call embtk_include_hostpkg,glib_host)
# intltool
-include packages/misc/intltool/intltool.mk
-HOSTTOOLS_COMPONENTS-$(CONFIG_EMBTK_HOST_HAVE_INTLTOOL) += intltool_host_install
+$(call embtk_include_hostpkg,intltool_host)
-#libxml2
+# libxml2
include packages/misc/libxml/libxml.mk
ROOTFS_COMPONENTS-$(CONFIG_EMBTK_HAVE_LIBXML2) += libxml2_install
-#ncurses
-include packages/misc/ncurses/ncurses.mk
-ROOTFS_COMPONENTS-$(CONFIG_EMBTK_HAVE_NCURSES) += ncurses_install
-
-#tslib
-include packages/misc/tslib/tslib.mk
-ROOTFS_COMPONENTS-$(CONFIG_EMBTK_HAVE_TSLIB) += tslib_install
+# ncurses
+$(call embtk_include_pkg,ncurses)
+# tslib
+$(call embtk_include_pkg,tslib)