summaryrefslogtreecommitdiff
path: root/packages/misc
diff options
context:
space:
mode:
authorRicardo Crudo <ricardo.crudo@gmail.com>2014-05-17 14:19:48 -0300
committerAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2014-05-17 23:41:07 +0200
commit7a39fd737a35440b754c1116eaaa98531ad037ba (patch)
treedb068b1baa13a067e926f68c77713746410b00ea /packages/misc
parent0ead48c714b2ea5f20235d9a654ac62116e70769 (diff)
downloadembtoolkit-7a39fd737a35440b754c1116eaaa98531ad037ba.tar.gz
embtoolkit-7a39fd737a35440b754c1116eaaa98531ad037ba.tar.bz2
embtoolkit-7a39fd737a35440b754c1116eaaa98531ad037ba.tar.xz
Packages/misc: New sratom v0.4.4
Signed-off-by: Ricardo Crudo <ricardo.crudo@gmail.com> Signed-off-by: Abdoulaye Walsimou Gaye <awg@embtoolkit.org>
Diffstat (limited to 'packages/misc')
-rw-r--r--packages/misc/misc.kconfig3
-rw-r--r--packages/misc/misc.mk3
-rw-r--r--packages/misc/sratom/sratom.kconfig55
-rw-r--r--packages/misc/sratom/sratom.mk45
4 files changed, 106 insertions, 0 deletions
diff --git a/packages/misc/misc.kconfig b/packages/misc/misc.kconfig
index 395122f..c64e023 100644
--- a/packages/misc/misc.kconfig
+++ b/packages/misc/misc.kconfig
@@ -46,5 +46,8 @@ source packages/misc/serd/serd.kconfig
# sord
source packages/misc/sord/sord.kconfig
+# sratom
+source packages/misc/sratom/sratom.kconfig
+
# tslib
source packages/misc/tslib/tslib.kconfig
diff --git a/packages/misc/misc.mk b/packages/misc/misc.mk
index 3cd34f1..2bc4f8b 100644
--- a/packages/misc/misc.mk
+++ b/packages/misc/misc.mk
@@ -52,5 +52,8 @@ $(call embtk_include_pkg,serd)
# sord
$(call embtk_include_pkg,sord)
+# sratom
+$(call embtk_include_pkg,sratom)
+
# tslib
$(call embtk_include_pkg,tslib)
diff --git a/packages/misc/sratom/sratom.kconfig b/packages/misc/sratom/sratom.kconfig
new file mode 100644
index 0000000..46be828
--- /dev/null
+++ b/packages/misc/sratom/sratom.kconfig
@@ -0,0 +1,55 @@
+################################################################################
+# Embtoolkit
+# Copyright(C) 2009-2014 Abdoulaye Walsimou GAYE.
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+################################################################################
+#
+# \file sratom.kconfig
+# \brief sratom.kconfig of Embtoolkit.
+# \author Ricardo Crudo <ricardo.crudo@gmail.com>
+# \date May 2014
+################################################################################
+
+config EMBTK_HAVE_SRATOM
+ bool "Have sratom"
+ select EMBTK_HAVE_LV2
+ select EMBTK_HAVE_SERD
+ select EMBTK_HAVE_SORD
+ help
+ Sratom is a library for serialising LV2 atoms to/from RDF, particularly
+ the Turtle syntax.
+
+choice
+ prompt "sratom version to use"
+ depends on EMBTK_HAVE_SRATOM
+ help
+ sratom version to use
+
+ config EMBTK_SRATOM_VERSION_0_4_4
+ bool "sratom-0.4.4"
+endchoice
+
+config EMBTK_SRATOM_USE_WAF
+ bool
+ default y
+ select EMBTK_HOST_HAVE_WAF
+
+config EMBTK_SRATOM_VERSION_STRING
+ string
+ default "0.4.4" if EMBTK_SRATOM_VERSION_0_4_4
+
+config EMBTK_SRATOM_NEED_PATCH
+ bool
diff --git a/packages/misc/sratom/sratom.mk b/packages/misc/sratom/sratom.mk
new file mode 100644
index 0000000..81cf3e2
--- /dev/null
+++ b/packages/misc/sratom/sratom.mk
@@ -0,0 +1,45 @@
+################################################################################
+# Embtoolkit
+# Copyright(C) 2009-2014 Abdoulaye Walsimou GAYE.
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+################################################################################
+#
+# \file sratom.mk
+# \brief sratom.mk of Embtoolkit.
+# \author Ricardo Crudo <ricardo.crudo@gmail.com>
+# \date May 2014
+################################################################################
+
+SRATOM_NAME := sratom
+SRATOM_VERSION := $(call embtk_get_pkgversion,sratom)
+SRATOM_SITE := http://download.drobilla.net
+SRATOM_PACKAGE := sratom-$(SRATOM_VERSION).tar.bz2
+SRATOM_SRC_DIR := $(embtk_pkgb)/sratom-$(SRATOM_VERSION)
+SRATOM_BUILD_DIR := $(embtk_pkgb)/sratom-$(SRATOM_VERSION)
+
+SRATOM_DEPS := lv2_install serd_install sord_install
+SRATOM_INCLUDES := sratom-0
+SRATOM_LIBS := libsratom*
+SRATOM_PKGCONFIGS := sratom-0.pc
+
+# FIXME: uses python2 to execute the waf due a bug with waflib and python 3.4.0
+define embtk_beforeinstall_sratom
+ cp $(SRATOM_SRC_DIR)/waf $(SRATOM_SRC_DIR)/waf.bak
+ sed -e 's;env[[:space:]]python;env python2;' \
+ < $(SRATOM_SRC_DIR)/waf > $(SRATOM_SRC_DIR)/waf.new
+ mv $(SRATOM_SRC_DIR)/waf.new $(SRATOM_SRC_DIR)/waf
+ chmod +x $(SRATOM_SRC_DIR)/waf
+endef