summaryrefslogtreecommitdiff
path: root/packages/misc
diff options
context:
space:
mode:
authorAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2014-07-25 00:01:43 +0200
committerAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2014-07-25 00:01:43 +0200
commit7c7fb9a7de30c10c199a34e46b95517c6ecff7d9 (patch)
tree1bbd4021bfc88ef8e4d505defde2d4b0524f175f /packages/misc
parentaeae0ce299f70f2acb762aa8a5c104d47ff8ed00 (diff)
downloadembtoolkit-7c7fb9a7de30c10c199a34e46b95517c6ecff7d9.tar.gz
embtoolkit-7c7fb9a7de30c10c199a34e46b95517c6ecff7d9.tar.bz2
embtoolkit-7c7fb9a7de30c10c199a34e46b95517c6ecff7d9.tar.xz
Packages: libelf: split into host/target packages
Signed-off-by: Abdoulaye Walsimou Gaye <awg@embtoolkit.org>
Diffstat (limited to 'packages/misc')
-rw-r--r--packages/misc/libelf/libelf.kconfig53
-rw-r--r--packages/misc/libelf/libelf.mk52
2 files changed, 0 insertions, 105 deletions
diff --git a/packages/misc/libelf/libelf.kconfig b/packages/misc/libelf/libelf.kconfig
deleted file mode 100644
index 72d8d70..0000000
--- a/packages/misc/libelf/libelf.kconfig
+++ /dev/null
@@ -1,53 +0,0 @@
-################################################################################
-# Embtoolkit
-# Copyright(C) 2010-2012 GAYE Abdoulaye Walsimou.
-#
-# This program is free software; you can distribute it and/or modify it
-# under the terms of the GNU General Public License
-# (Version 2 or later) published by the Free Software Foundation.
-#
-# This program is distributed in the hope it will be useful, but WITHOUT
-# ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or
-# FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License
-# for more details.
-#
-# You should have received a copy of the GNU General Public License along
-# with this program; if not, write to the Free Software Foundation, Inc.,
-# 59 Temple Place - Suite 330, Boston MA 02111-1307, USA.
-################################################################################
-#
-# \file libelf.kconfig
-# \brief libelf.kconfig of Embtoolkit
-# \author GAYE Abdoulaye Walsimou, <walsimou@walsimou.com>
-# \date January 2010
-################################################################################
-
-config EMBTK_HOST_HAVE_LIBELF
- bool
- select EMBTK_LIBELF_HOST_NEED_PATCH
- help
- libelf for host development machine
-
-config EMBTK_HAVE_LIBELF
- bool
- select EMBTK_LIBELF_NEED_PATCH
- help
- libelf lets you read, modify or create ELF files in an
- architecture-independent way. The library takes care of size and
- endian issues, e.g. you can process a file for SPARC processors
- on an Intel-based system.
-
-config EMBTK_LIBELF_VERSION_STRING
- string
- depends on EMBTK_HOST_HAVE_LIBELF || EMBTK_HAVE_LIBELF
- default "0.8.13"
-
-config EMBTK_LIBELF_NEED_PATCH
- bool
-config EMBTK_LIBELF_NEED_AUTORECONF
- bool
-
-config EMBTK_LIBELF_HOST_NEED_PATCH
- bool
-config EMBTK_LIBELF_HOST_NEED_AUTORECONF
- bool
diff --git a/packages/misc/libelf/libelf.mk b/packages/misc/libelf/libelf.mk
deleted file mode 100644
index 71f25e9..0000000
--- a/packages/misc/libelf/libelf.mk
+++ /dev/null
@@ -1,52 +0,0 @@
-################################################################################
-# Embtoolkit
-# Copyright(C) 2010-2012 Abdoulaye Walsimou GAYE.
-#
-# This program is free software: you can redistribute it and/or modify
-# it under the terms of the GNU General Public License as published by
-# the Free Software Foundation, either version 2 of the License, or
-# (at your option) any later version.
-#
-# This program is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-# GNU General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License
-# along with this program. If not, see <http://www.gnu.org/licenses/>.
-#
-################################################################################
-#
-# \file libelf.mk
-# \brief libelf.mk of Embtoolkit
-# \author Abdoulaye Walsimou GAYE <awg@embtoolkit.org>
-# \date January 2010
-################################################################################
-
-LIBELF_NAME := libelf
-LIBELF_VERSION := $(call embtk_get_pkgversion,libelf)
-LIBELF_SITE := http://www.mr511.de/software
-LIBELF_PACKAGE := libelf-$(LIBELF_VERSION).tar.gz
-LIBELF_SRC_DIR := $(embtk_pkgb)/libelf-$(LIBELF_VERSION)
-LIBELF_BUILD_DIR := $(embtk_pkgb)/libelf-$(LIBELF_VERSION)
-
-LIBELF_BINS :=
-LIBELF_SBINS :=
-LIBELF_INCLUDES := libelf gelf.h libelf.h nlist.h
-LIBELF_LIBS := libelf.a
-LIBELF_PKGCONFIGS := libelf.pc
-
-LIBELF_CONFIGURE_OPTS := --enable-elf64 --disable-nls
-
-#
-# libelf for host development machine
-#
-
-LIBELF_HOST_NAME := $(LIBELF_NAME)
-LIBELF_HOST_VERSION := $(LIBELF_VERSION)
-LIBELF_HOST_SITE := $(LIBELF_SITE)
-LIBELF_HOST_PACKAGE := $(LIBELF_PACKAGE)
-LIBELF_HOST_SRC_DIR := $(embtk_toolsb)/libelf-$(LIBELF_VERSION)
-LIBELF_HOST_BUILD_DIR := $(embtk_toolsb)/libelf-$(LIBELF_VERSION)
-
-LIBELF_HOST_CONFIGURE_OPTS := --enable-elf64 --disable-nls