summaryrefslogtreecommitdiff
path: root/packages/misc
diff options
context:
space:
mode:
authorAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2014-07-16 21:45:14 +0200
committerAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2014-07-16 21:45:14 +0200
commitace7970ea96b21079db8c487928425d98664ae24 (patch)
tree08c759a56ae011de651f8f97f2b55ac904c0e1ea /packages/misc
parent17c4f44b287fdc7e617422a070cb17cb97b74410 (diff)
downloadembtoolkit-ace7970ea96b21079db8c487928425d98664ae24.tar.gz
embtoolkit-ace7970ea96b21079db8c487928425d98664ae24.tar.bz2
embtoolkit-ace7970ea96b21079db8c487928425d98664ae24.tar.xz
Packages: libxml2: fix installed xml2-config sctipts and move it among textproc packages
Signed-off-by: Abdoulaye Walsimou Gaye <awg@embtoolkit.org>
Diffstat (limited to 'packages/misc')
-rw-r--r--packages/misc/libxml/libxml.kconfig56
-rw-r--r--packages/misc/libxml/libxml.mk46
-rw-r--r--packages/misc/misc.kconfig3
-rw-r--r--packages/misc/misc.mk4
4 files changed, 0 insertions, 109 deletions
diff --git a/packages/misc/libxml/libxml.kconfig b/packages/misc/libxml/libxml.kconfig
deleted file mode 100644
index 619516d..0000000
--- a/packages/misc/libxml/libxml.kconfig
+++ /dev/null
@@ -1,56 +0,0 @@
-################################################################################
-# Embtoolkit
-# Copyright(C) 2009-2011 Abdoulaye Walsimou GAYE.
-#
-# This program is free software: you can redistribute it and/or modify
-# it under the terms of the GNU General Public License as published by
-# the Free Software Foundation, either version 2 of the License, or
-# (at your option) any later version.
-#
-# This program is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-# GNU General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License
-# along with this program. If not, see <http://www.gnu.org/licenses/>.
-#
-################################################################################
-#
-# \file libxml.kconfig
-# \brief libxml.kconfig of Embtoolkit
-# \author Abdoulaye Walsimou GAYE <awg@embtoolkit.org>
-# \date December 2009
-################################################################################
-
-config EMBTK_HAVE_LIBXML2
- bool "Have libxml2"
- select KEMBTK_UCLIBC_UCLIBC_HAS_FLOATS if EMBTK_CLIB_UCLIBC
- select KEMBTK_UCLIBC_DO_C99_MATH if EMBTK_CLIB_UCLIBC
- help
- libxml2
-choice
- prompt "libxml version you wish"
- depends on EMBTK_HAVE_LIBXML2
- help
- Here you can choose which version of libxml2 you want to use.
-
- config EMBTK_LIBXML2_VERSION_2_7_7
- bool "libxml2-2.7.7"
- config EMBTK_LIBXML2_VERSION_2_7_6
- bool "libxml2-2.7.6"
-endchoice
-
-config EMBTK_LIBXML2_VERSION_STRING
- string
- default "2.7.7" if EMBTK_LIBXML2_VERSION_2_7_7
- default "2.7.6" if EMBTK_LIBXML2_VERSION_2_7_6
-
-config EMBTK_LIBXML2_NEED_PATCH
- bool
-config EMBTK_LIBXML2_NEED_AUTORECONF
- bool
-config EMBTK_LIBXML2_PKG_IS_TARGZ
- bool
-config EMBTK_LIBXML2_PKG_IS_TARBZ2
- bool
diff --git a/packages/misc/libxml/libxml.mk b/packages/misc/libxml/libxml.mk
deleted file mode 100644
index d903366..0000000
--- a/packages/misc/libxml/libxml.mk
+++ /dev/null
@@ -1,46 +0,0 @@
-################################################################################
-# Embtoolkit
-# Copyright(C) 2009-2014 Abdoulaye Walsimou GAYE.
-#
-# This program is free software: you can redistribute it and/or modify
-# it under the terms of the GNU General Public License as published by
-# the Free Software Foundation, either version 2 of the License, or
-# (at your option) any later version.
-#
-# This program is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-# GNU General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License
-# along with this program. If not, see <http://www.gnu.org/licenses/>.
-#
-################################################################################
-#
-# \file libxml.mk
-# \brief libxml.mk of Embtoolkit
-# \author Abdoulaye Walsimou GAYE <awg@embtoolkit.org>
-# \date December 2009
-################################################################################
-
-LIBXML2_NAME := libxml2
-LIBXML2_VERSION := $(call embtk_get_pkgversion,libxml2)
-LIBXML2_SITE := ftp://xmlsoft.org/libxml2
-LIBXML2_PACKAGE := libxml2-$(LIBXML2_VERSION).tar.gz
-LIBXML2_SRC_DIR := $(embtk_pkgb)/libxml2-$(LIBXML2_VERSION)
-LIBXML2_BUILD_DIR := $(embtk_pkgb)/libxml2-$(LIBXML2_VERSION)
-
-LIBXML2_BINS := xml2-config xmlcatalog xmllint
-LIBXML2_INCLUDES := libxml2
-LIBXML2_LIBS := libxml2* xml2Conf.sh
-LIBXML2_PKGCONFIGS := libxml*.pc
-
-LIBXML2_CONFIGURE_OPTS := --without-python
-
-# FIXME: this should be fixed from upstream libxml2
-pembtk_libxml2conf := $(embtk_sysroot)/usr/$(LIBDIR)/xml2Conf.sh
-define embtk_postinstallonce_libxml2
- sed -e 's;/usr;$(embtk_sysroot)/usr;g' \
- < $(pembtk_libxml2conf) > $(pembtk_libxml2conf).tmp; \
- mv $(pembtk_libxml2conf).tmp $(pembtk_libxml2conf)
-endef
diff --git a/packages/misc/misc.kconfig b/packages/misc/misc.kconfig
index 3ed4364..140b63a 100644
--- a/packages/misc/misc.kconfig
+++ b/packages/misc/misc.kconfig
@@ -35,9 +35,6 @@ source packages/misc/glib/glib.kconfig
# inttltool
source packages/misc/intltool/intltool.kconfig
-# libxml
-source packages/misc/libxml/libxml.kconfig
-
# ncurses included in main Kconfig
# raptor
diff --git a/packages/misc/misc.mk b/packages/misc/misc.mk
index 015af2e..1c1e617 100644
--- a/packages/misc/misc.mk
+++ b/packages/misc/misc.mk
@@ -38,10 +38,6 @@ $(call embtk_include_hostpkg,glib_host)
# intltool
$(call embtk_include_hostpkg,intltool_host)
-# libxml2
-include packages/misc/libxml/libxml.mk
-ROOTFS_COMPONENTS-$(CONFIG_EMBTK_HAVE_LIBXML2) += libxml2_install
-
# ncurses
$(call embtk_include_pkg,ncurses)