summaryrefslogtreecommitdiff
path: root/packages/misc
diff options
context:
space:
mode:
authorRicardo Crudo <ricardo.crudo@gmail.com>2014-05-17 14:09:22 -0300
committerAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2014-05-17 21:35:59 +0200
commitd9886c0e102356edcb56bbbc6a2e6907eb9c2070 (patch)
treefd258aec6cd14e933ad66e54353a52ffbdcf4dc3 /packages/misc
parent4ef11d2dd30ff0fffc573879f0a7b9327879c5f2 (diff)
downloadembtoolkit-d9886c0e102356edcb56bbbc6a2e6907eb9c2070.tar.gz
embtoolkit-d9886c0e102356edcb56bbbc6a2e6907eb9c2070.tar.bz2
embtoolkit-d9886c0e102356edcb56bbbc6a2e6907eb9c2070.tar.xz
Packages/misc: New serd v0.18.2
Signed-off-by: Ricardo Crudo <ricardo.crudo@gmail.com> Signed-off-by: Abdoulaye Walsimou Gaye <awg@embtoolkit.org>
Diffstat (limited to 'packages/misc')
-rw-r--r--packages/misc/misc.kconfig17
-rw-r--r--packages/misc/misc.mk3
-rw-r--r--packages/misc/serd/serd.kconfig58
-rw-r--r--packages/misc/serd/serd.mk46
4 files changed, 123 insertions, 1 deletions
diff --git a/packages/misc/misc.kconfig b/packages/misc/misc.kconfig
index 6bac669..537ba33 100644
--- a/packages/misc/misc.kconfig
+++ b/packages/misc/misc.kconfig
@@ -1,6 +1,6 @@
################################################################################
# Embtoolkit
-# Copyright(C) 2010-2012 GAYE Abdoulaye Walsimou.
+# Copyright(C) 2010-2014 GAYE Abdoulaye Walsimou.
#
# This program is free software: you can redistribute it and/or modify
# it under the terms of the GNU General Public License as published by
@@ -23,10 +23,25 @@
# \date February 2010
################################################################################
+# expat
source packages/misc/expat/expat.kconfig
+
+# gettext
source packages/misc/gettext/gettext.kconfig
+
+# glib
source packages/misc/glib/glib.kconfig
+
+# inttltool
source packages/misc/intltool/intltool.kconfig
+
+# libxml
source packages/misc/libxml/libxml.kconfig
+
# ncurses included in main Kconfig
+
+# serd
+source packages/misc/serd/serd.kconfig
+
+# tslib
source packages/misc/tslib/tslib.kconfig
diff --git a/packages/misc/misc.mk b/packages/misc/misc.mk
index daf9be8..02fdb9d 100644
--- a/packages/misc/misc.mk
+++ b/packages/misc/misc.mk
@@ -46,5 +46,8 @@ ROOTFS_COMPONENTS-$(CONFIG_EMBTK_HAVE_LIBXML2) += libxml2_install
# ncurses
$(call embtk_include_pkg,ncurses)
+# serd
+$(call embtk_include_pkg,serd)
+
# tslib
$(call embtk_include_pkg,tslib)
diff --git a/packages/misc/serd/serd.kconfig b/packages/misc/serd/serd.kconfig
new file mode 100644
index 0000000..f5b5f30
--- /dev/null
+++ b/packages/misc/serd/serd.kconfig
@@ -0,0 +1,58 @@
+################################################################################
+# Embtoolkit
+# Copyright(C) 2010-2014 Abdoulaye Walsimou GAYE.
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+################################################################################
+#
+# \file serd.kconfig
+# \brief serd.kconfig of Embtoolkit.
+# \author Ricardo Crudo <ricardo.crudo@gmail.com>
+# \date May 2014
+################################################################################
+
+config EMBTK_HAVE_SERD
+ bool "Have serd"
+ help
+ Serd is a lightweight C library for RDF syntax which supports reading and writing
+ Turtle and NTriples. Serd is not intended to be a swiss-army knife of RDF syntax,
+ but rather is suited to resource limited or performance critical applications (e.g.
+ converting many gigabytes of NTriples to Turtle), or situations where a simple
+ reader/writer with minimal dependencies is ideal (e.g. in LV2 implementations or
+ embedded applications).
+
+choice
+ prompt "serd version to use"
+ depends on EMBTK_HAVE_SERD
+ help
+ serd version to use
+
+ config EMBTK_SERD_VERSION_0_18_2
+ bool "serd-0.18.2"
+endchoice
+
+config EMBTK_SERD_USE_WAF
+ bool
+ default y
+ select EMBTK_HOST_HAVE_WAF
+
+config EMBTK_SERD_VERSION_STRING
+ string
+ default "0.18.2" if EMBTK_SERD_VERSION_0_18_2
+
+config EMBTK_SERD_NEED_PATCH
+ bool
+config EMBTK_SERD_NEED_AUTORECONF
+ bool
diff --git a/packages/misc/serd/serd.mk b/packages/misc/serd/serd.mk
new file mode 100644
index 0000000..01f04c9
--- /dev/null
+++ b/packages/misc/serd/serd.mk
@@ -0,0 +1,46 @@
+################################################################################
+# Embtoolkit
+# Copyright(C) 2009-2014 Abdoulaye Walsimou GAYE.
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+################################################################################
+#
+# \file serd.mk
+# \brief serd.mk of Embtoolkit.
+# \author Ricardo Crudo <ricardo.crudo@gmail.com>
+# \date May 2014
+################################################################################
+
+SERD_NAME := serd
+SERD_VERSION := $(call embtk_get_pkgversion,serd)
+SERD_SITE := http://download.drobilla.net
+SERD_PACKAGE := serd-$(SERD_VERSION).tar.bz2
+SERD_SRC_DIR := $(embtk_pkgb)/serd-$(SERD_VERSION)
+SERD_BUILD_DIR := $(embtk_pkgb)/serd-$(SERD_VERSION)
+
+SERD_BINS := serdi
+SERD_INCLUDES := serd-0
+SERD_LIBS := libserd*
+SERD_PKGCONFIGS := serd-0.pc
+SERD_SHARES := man/*/serdi*
+
+# FIXME: uses python2 to execute the waf due a bug with waflib and python 3.4.0
+define embtk_beforeinstall_serd
+ cp $(SERD_SRC_DIR)/waf $(SERD_SRC_DIR)/waf.bak
+ sed -e 's;env[[:space:]]python;env python2;' \
+ < $(SERD_SRC_DIR)/waf > $(SERD_SRC_DIR)/waf.new
+ mv $(SERD_SRC_DIR)/waf.new $(SERD_SRC_DIR)/waf
+ chmod +x $(SERD_SRC_DIR)/waf
+endef