summaryrefslogtreecommitdiff
path: root/packages/misc
diff options
context:
space:
mode:
authorAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2010-08-22 20:05:12 +0200
committerAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2010-08-22 20:05:12 +0200
commitdbfc9fdc6085a528fc8178ff5ce9960ad8f6a5cd (patch)
treeefb0370771ebdf5143a55cd08ce09942cf213208 /packages/misc
parent4d4894930a92e5101a0f045dc20be4f6ccb21e1f (diff)
downloadembtoolkit-dbfc9fdc6085a528fc8178ff5ce9960ad8f6a5cd.tar.gz
embtoolkit-dbfc9fdc6085a528fc8178ff5ce9960ad8f6a5cd.tar.bz2
embtoolkit-dbfc9fdc6085a528fc8178ff5ce9960ad8f6a5cd.tar.xz
Embtk: drastically improve packages rebuild duration
Signed-off-by: Abdoulaye Walsimou Gaye <awg@embtoolkit.org>
Diffstat (limited to 'packages/misc')
-rw-r--r--packages/misc/expat/expat.mk7
-rw-r--r--packages/misc/foo/foo.mk11
-rw-r--r--packages/misc/gettext/gettext.mk17
-rw-r--r--packages/misc/glib/glib.mk13
-rw-r--r--packages/misc/libelf/libelf.mk52
-rw-r--r--packages/misc/libxml/libxml.mk5
-rw-r--r--packages/misc/misc.mk4
-rw-r--r--packages/misc/ncurses/ncurses.mk54
-rw-r--r--packages/misc/pango/pango.mk14
-rw-r--r--packages/misc/tslib/tslib.mk19
10 files changed, 109 insertions, 87 deletions
diff --git a/packages/misc/expat/expat.mk b/packages/misc/expat/expat.mk
index 47576b3..e97e9e6 100644
--- a/packages/misc/expat/expat.mk
+++ b/packages/misc/expat/expat.mk
@@ -37,7 +37,9 @@ EXPAT_PKGCONFIGS =
EXPAT_DEPS =
-expat_install: $(EXPAT_BUILD_DIR)/.installed
+expat_install:
+ @test -e $(EXPAT_BUILD_DIR)/.installed || \
+ $(MAKE) $(EXPAT_BUILD_DIR)/.installed
$(EXPAT_BUILD_DIR)/.installed: $(EXPAT_DEPS) download_expat \
$(EXPAT_BUILD_DIR)/.decompressed $(EXPAT_BUILD_DIR)/.configured
@@ -94,10 +96,11 @@ $(EXPAT_BUILD_DIR)/.configured:
@touch $@
expat_clean:
- $(call EMBTK_GENERIC_MESSAGE,"cleanup expat-$(EXPAT_VERSION)...")
+ $(call EMBTK_GENERIC_MESSAGE,"cleanup expat...")
$(Q)-cd $(SYSROOT)/usr/bin; rm -rf $(EXPAT_BINS)
$(Q)-cd $(SYSROOT)/usr/sbin; rm -rf $(EXPAT_SBINS)
$(Q)-cd $(SYSROOT)/usr/include; rm -rf $(EXPAT_INCLUDES)
$(Q)-cd $(SYSROOT)/usr/$(LIBDIR); rm -rf $(EXPAT_LIBS)
$(Q)-cd $(SYSROOT)/usr/$(LIBDIR)/pkgconfig; rm -rf $(EXPAT_PKGCONFIGS)
+ $(Q)-rm -rf $(EXPAT_BUILD_DIR)
diff --git a/packages/misc/foo/foo.mk b/packages/misc/foo/foo.mk
index a057402..3aba6bd 100644
--- a/packages/misc/foo/foo.mk
+++ b/packages/misc/foo/foo.mk
@@ -35,9 +35,11 @@ FOO_INCLUDES =
FOO_LIBS =
FOO_PKGCONFIGS =
-FOO_DEPS =
+FOO_DEPS :=
-foo_install: $(FOO_BUILD_DIR)/.installed
+foo_install:
+ @test -e $(FOO_BUILD_DIR)/.installed || \
+ $(MAKE) $(FOO_BUILD_DIR)/.installed
$(FOO_BUILD_DIR)/.installed: $(FOO_DEPS) download_foo \
$(FOO_BUILD_DIR)/.decompressed $(FOO_BUILD_DIR)/.configured
@@ -66,7 +68,7 @@ $(FOO_BUILD_DIR)/.decompressed:
$(call EMBTK_GENERIC_MESSAGE,"Decompressing $(FOO_PACKAGE) ...")
@tar -C $(PACKAGES_BUILD) -xzf $(DOWNLOAD_DIR)/$(FOO_PACKAGE)
ifeq ($(CONFIG_EMBTK_FOO_NEED_PATCH),y)
- @cd $(PACKAGES_BUILD)/foo-$(FOO_VERSION); \
+ @cd $(FOO_BUILD_DIR); \
patch -p1 < $(DOWNLOAD_DIR)/foo-$(FOO_VERSION).patch
endif
@touch $@
@@ -95,10 +97,11 @@ $(FOO_BUILD_DIR)/.configured:
@touch $@
foo_clean:
- $(call EMBTK_GENERIC_MESSAGE,"cleanup foo-$(FOO_VERSION)...")
+ $(call EMBTK_GENERIC_MESSAGE,"cleanup foo...")
$(Q)-cd $(SYSROOT)/usr/bin; rm -rf $(FOO_BINS)
$(Q)-cd $(SYSROOT)/usr/sbin; rm -rf $(FOO_SBINS)
$(Q)-cd $(SYSROOT)/usr/include; rm -rf $(FOO_INCLUDES)
$(Q)-cd $(SYSROOT)/usr/$(LIBDIR); rm -rf $(FOO_LIBS)
$(Q)-cd $(SYSROOT)/usr/$(LIBDIR)/pkgconfig; rm -rf $(FOO_PKGCONFIGS)
+ $(Q)-rm -rf $(FOO_BUILD_DIR)
diff --git a/packages/misc/gettext/gettext.mk b/packages/misc/gettext/gettext.mk
index 62e4b33..40c9306 100644
--- a/packages/misc/gettext/gettext.mk
+++ b/packages/misc/gettext/gettext.mk
@@ -1,6 +1,6 @@
################################################################################
# Embtoolkit
-# Copyright(C) 2009-2010 GAYE Abdoulaye Walsimou. All rights reserved.
+# Copyright(C) 2009-2010 Abdoulaye Walsimou GAYE. All rights reserved.
#
# This program is free software; you can distribute it and/or modify it
# under the terms of the GNU General Public License
@@ -18,7 +18,7 @@
#
# \file gettext.mk
# \brief gettext.mk of Embtoolkit
-# \author GAYE Abdoulaye Walsimou, <walsimou@walsimou.com>
+# \author Abdoulaye Walsimou GAYE <awg@embtoolkit.org>
# \date December 2009
################################################################################
@@ -38,7 +38,9 @@ GETTEXT_PKGCONFIGS =
GETTEXT_DEPS = ncurses_install libxml2_install
-gettext_install: $(GETTEXT_BUILD_DIR)/.installed
+gettext_install:
+ @test -e $(GETTEXT_BUILD_DIR)/.installed || \
+ $(MAKE) $(GETTEXT_BUILD_DIR)/.installed
$(GETTEXT_BUILD_DIR)/.installed: $(GETTEXT_DEPS) download_gettext \
$(GETTEXT_BUILD_DIR)/.decompressed $(GETTEXT_BUILD_DIR)/.configured
@@ -85,12 +87,9 @@ gettext_clean:
$(Q)-cd $(SYSROOT)/usr/bin; rm -rf $(GETTEXT_BINS)
$(Q)-cd $(SYSROOT)/usr/sbin; rm -rf $(GETTEXT_SBINS)
$(Q)-cd $(SYSROOT)/usr/include; rm -rf $(GETTEXT_INCLUDES)
- $(Q)-cd $(SYSROOT)/usr/lib; rm -rf $(GETTEXT_LIBS)
- $(Q)-cd $(SYSROOT)/usr/lib/pkgconfig; rm -rf $(GETTEXT_PKGCONFIGS)
-ifeq ($(CONFIG_EMBTK_64BITS_FS_COMPAT32),y)
- $(Q)-cd $(SYSROOT)/usr/lib32; rm -rf $(GETTEXT_LIBS)
- $(Q)-cd $(SYSROOT)/usr/lib32/pkgconfig; rm -rf $(GETTEXT_PKGCONFIGS)
-endif
+ $(Q)-cd $(SYSROOT)/usr/$(LIBDIR); rm -rf $(GETTEXT_LIBS)
+ $(Q)-cd $(SYSROOT)/usr/$(LIBDIR)/pkgconfig; rm -rf $(GETTEXT_PKGCONFIGS)
+ $(Q)-rm -rf $(GETTEXT_BUILD_DIR)
#FIXME: this should be fixed in gettext project
$(GETTEXT_BUILD_DIR)/.patchlibtool:
diff --git a/packages/misc/glib/glib.mk b/packages/misc/glib/glib.mk
index 773dcd6..b72ebdb 100644
--- a/packages/misc/glib/glib.mk
+++ b/packages/misc/glib/glib.mk
@@ -36,10 +36,14 @@ GLIB_INCLUDES = gio-unix-* glib-*
GLIB_LIBS = gio* libgio-* libglib-* libgmodule-* libgobject-* libgthread-* glib-*
GLIB_PKGCONFIGS = gio-*.pc glib-*.pc gmodule-*.pc gobject-*.pc gthread-*.pc
-glib_install: $(GLIB_BUILD_DIR)/.installed
+GLIB_DEPS := zlib_target_install gettext_install
-$(GLIB_BUILD_DIR)/.installed: zlib_target_install \
- gettext_install download_glib $(GLIB_BUILD_DIR)/.decompressed \
+glib_install:
+ @test -e $(GLIB_BUILD_DIR)/.installed || \
+ $(MAKE) $(GLIB_BUILD_DIR)/.installed
+
+$(GLIB_BUILD_DIR)/.installed: $(GLIB_DEPS) \
+ download_glib $(GLIB_BUILD_DIR)/.decompressed \
$(GLIB_BUILD_DIR)/.configured
$(call EMBTK_GENERIC_MESSAGE,"Compiling and installing \
glib-$(GLIB_VERSION) in your root filesystem...")
@@ -115,10 +119,11 @@ $(GLIB_BUILD_DIR)/.patchlibtool:
mv libgthread-2.0.la.new $(SYSROOT)/usr/$(LIBDIR)/libgthread-2.0.la
glib_clean:
- $(call EMBTK_GENERIC_MESSAGE,"cleanup glib-$(GLIB_VERSION)...")
+ $(call EMBTK_GENERIC_MESSAGE,"cleanup glib...")
$(Q)-cd $(SYSROOT)/usr/bin; rm -rf $(GLIB_BINS)
$(Q)-cd $(SYSROOT)/usr/sbin; rm -rf $(GLIB_SBINS)
$(Q)-cd $(SYSROOT)/usr/include; rm -rf $(GLIB_INCLUDES)
$(Q)-cd $(SYSROOT)/usr/$(LIBDIR); rm -rf $(GLIB_LIBS)
$(Q)-cd $(SYSROOT)/usr/$(LIBDIR)/pkgconfig; rm -rf $(GLIB_PKGCONFIGS)
+ $(Q)-rm -rf $(GLIB_BUILD_DIR)
diff --git a/packages/misc/libelf/libelf.mk b/packages/misc/libelf/libelf.mk
index 276e470..2cf5952 100644
--- a/packages/misc/libelf/libelf.mk
+++ b/packages/misc/libelf/libelf.mk
@@ -1,24 +1,25 @@
################################################################################
# Embtoolkit
-# Copyright(C) 2010 GAYE Abdoulaye Walsimou. All rights reserved.
+# Copyright(C) 2010 Abdoulaye Walsimou GAYE. All rights reserved.
#
-# This program is free software; you can distribute it and/or modify it
-# under the terms of the GNU General Public License
-# (Version 2 or later) published by the Free Software Foundation.
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
#
-# This program is distributed in the hope it will be useful, but WITHOUT
-# ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or
-# FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License
-# for more details.
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
#
-# You should have received a copy of the GNU General Public License along
-# with this program; if not, write to the Free Software Foundation, Inc.,
-# 59 Temple Place - Suite 330, Boston MA 02111-1307, USA.
################################################################################
#
# \file libelf.mk
# \brief libelf.mk of Embtoolkit
-# \author GAYE Abdoulaye Walsimou, <walsimou@walsimou.com>
+# \author Abdoulaye Walsimou GAYE <awg@embtoolkit.org>
# \date January 2010
################################################################################
@@ -34,15 +35,13 @@ LIBELF_INCLUDES = libelf gelf.h libelf.h nlist.h
LIBELF_LIBS = libelf.a
LIBELF_PKGCONFIGS = libelf.pc
-ifeq ($(CONFIG_EMBTK_64BITS_FS_COMPAT32),y)
-PKG_CONFIG_PATH=$(SYSROOT)/usr/lib32/pkgconfig
-else
-PKG_CONFIG_PATH=$(SYSROOT)/usr/lib/pkgconfig
-endif
+LIBELF_DEPS := gettext_install
-libelf_install: $(LIBELF_BUILD_DIR)/.installed
+libelf_install:
+ @test -e $(LIBELF_BUILD_DIR)/.installed || \
+ $(MAKE) $(LIBELF_BUILD_DIR)/.installed
-$(LIBELF_BUILD_DIR)/.installed: gettext_install download_libelf \
+$(LIBELF_BUILD_DIR)/.installed: $(LIBELF_DEPS) download_libelf \
$(LIBELF_BUILD_DIR)/.decompressed $(LIBELF_BUILD_DIR)/.configured
$(call EMBTK_GENERIC_MESSAGE,"Compiling and installing \
libelf-$(LIBELF_VERSION) in your root filesystem...")
@@ -58,7 +57,7 @@ download_libelf:
wget -O $(DOWNLOAD_DIR)/$(LIBELF_PACKAGE) \
$(LIBELF_SITE)/$(LIBELF_PACKAGE)
ifeq ($(CONFIG_EMBTK_LIBELF_NEED_PATCH),y)
- $(Q)test -e $(DOWNLOAD_DIR)/libelf-$(LIBELF_VERSION).patch || \
+ @test -e $(DOWNLOAD_DIR)/libelf-$(LIBELF_VERSION).patch || \
wget -O $(DOWNLOAD_DIR)/libelf-$(LIBELF_VERSION).patch \
$(LIBELF_PATCH_SITE)/libelf-$(LIBELF_VERSION)-*.patch
endif
@@ -67,7 +66,7 @@ $(LIBELF_BUILD_DIR)/.decompressed:
$(call EMBTK_GENERIC_MESSAGE,"Decompressing $(LIBELF_PACKAGE) ...")
@tar -C $(PACKAGES_BUILD) -xzf $(DOWNLOAD_DIR)/$(LIBELF_PACKAGE)
ifeq ($(CONFIG_EMBTK_LIBELF_NEED_PATCH),y)
- cd $(PACKAGES_BUILD)/libelf-$(LIBELF_VERSION); \
+ cd $(LIBELF_BUILD_DIR); \
patch -p1 < $(DOWNLOAD_DIR)/libelf-$(LIBELF_VERSION).patch
endif
@touch $@
@@ -97,14 +96,11 @@ $(LIBELF_BUILD_DIR)/.configured:
@touch $@
libelf_clean:
- $(call EMBTK_GENERIC_MESSAGE,"cleanup libelf-$(LIBELF_VERSION)...")
+ $(call EMBTK_GENERIC_MESSAGE,"cleanup libelf...")
$(Q)-cd $(SYSROOT)/usr/bin; rm -rf $(LIBELF_BINS)
$(Q)-cd $(SYSROOT)/usr/sbin; rm -rf $(LIBELF_SBINS)
$(Q)-cd $(SYSROOT)/usr/include; rm -rf $(LIBELF_INCLUDES)
- $(Q)-cd $(SYSROOT)/usr/lib; rm -rf $(LIBELF_LIBS)
- $(Q)-cd $(SYSROOT)/usr/lib/pkgconfig; rm -rf $(LIBELF_PKGCONFIGS)
-ifeq ($(CONFIG_EMBTK_64BITS_FS_COMPAT32),y)
- $(Q)-cd $(SYSROOT)/usr/lib32; rm -rf $(LIBELF_LIBS)
- $(Q)-cd $(SYSROOT)/usr/lib32/pkgconfig; rm -rf $(LIBELF_PKGCONFIGS)
-endif
+ $(Q)-cd $(SYSROOT)/usr/$(LIBDIR); rm -rf $(LIBELF_LIBS)
+ $(Q)-cd $(SYSROOT)/usr/$(LIBDIR)/pkgconfig; rm -rf $(LIBELF_PKGCONFIGS)
+ $(Q)-rm -rf $(LIBELF_BUILD_DIR)
diff --git a/packages/misc/libxml/libxml.mk b/packages/misc/libxml/libxml.mk
index c3cbc00..a3b617a 100644
--- a/packages/misc/libxml/libxml.mk
+++ b/packages/misc/libxml/libxml.mk
@@ -35,7 +35,9 @@ LIBXML2_LIBS = libxml2* xml2Conf.sh
LIBXML2_PKGCONFIGS = libxml*.pc
LIBXML2_LIBTOOLS = libxml2.la
-libxml2_install: $(LIBXML2_BUILD_DIR)/.installed
+libxml2_install:
+ @test -e $(LIBXML2_BUILD_DIR)/.installed || \
+ $(MAKE) $(LIBXML2_BUILD_DIR)/.installed
$(LIBXML2_BUILD_DIR)/.installed: download_libxml2 \
$(LIBXML2_BUILD_DIR)/.decompressed $(LIBXML2_BUILD_DIR)/.configured
@@ -91,4 +93,5 @@ libxml2_clean:
$(Q)-cd $(SYSROOT)/usr/$(LIBDIR); rm -rf $(LIBXML2_LIBS)
$(Q)-cd $(SYSROOT)/usr/$(LIBDIR)/pkgconfig; rm -rf $(LIBXML2_PKGCONFIGS)
$(Q)-cd $(SYSROOT)/usr/$(LIBDIR)/pkgconfig; rm -rf $(LIBXML2_LIBTOOLS)
+ $(Q)-rm -rf $(LIBXML2_BUILD_DIR)
diff --git a/packages/misc/misc.mk b/packages/misc/misc.mk
index 89b8956..7f91bd9 100644
--- a/packages/misc/misc.mk
+++ b/packages/misc/misc.mk
@@ -1,6 +1,6 @@
################################################################################
# Embtoolkit
-# Copyright(C) 2010 GAYE Abdoulaye Walsimou. All rights reserved.
+# Copyright(C) 2010 Abdoulaye Walsimou GAYE. All rights reserved.
#
# This program is free software; you can distribute it and/or modify it
# under the terms of the GNU General Public License
@@ -18,7 +18,7 @@
#
# \file misc.mk
# \brief misc.mk of Embtoolkit
-# \author GAYE Abdoulaye Walsimou, <walsimou@walsimou.com>
+# \author Abdoulaye Walsimou GAYE <awg@embtoolkit.org>
# \date February 2010
################################################################################
diff --git a/packages/misc/ncurses/ncurses.mk b/packages/misc/ncurses/ncurses.mk
index 131ebdd..cd622b9 100644
--- a/packages/misc/ncurses/ncurses.mk
+++ b/packages/misc/ncurses/ncurses.mk
@@ -1,24 +1,25 @@
################################################################################
# Embtoolkit
-# Copyright(C) 2010 GAYE Abdoulaye Walsimou. All rights reserved.
+# Copyright(C) 2010 Abdoulaye Walsimou GAYE. All rights reserved.
#
-# This program is free software; you can distribute it and/or modify it
-# under the terms of the GNU General Public License
-# (Version 2 or later) published by the Free Software Foundation.
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
#
-# This program is distributed in the hope it will be useful, but WITHOUT
-# ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or
-# FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License
-# for more details.
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
#
-# You should have received a copy of the GNU General Public License along
-# with this program; if not, write to the Free Software Foundation, Inc.,
-# 59 Temple Place - Suite 330, Boston MA 02111-1307, USA.
################################################################################
#
# \file ncurses.mk
# \brief ncurses.mk of Embtoolkit
-# \author GAYE Abdoulaye Walsimou, <walsimou@walsimou.com>
+# \author Abdoulaye Walsimou GAYE <awg@embtoolkit.org>
# \date January 2010
################################################################################
@@ -39,13 +40,10 @@ NCURSES_LIBS = libcurses.a libform.a libform_g.a libmenu.a libmenu_g.a \
libpanel_g.a terminfo
NCURSES_PKGCONFIGS =
-ifeq ($(CONFIG_EMBTK_64BITS_FS_COMPAT32),y)
-PKG_CONFIG_PATH=$(SYSROOT)/usr/lib32/pkgconfig
-else
-PKG_CONFIG_PATH=$(SYSROOT)/usr/lib/pkgconfig
-endif
-
-ncurses_install: $(NCURSES_BUILD_DIR)/.installed
+ncurses_install:
+ @test -e $(NCURSES_BUILD_DIR)/.installed || \
+ $(MAKE) $(NCURSES_BUILD_DIR)/.installed
+ $(MAKE) $(NCURSES_BUILD_DIR)/.special
$(NCURSES_BUILD_DIR)/.installed: download_ncurses \
$(NCURSES_BUILD_DIR)/.decompressed $(NCURSES_BUILD_DIR)/.configured
@@ -53,7 +51,6 @@ $(NCURSES_BUILD_DIR)/.installed: download_ncurses \
ncurses-$(NCURSES_VERSION) in your root filesystem...")
$(Q)$(MAKE) -C $(NCURSES_BUILD_DIR) $(J)
$(Q)$(MAKE) -C $(NCURSES_BUILD_DIR) DESTDIR=$(SYSROOT) install
- $(Q)-cp -R $(SYSROOT)/usr/share/tabset $(ROOTFS)/usr/share/
@touch $@
download_ncurses:
@@ -93,14 +90,17 @@ $(NCURSES_BUILD_DIR)/.configured:
@touch $@
ncurses_clean:
- $(call EMBTK_GENERIC_MESSAGE,"cleanup ncurses-$(NCURSES_VERSION)...")
+ $(call EMBTK_GENERIC_MESSAGE,"cleanup ncurses...")
$(Q)-cd $(SYSROOT)/usr/bin; rm -rf $(NCURSES_BINS)
$(Q)-cd $(SYSROOT)/usr/sbin; rm -rf $(NCURSES_SBINS)
$(Q)-cd $(SYSROOT)/usr/include; rm -rf $(NCURSES_INCLUDES)
- $(Q)-cd $(SYSROOT)/usr/lib; rm -rf $(NCURSES_LIBS)
- $(Q)-cd $(SYSROOT)/usr/lib/pkgconfig; rm -rf $(NCURSES_PKGCONFIGS)
-ifeq ($(CONFIG_EMBTK_64BITS_FS_COMPAT32),y)
- $(Q)-cd $(SYSROOT)/usr/lib32; rm -rf $(NCURSES_LIBS)
- $(Q)-cd $(SYSROOT)/usr/lib32/pkgconfig; rm -rf $(NCURSES_PKGCONFIGS)
-endif
+ $(Q)-cd $(SYSROOT)/usr/$(LIBDIR); rm -rf $(NCURSES_LIBS)
+ $(Q)-cd $(SYSROOT)/usr/$(LIBDIR)/pkgconfig; rm -rf $(NCURSES_PKGCONFIGS)
+ $(Q)-rm -rf $(NCURSES_BUILD_DIR)
+.PHONY: $(NCURSES_BUILD_DIR)/.special
+
+$(NCURSES_BUILD_DIR)/.special:
+ $(Q)mkdir -p $(ROOTFS)/usr/share
+ $(Q)-cp -R $(SYSROOT)/usr/share/tabset $(ROOTFS)/usr/share/
+ @touch $@
diff --git a/packages/misc/pango/pango.mk b/packages/misc/pango/pango.mk
index 8a45888..541186f 100644
--- a/packages/misc/pango/pango.mk
+++ b/packages/misc/pango/pango.mk
@@ -35,12 +35,15 @@ PANGO_INCLUDES = pango*
PANGO_LIBS = pango-* pango* libpango*
PANGO_PKGCONFIGS = pango*.pc
-pango_install: $(PANGO_BUILD_DIR)/.installed $(PANGO_BUILD_DIR)/.special
+PANGO_DEPS := glib_install fontconfig_install cairo_install
-$(PANGO_BUILD_DIR)/.installed: $(GLIB_BUILD_DIR)/.installed \
- $(FONTCONFIG_BUILD_DIR)/.installed $(CAIRO_BUILD_DIR)/.installed \
- download_pango $(PANGO_BUILD_DIR)/.decompressed \
- $(PANGO_BUILD_DIR)/.configured
+pango_install:
+ @test -e $(PANGO_BUILD_DIR)/.installed || \
+ $(MAKE) $(PANGO_BUILD_DIR)/.installed
+ $(MAKE) $(PANGO_BUILD_DIR)/.special
+
+$(PANGO_BUILD_DIR)/.installed: $(PANGO_DEPS) download_pango \
+ $(PANGO_BUILD_DIR)/.decompressed $(PANGO_BUILD_DIR)/.configured
$(call EMBTK_GENERIC_MESSAGE,"Compiling and installing \
pango-$(PANGO_VERSION) in your root filesystem...")
$(call EMBTK_KILL_LT_RPATH, $(PANGO_BUILD_DIR))
@@ -110,4 +113,5 @@ pango_clean:
$(Q)-cd $(SYSROOT)/usr/include; rm -rf $(PANGO_INCLUDES)
$(Q)-cd $(SYSROOT)/usr/$(LIBDIR); rm -rf $(PANGO_LIBS)
$(Q)-cd $(SYSROOT)/usr/$(LIBDIR)/pkgconfig; rm -rf $(PANGO_PKGCONFIGS)
+ $(Q)-rm -rf $(PANGO_BUILD_DIR)
diff --git a/packages/misc/tslib/tslib.mk b/packages/misc/tslib/tslib.mk
index a25fc54..cb55af0 100644
--- a/packages/misc/tslib/tslib.mk
+++ b/packages/misc/tslib/tslib.mk
@@ -1,6 +1,6 @@
################################################################################
# Embtoolkit
-# Copyright(C) 2010 GAYE Abdoulaye Walsimou. All rights reserved.
+# Copyright(C) 2010 Abdoulaye Walsimou GAYE. All rights reserved.
#
# This program is free software: you can redistribute it and/or modify
# it under the terms of the GNU General Public License as published by
@@ -19,7 +19,7 @@
#
# \file tslib.mk
# \brief tslib.mk of Embtoolkit
-# \author GAYE Abdoulaye Walsimou, <walsimou@walsimou.com>
+# \author Abdoulaye Walsimou GAYE <awg@embtoolkit.org>
# \date March 2010
################################################################################
@@ -37,7 +37,10 @@ TSLIB_PKGCONFIGS = tslib-*.pc
TSLIB_DEPS =
-tslib_install: $(TSLIB_BUILD_DIR)/.installed
+tslib_install:
+ @test -e $(TSLIB_BUILD_DIR)/.installed || \
+ $(MAKE) $(TSLIB_BUILD_DIR)/.installed
+ $(MAKE) $(TSLIB_BUILD_DIR)/.special
$(TSLIB_BUILD_DIR)/.installed: $(TSLIB_DEPS) download_tslib \
$(TSLIB_BUILD_DIR)/.decompressed $(TSLIB_BUILD_DIR)/.configured
@@ -47,7 +50,6 @@ $(TSLIB_BUILD_DIR)/.installed: $(TSLIB_DEPS) download_tslib \
$(Q)$(MAKE) -C $(TSLIB_BUILD_DIR) DESTDIR=$(SYSROOT) install
$(Q)$(MAKE) libtool_files_adapt
$(Q)$(MAKE) pkgconfig_files_adapt
- $(Q)-cp -R $(SYSROOT)/usr/$(LIBDIR)/ts $(ROOTFS)/usr/$(LIBDIR)/
@touch $@
download_tslib:
@@ -66,7 +68,7 @@ $(TSLIB_BUILD_DIR)/.decompressed:
$(call EMBTK_GENERIC_MESSAGE,"Decompressing $(TSLIB_PACKAGE) ...")
@tar -C $(PACKAGES_BUILD) -xjf $(DOWNLOAD_DIR)/$(TSLIB_PACKAGE)
ifeq ($(CONFIG_EMBTK_TSLIB_NEED_PATCH),y)
- @cd $(PACKAGES_BUILD)/tslib-$(TSLIB_VERSION); \
+ @cd $(TSLIB_BUILD_DIR); \
patch -p1 < $(DOWNLOAD_DIR)/tslib-$(TSLIB_VERSION).patch
endif
@touch $@
@@ -105,4 +107,11 @@ tslib_clean:
$(Q)-cd $(SYSROOT)/usr/include; rm -rf $(TSLIB_INCLUDES)
$(Q)-cd $(SYSROOT)/usr/$(LIBDIR); rm -rf $(TSLIB_LIBS)
$(Q)-cd $(SYSROOT)/usr/$(LIBDIR)/pkgconfig; rm -rf $(TSLIB_PKGCONFIGS)
+ $(Q)-rm -rf $(TSLIB_BUILD_DIR)
+
+
+.PHONY: $(TSLIB_BUILD_DIR)/.special
+$(TSLIB_BUILD_DIR)/.special:
+ $(Q)-cp -R $(SYSROOT)/usr/$(LIBDIR)/ts $(ROOTFS)/usr/$(LIBDIR)/
+ @touch $@