summaryrefslogtreecommitdiff
path: root/packages/misc
diff options
context:
space:
mode:
authorAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2012-02-04 22:02:04 +0100
committerAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2012-02-04 22:02:04 +0100
commite4e174f7d561f263d15ad7be062cdfe2b0934181 (patch)
treed4060f55104383cd6149a54ad2d1655af659d7c5 /packages/misc
parent6acf5f803e1dc60015d8be310b0791c8d7bd124e (diff)
downloadembtoolkit-e4e174f7d561f263d15ad7be062cdfe2b0934181.tar.gz
embtoolkit-e4e174f7d561f263d15ad7be062cdfe2b0934181.tar.bz2
embtoolkit-e4e174f7d561f263d15ad7be062cdfe2b0934181.tar.xz
Packages: libelf: do make libelf depends on having rootfs, as it may be needed by toolchain addons
Signed-off-by: Abdoulaye Walsimou Gaye <awg@embtoolkit.org>
Diffstat (limited to 'packages/misc')
-rw-r--r--packages/misc/libelf/libelf.kconfig31
-rw-r--r--packages/misc/libelf/libelf.mk9
-rw-r--r--packages/misc/misc.kconfig1
-rw-r--r--packages/misc/misc.mk28
4 files changed, 21 insertions, 48 deletions
diff --git a/packages/misc/libelf/libelf.kconfig b/packages/misc/libelf/libelf.kconfig
index 45783e1..72d8d70 100644
--- a/packages/misc/libelf/libelf.kconfig
+++ b/packages/misc/libelf/libelf.kconfig
@@ -1,6 +1,6 @@
################################################################################
# Embtoolkit
-# Copyright(C) 2010-2011 GAYE Abdoulaye Walsimou.
+# Copyright(C) 2010-2012 GAYE Abdoulaye Walsimou.
#
# This program is free software; you can distribute it and/or modify it
# under the terms of the GNU General Public License
@@ -24,49 +24,30 @@
config EMBTK_HOST_HAVE_LIBELF
bool
- select EMBTK_HOST_HAVE_GETTEXT
+ select EMBTK_LIBELF_HOST_NEED_PATCH
help
libelf for host development machine
config EMBTK_HAVE_LIBELF
- bool "Have libelf"
- select EMBTK_HAVE_GETTEXT
+ bool
+ select EMBTK_LIBELF_NEED_PATCH
help
libelf lets you read, modify or create ELF files in an
architecture-independent way. The library takes care of size and
endian issues, e.g. you can process a file for SPARC processors
on an Intel-based system.
-choice
- prompt "libelf version you wish"
- depends on EMBTK_HAVE_LIBELF || EMBTK_HOST_HAVE_LIBELF
- help
- Here you can choose which version of libelf you want to use.
-
- config EMBTK_LIBELF_VERSION_0_8_13
- bool "libelf-0.8.13"
- select EMBTK_LIBELF_NEED_PATCH
-endchoice
config EMBTK_LIBELF_VERSION_STRING
string
- default "0.8.13" if EMBTK_LIBELF_VERSION_0_8_13
+ depends on EMBTK_HOST_HAVE_LIBELF || EMBTK_HAVE_LIBELF
+ default "0.8.13"
config EMBTK_LIBELF_NEED_PATCH
bool
- select EMBTK_LIBELF_HOST_NEED_PATCH
config EMBTK_LIBELF_NEED_AUTORECONF
bool
- select EMBTK_LIBELF_HOST_NEED_AUTORECONF
-config EMBTK_LIBELF_PKG_IS_TARGZ
- bool
-config EMBTK_LIBELF_PKG_IS_TARBZ2
- bool
config EMBTK_LIBELF_HOST_NEED_PATCH
bool
config EMBTK_LIBELF_HOST_NEED_AUTORECONF
bool
-config EMBTK_LIBELF_HOST_PKG_IS_TARGZ
- bool
-config EMBTK_LIBELF_HOST_PKG_IS_TARBZ2
- bool
diff --git a/packages/misc/libelf/libelf.mk b/packages/misc/libelf/libelf.mk
index 2bb9338..ca2a4a6 100644
--- a/packages/misc/libelf/libelf.mk
+++ b/packages/misc/libelf/libelf.mk
@@ -1,6 +1,6 @@
################################################################################
# Embtoolkit
-# Copyright(C) 2010-2011 Abdoulaye Walsimou GAYE.
+# Copyright(C) 2010-2012 Abdoulaye Walsimou GAYE.
#
# This program is free software: you can redistribute it and/or modify
# it under the terms of the GNU General Public License as published by
@@ -36,9 +36,7 @@ LIBELF_INCLUDES := libelf gelf.h libelf.h nlist.h
LIBELF_LIBS := libelf.a
LIBELF_PKGCONFIGS := libelf.pc
-LIBELF_CONFIGURE_OPTS := --enable-elf64
-LIBELF_DEPS := gettext_install
-
+LIBELF_CONFIGURE_OPTS := --enable-elf64 --disable-nls
#
# libelf for host development machine
@@ -51,5 +49,4 @@ LIBELF_HOST_PACKAGE := $(LIBELF_PACKAGE)
LIBELF_HOST_SRC_DIR := $(TOOLS_BUILD)/libelf-$(LIBELF_VERSION)
LIBELF_HOST_BUILD_DIR := $(TOOLS_BUILD)/libelf-$(LIBELF_VERSION)
-LIBELF_HOST_CONFIGURE_OPTS := --enable-elf64
-LIBELF_HOST_DEPS := gettext_host_install
+LIBELF_HOST_CONFIGURE_OPTS := --enable-elf64 --disable-nls
diff --git a/packages/misc/misc.kconfig b/packages/misc/misc.kconfig
index 972b834..6bac669 100644
--- a/packages/misc/misc.kconfig
+++ b/packages/misc/misc.kconfig
@@ -27,7 +27,6 @@ source packages/misc/expat/expat.kconfig
source packages/misc/gettext/gettext.kconfig
source packages/misc/glib/glib.kconfig
source packages/misc/intltool/intltool.kconfig
-source packages/misc/libelf/libelf.kconfig
source packages/misc/libxml/libxml.kconfig
# ncurses included in main Kconfig
source packages/misc/tslib/tslib.kconfig
diff --git a/packages/misc/misc.mk b/packages/misc/misc.mk
index 3f7c999..78cc81c 100644
--- a/packages/misc/misc.mk
+++ b/packages/misc/misc.mk
@@ -1,19 +1,20 @@
################################################################################
# Embtoolkit
-# Copyright(C) 2010-2012 Abdoulaye Walsimou GAYE.
+# Copyright(C) 2010-2012 GAYE Abdoulaye Walsimou.
#
-# This program is free software; you can distribute it and/or modify it
-# under the terms of the GNU General Public License
-# (Version 2 or later) published by the Free Software Foundation.
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 2 of the License, or
+# (at your option) any later version.
#
-# This program is distributed in the hope it will be useful, but WITHOUT
-# ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or
-# FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License
-# for more details.
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
#
-# You should have received a copy of the GNU General Public License along
-# with this program; if not, write to the Free Software Foundation, Inc.,
-# 59 Temple Place - Suite 330, Boston MA 02111-1307, USA.
################################################################################
#
# \file misc.mk
@@ -40,11 +41,6 @@ HOSTTOOLS_COMPONENTS-$(CONFIG_EMBTK_HOST_HAVE_GLIB) += glib_host_install
include $(EMBTK_ROOT)/packages/misc/intltool/intltool.mk
HOSTTOOLS_COMPONENTS-$(CONFIG_EMBTK_HOST_HAVE_INTLTOOL) += intltool_host_install
-#libelf
-include $(EMBTK_ROOT)/packages/misc/libelf/libelf.mk
-ROOTFS_COMPONENTS-$(CONFIG_EMBTK_HAVE_LIBELF) += libelf_install
-HOSTTOOLS_COMPONENTS-$(CONFIG_EMBTK_HOST_HAVE_LIBELF) += libelf_host_install
-
#libxml2
include $(EMBTK_ROOT)/packages/misc/libxml/libxml.mk
ROOTFS_COMPONENTS-$(CONFIG_EMBTK_HAVE_LIBXML2) += libxml2_install