summaryrefslogtreecommitdiff
path: root/packages/misc
diff options
context:
space:
mode:
authorAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2014-05-15 00:51:04 +0200
committerAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2014-05-15 00:52:19 +0200
commitebe622803c485fe6f69178726f22799e1f98718d (patch)
treeaf4570c3f27edea76261b6eabd62927c67fd9a27 /packages/misc
parent9aa8e4cd47bbc709ba1a15886f38e91e8c74935e (diff)
downloadembtoolkit-ebe622803c485fe6f69178726f22799e1f98718d.tar.gz
embtoolkit-ebe622803c485fe6f69178726f22799e1f98718d.tar.bz2
embtoolkit-ebe622803c485fe6f69178726f22799e1f98718d.tar.xz
Packages: gettext: update to v0.18.3.2
Signed-off-by: Abdoulaye Walsimou Gaye <awg@embtoolkit.org>
Diffstat (limited to 'packages/misc')
-rw-r--r--packages/misc/gettext/gettext.kconfig51
-rw-r--r--packages/misc/gettext/gettext.mk10
2 files changed, 31 insertions, 30 deletions
diff --git a/packages/misc/gettext/gettext.kconfig b/packages/misc/gettext/gettext.kconfig
index c8a4b5f..36b015f 100644
--- a/packages/misc/gettext/gettext.kconfig
+++ b/packages/misc/gettext/gettext.kconfig
@@ -1,6 +1,6 @@
################################################################################
# Embtoolkit
-# Copyright(C) 2009-2011 GAYE Abdoulaye Walsimou.
+# Copyright(C) 2009-2014 GAYE Abdoulaye Walsimou.
#
# This program is free software: you can redistribute it and/or modify
# it under the terms of the GNU General Public License as published by
@@ -26,7 +26,7 @@
config EMBTK_HOST_HAVE_GETTEXT
bool
help
- gettext for host development machine.
+ gettext for host development machine.
config EMBTK_HAVE_GETTEXT
bool "Have gettext"
@@ -39,38 +39,39 @@ config EMBTK_HAVE_GETTEXT
select KEMBTK_UCLIBC_UCLIBC_HAS_LOCALE if EMBTK_CLIB_UCLIBC
select KEMBTK_UCLIBC_UCLIBC_SUSV4_LEGACY if EMBTK_CLIB_UCLIBC
help
- GNU `gettext' is an important step for the GNU Translation
- Project, as it is an asset on which we may build many other
- steps. This package offers to programmers, translators, and even
- users, a well integrated set of tools and documentation.
- Specifically, the GNU `gettext' utilities are a set of tools
- that provides a framework to help other GNU packages produce
- multi-lingual messages. These tools include a set of conventions
- about how programs should be written to support message
- catalogs, a directory and file naming organization for the
- message catalogs themselves, a runtime library supporting the
- retrieval of translated messages, and a few stand-alone programs
- to massage in various ways the sets of translatable strings, or
- already translated strings. A special GNU Emacs mode also helps
- interested parties in preparing these sets, or bringing them up
- to date.
- Online Manual is available at:
- www.gnu.org/software/gettext/manual/gettext.html
- The Frequently Asked Questions and their answers are at:
- www.gnu.org/software/gettext/FAQ.html
+ GNU `gettext' is an important step for the GNU Translation
+ Project, as it is an asset on which we may build many other
+ steps. This package offers to programmers, translators, and even
+ users, a well integrated set of tools and documentation.
+ Specifically, the GNU `gettext' utilities are a set of tools
+ that provides a framework to help other GNU packages produce
+ multi-lingual messages. These tools include a set of conventions
+ about how programs should be written to support message
+ catalogs, a directory and file naming organization for the
+ message catalogs themselves, a runtime library supporting the
+ retrieval of translated messages, and a few stand-alone programs
+ to massage in various ways the sets of translatable strings, or
+ already translated strings. A special GNU Emacs mode also helps
+ interested parties in preparing these sets, or bringing them up
+ to date.
+ Online Manual is available at:
+ www.gnu.org/software/gettext/manual/gettext.html
+ The Frequently Asked Questions and their answers are at:
+ www.gnu.org/software/gettext/FAQ.html
+
choice
prompt "gettext version you wish"
depends on EMBTK_HAVE_GETTEXT || EMBTK_HOST_HAVE_GETTEXT
help
- Here you can choose which version of gettext you want to use.
+ Here you can choose which version of gettext you want to use.
- config EMBTK_GETTEXT_VERSION_0_16_1
- bool "gettext-0.16.1"
+ config EMBTK_GETTEXT_VERSION_0_18_3_2
+ bool "gettext-0.18.3.2"
endchoice
config EMBTK_GETTEXT_VERSION_STRING
string
- default "0.16.1" if EMBTK_GETTEXT_VERSION_0_16_1
+ default "0.18.3.2" if EMBTK_GETTEXT_VERSION_0_18_3_2
config EMBTK_GETTEXT_NEED_PATCH
bool
diff --git a/packages/misc/gettext/gettext.mk b/packages/misc/gettext/gettext.mk
index 4829f08..126c884 100644
--- a/packages/misc/gettext/gettext.mk
+++ b/packages/misc/gettext/gettext.mk
@@ -36,7 +36,7 @@ GETTEXT_BINS = autopoint gettext gettext.sh msgcat msgcomm msgen \
msgfilter msggrep msgmerge msguniq recode-sr-latin \
envsubst gettextize msgattrib msgcmp msgconv msgexec \
msgfmt msginit msgunfmt ngettext xgettext
-GETTEXT_SBINS =
+
GETTEXT_INCLUDES = autosprintf.h gettext-po.h libintl.h
GETTEXT_LIBS = gettext libgettext* libasprintf* libintl*
GETTEXT_PKGCONFIGS =
@@ -47,11 +47,11 @@ GETTEXT_CONFIGURE_ENV := gl_cv_func_wcwidth_works=yes \
gt_cv_int_divbyzero_sigfpe=no
GETTEXT_CONFIGURE_OPTS := --enable-relocatable --with-included-gettext \
--disable-rpath --disable-openmp --disable-java \
- --with-libxml2-prefix=$(embtk_sysroot)/usr \
- --disable-openmp
-
-GETTEXT_DEPS = ncurses_install libxml2_install
+ --with-libxml2-prefix=$(embtk_sysroot)/usr \
+ --disable-openmp --disable-csharp \
+ --without-emacs
+GETTEXT_DEPS := ncurses_install libxml2_install
define embtk_postinstallonce_gettext
$(MAKE) $(GETTEXT_BUILD_DIR)/.patchlibtool