summaryrefslogtreecommitdiff
path: root/packages/misc
diff options
context:
space:
mode:
authorAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2014-07-16 21:52:06 +0200
committerAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2014-07-16 21:52:06 +0200
commitef47bdb3181d757347325b66304cc1c4f969c67d (patch)
treec814f6cac4b26d526846a141eabcad3bd3447423 /packages/misc
parente8dffacaf95197e36aab1d1247c66af39c67c0e4 (diff)
downloadembtoolkit-ef47bdb3181d757347325b66304cc1c4f969c67d.tar.gz
embtoolkit-ef47bdb3181d757347325b66304cc1c4f969c67d.tar.bz2
embtoolkit-ef47bdb3181d757347325b66304cc1c4f969c67d.tar.xz
Packages: raptor: move to textproc
Signed-off-by: Abdoulaye Walsimou Gaye <awg@embtoolkit.org>
Diffstat (limited to 'packages/misc')
-rw-r--r--packages/misc/misc.kconfig3
-rw-r--r--packages/misc/misc.mk3
-rw-r--r--packages/misc/raptor/raptor.kconfig52
-rw-r--r--packages/misc/raptor/raptor.mk52
4 files changed, 0 insertions, 110 deletions
diff --git a/packages/misc/misc.kconfig b/packages/misc/misc.kconfig
index 140b63a..d1bc85f 100644
--- a/packages/misc/misc.kconfig
+++ b/packages/misc/misc.kconfig
@@ -37,9 +37,6 @@ source packages/misc/intltool/intltool.kconfig
# ncurses included in main Kconfig
-# raptor
-source packages/misc/raptor/raptor.kconfig
-
# serd
source packages/misc/serd/serd.kconfig
diff --git a/packages/misc/misc.mk b/packages/misc/misc.mk
index 1c1e617..b8ffd4f 100644
--- a/packages/misc/misc.mk
+++ b/packages/misc/misc.mk
@@ -41,9 +41,6 @@ $(call embtk_include_hostpkg,intltool_host)
# ncurses
$(call embtk_include_pkg,ncurses)
-# raptor
-$(call embtk_include_pkg,raptor)
-
# serd
$(call embtk_include_pkg,serd)
diff --git a/packages/misc/raptor/raptor.kconfig b/packages/misc/raptor/raptor.kconfig
deleted file mode 100644
index 67d80f8..0000000
--- a/packages/misc/raptor/raptor.kconfig
+++ /dev/null
@@ -1,52 +0,0 @@
-################################################################################
-# Embtoolkit
-# Copyright(C) 2009-2014 Abdoulaye Walsimou GAYE.
-#
-# This program is free software: you can redistribute it and/or modify
-# it under the terms of the GNU General Public License as published by
-# the Free Software Foundation, either version 2 of the License, or
-# (at your option) any later version.
-#
-# This program is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-# GNU General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License
-# along with this program. If not, see <http://www.gnu.org/licenses/>.
-#
-################################################################################
-#
-# \file raptor.kconfig
-# \brief raptor.kconfig of Embtoolkit
-# \author Ricardo Crudo <ricardo.crudo@gmail.com>
-# \date Jun 2014
-################################################################################
-
-config EMBTK_HAVE_RAPTOR
- bool "Have raptor"
- select EMBTK_HAVE_LIBXML2
- help
- Raptor is a free software / Open Source C library that provides a
- set of parsers and serializers that generate Resource Description
- Framework (RDF) triples by parsing syntaxes or serialize the triples
- into a syntax.
-
-choice
- prompt "raptor version you wish"
- depends on EMBTK_HAVE_RAPTOR
- help
- Here you can choose which version of raptor you want to use.
-
- config EMBTK_RAPTOR_VERSION_1_4_21
- bool "raptor-1.4.21"
-endchoice
-
-config EMBTK_RAPTOR_VERSION_STRING
- string
- default "1.4.21" if EMBTK_RAPTOR_VERSION_1_4_21
-
-config EMBTK_RAPTOR_NEED_PATCH
- bool
-config EMBTK_RAPTOR_NEED_AUTORECONF
- bool
diff --git a/packages/misc/raptor/raptor.mk b/packages/misc/raptor/raptor.mk
deleted file mode 100644
index 69385b2..0000000
--- a/packages/misc/raptor/raptor.mk
+++ /dev/null
@@ -1,52 +0,0 @@
-################################################################################
-# Embtoolkit
-# Copyright(C) 2009-2014 Abdoulaye Walsimou GAYE.
-#
-# This program is free software: you can redistribute it and/or modify
-# it under the terms of the GNU General Public License as published by
-# the Free Software Foundation, either version 2 of the License, or
-# (at your option) any later version.
-#
-# This program is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-# GNU General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License
-# along with this program. If not, see <http://www.gnu.org/licenses/>.
-#
-################################################################################
-#
-# \file raptor.mk
-# \brief raptor.mk of Embtoolkit
-# \author Ricardo Crudo <ricardo.crudo@gmail.com>
-# \date Jun 2014
-################################################################################
-
-RAPTOR_NAME := raptor
-RAPTOR_VERSION := $(call embtk_get_pkgversion,raptor)
-RAPTOR_SITE := http://download.librdf.org/source
-RAPTOR_PACKAGE := raptor-$(RAPTOR_VERSION).tar.gz
-RAPTOR_SRC_DIR := $(embtk_pkgb)/raptor-$(RAPTOR_VERSION)
-RAPTOR_BUILD_DIR := $(embtk_pkgb)/raptor-$(RAPTOR_VERSION)
-
-RAPTOR_BINS := rapper raptor-config
-RAPTOR_INCLUDES := raptor.h
-RAPTOR_LIBS := libraptor*
-RAPTOR_PKGCONFIGS := raptor.pc
-RAPTOR_SHARES := man/man1/rapper.1
-RAPTOR_SHARES += man/man1/raptor-config.1
-RAPTOR_SHARES += man/man3/libraptor.3 gtk-doc/html/raptor
-
-RAPTOR_DEPS := libxml2_install
-RAPTOR_CONFIGURE_OPTS := --with-xml2-config=$(embtk_sysroot)/usr/bin/xml2-config
-
-#
-# FIXME: should be fixed upstream - curl/types.h was removed from curl
-#
-define embtk_beforeinstall_raptor
- for f in $$(grep -Rl '<curl/types.h>' $(RAPTOR_SRC_DIR)); do \
- sed -e '/<curl\/types\.h>/d' < $$f > $$f.tmp; \
- mv $$f.tmp $$f; \
- done
-endef