summaryrefslogtreecommitdiff
path: root/packages/net/odhcp6c/odhcp6c.mk
diff options
context:
space:
mode:
authorAverell Kinouani <averell.kinouani@embtoolkit.org>2015-07-26 18:41:27 +0200
committerAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2015-07-26 19:51:28 +0200
commit733096af0743a81756e9d6f54e9e541fe7e61f3f (patch)
treef7d695787a0b03f06b109c7da08b77fc81e08793 /packages/net/odhcp6c/odhcp6c.mk
parente01941925b4bda814f2685ec6776600217b097ea (diff)
downloadembtoolkit-733096af0743a81756e9d6f54e9e541fe7e61f3f.tar.gz
embtoolkit-733096af0743a81756e9d6f54e9e541fe7e61f3f.tar.bz2
embtoolkit-733096af0743a81756e9d6f54e9e541fe7e61f3f.tar.xz
install new packages in network category: - dnsmasq - odhcp6c - radvd
Diffstat (limited to 'packages/net/odhcp6c/odhcp6c.mk')
-rw-r--r--packages/net/odhcp6c/odhcp6c.mk50
1 files changed, 50 insertions, 0 deletions
diff --git a/packages/net/odhcp6c/odhcp6c.mk b/packages/net/odhcp6c/odhcp6c.mk
new file mode 100644
index 0000000..06702f4
--- /dev/null
+++ b/packages/net/odhcp6c/odhcp6c.mk
@@ -0,0 +1,50 @@
+################################################################################
+# Embtoolkit
+# Copyright(C) 2012 Abdoulaye Walsimou GAYE.
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+################################################################################
+#
+# \file odhcp6c.mk
+# \brief odhcp6c.mk of Embtoolkit
+# \author Averell KINOUANI <a.kinouani@embtoolkit.org>
+# \date July 2015
+################################################################################
+
+ODHCP6C_NAME := odhcp6c
+ODHCP6C_SITE := https://github.com/sbyx/odhcp6c/archive/
+ODHCP6C_VERSION := $(call embtk_get_pkgversion,odhcp6c)
+ODHCP6C_PACKAGE := v$(ODHCP6C_VERSION).tar.gz
+ODHCP6C_SRC_DIR := $(embtk_pkgb)/odhcp6c-$(ODHCP6C_VERSION)
+ODHCP6C_BUILD_DIR := $(embtk_pkgb)/odhcp6c-$(ODHCP6C_VERSION)
+
+ODHCP6C_BINS := odhcp6c
+
+
+ODHCP6C_CMAKE_OPTS := "SET(CMAKE_SYSTEM_NAME Linux)\n\
+ SET(CMAKE_C_COMPILER $(TARGETCC))\n\
+ SET(CMAKE_CXX_COMPILER $(TARGETCXX))\n\
+ SET(CMAKE_FIND_ROOT_PATH $(embtk_tools))\n\
+ SET(CMAKE_FIND_ROOT_PATH_MODE_PROGRAM NEVER)\n\
+ SET(CMAKE_FIND_ROOT_PATH_MODE_LIBRARY $(embtk_sysroot)/usr/lib)\n\
+ SET(CMAKE_FIND_ROOT_PATH_MODE_INCLUDE $(embtk_sysroot)/usr/include)\n\
+ SET(CMAKE_INSTALL_PREFIX $(embtk_sysroot)/usr)\n"
+
+
+define embtk_install_odhcp6c
+ printf $(ODHCP6C_CMAKE_OPTS) >> $(ODHCP6C_BUILD_DIR)/CMakeLists.txt; \
+ (cd $(ODHCP6C_BUILD_DIR)/ && cmake .; make; make install)
+endef
+