summaryrefslogtreecommitdiff
path: root/packages/net/tcpdump/tcpdump.mk
diff options
context:
space:
mode:
authorAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2012-12-25 23:40:31 +0100
committerAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2012-12-25 23:40:31 +0100
commit5c67312f3759cdba3c69b944480983fd6b9efe05 (patch)
treed2c1364805dcdd3543f0cb528d65338c115429d8 /packages/net/tcpdump/tcpdump.mk
parent15ae8eec3b124e5040dde33d5ebaeafed3c1058c (diff)
downloadembtoolkit-5c67312f3759cdba3c69b944480983fd6b9efe05.tar.gz
embtoolkit-5c67312f3759cdba3c69b944480983fd6b9efe05.tar.bz2
embtoolkit-5c67312f3759cdba3c69b944480983fd6b9efe05.tar.xz
Packages: add New packages: tcpdump-4.3.0
Signed-off-by: Abdoulaye Walsimou Gaye <awg@embtoolkit.org>
Diffstat (limited to 'packages/net/tcpdump/tcpdump.mk')
-rw-r--r--packages/net/tcpdump/tcpdump.mk38
1 files changed, 38 insertions, 0 deletions
diff --git a/packages/net/tcpdump/tcpdump.mk b/packages/net/tcpdump/tcpdump.mk
new file mode 100644
index 0000000..fd90630
--- /dev/null
+++ b/packages/net/tcpdump/tcpdump.mk
@@ -0,0 +1,38 @@
+################################################################################
+# Embtoolkit
+# Copyright(C) 2012 Abdoulaye Walsimou GAYE.
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+################################################################################
+#
+# \file tcpdump.mk
+# \brief tcpdump.mk of Embtoolkit
+# \author Abdoulaye Walsimou GAYE <awg@embtoolkit.org>
+# \date December 2012
+################################################################################
+
+TCPDUMP_NAME := tcpdump
+TCPDUMP_VERSION := $(call embtk_get_pkgversion,tcpdump)
+TCPDUMP_SITE := http://www.tcpdump.org/release
+TCPDUMP_PACKAGE := tcpdump-$(TCPDUMP_VERSION).tar.gz
+TCPDUMP_SRC_DIR := $(embtk_pkgb)/tcpdump-$(TCPDUMP_VERSION)
+TCPDUMP_BUILD_DIR := $(embtk_pkgb)/tcpdump-$(TCPDUMP_VERSION)
+
+TCPDUMP_SBINS := tcpdump*
+
+TCPDUMP_CONFIGURE_ENV := ac_cv_linux_vers=2
+TCPDUMP_CONFIGURE_OPTS := --with-pcap=linux --without-smi --without-crypto
+
+TCPDUMP_DEPS := libpcap_install