summaryrefslogtreecommitdiff
path: root/packages/net
diff options
context:
space:
mode:
authorAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2013-10-27 14:03:30 +0100
committerAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2013-10-27 14:03:30 +0100
commit5a3bd1d212bda6b4ded5c81949969b37ddc63694 (patch)
treeff51635c25135495092742a0dc6dfc0165f20152 /packages/net
parentf14ee043c92b5ab4065e602c9464be9db8878bb6 (diff)
downloadembtoolkit-5a3bd1d212bda6b4ded5c81949969b37ddc63694.tar.gz
embtoolkit-5a3bd1d212bda6b4ded5c81949969b37ddc63694.tar.bz2
embtoolkit-5a3bd1d212bda6b4ded5c81949969b37ddc63694.tar.xz
New package: fcgi: library for fastcgi development
Signed-off-by: Abdoulaye Walsimou Gaye <awg@embtoolkit.org>
Diffstat (limited to 'packages/net')
-rw-r--r--packages/net/fcgi/fcgi.kconfig49
-rw-r--r--packages/net/fcgi/fcgi.mk38
-rw-r--r--packages/net/net.kconfig5
-rw-r--r--packages/net/net.mk6
4 files changed, 96 insertions, 2 deletions
diff --git a/packages/net/fcgi/fcgi.kconfig b/packages/net/fcgi/fcgi.kconfig
new file mode 100644
index 0000000..605b6d4
--- /dev/null
+++ b/packages/net/fcgi/fcgi.kconfig
@@ -0,0 +1,49 @@
+################################################################################
+# Embtoolkit
+# Copyright(C) 2013 Abdoulaye Walsimou GAYE.
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+################################################################################
+#
+# \file fcgi.kconfig
+# \brief fcgi.kconfig of Embtoolkit
+# \author Abdoulaye Walsimou GAYE <awg@embtoolkit.org>
+# \date October 2013
+################################################################################
+
+config EMBTK_HAVE_FCGI
+ bool "Have fcgi"
+ select EMBTK_GCC_LANGUAGE_CPP
+ help
+ fastcgi development library.
+
+choice
+ prompt "fcgi version you wish"
+ depends on EMBTK_HAVE_FCGI
+ help
+ Here you can choose which version of fcgi you want to use.
+
+ config EMBTK_FCGI_VERSION_2_4_1
+ bool "fcgi-2.4.1-SNAP-0910052249"
+endchoice
+
+config EMBTK_FCGI_VERSION_STRING
+ string
+ default "2.4.1-SNAP-0910052249" if EMBTK_FCGI_VERSION_2_4_1
+
+config EMBTK_FCGI_NEED_PATCH
+ bool
+config EMBTK_FCGI_NEED_AUTORECONF
+ bool
diff --git a/packages/net/fcgi/fcgi.mk b/packages/net/fcgi/fcgi.mk
new file mode 100644
index 0000000..e036ea0
--- /dev/null
+++ b/packages/net/fcgi/fcgi.mk
@@ -0,0 +1,38 @@
+################################################################################
+# Embtoolkit
+# Copyright(C) 2013 Abdoulaye Walsimou GAYE.
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+################################################################################
+#
+# \file fcgi.mk
+# \brief fcgi.mk of Embtoolkit
+# \author Abdoulaye Walsimou GAYE <awg@embtoolkit.org>
+# \date October 2013
+################################################################################
+
+FCGI_NAME := fcgi
+FCGI_VERSION := $(call embtk_get_pkgversion,fcgi)
+FCGI_SITE := ftp://ftp.embtoolkit.org/embtoolkit.org/packages-mirror
+FCGI_PACKAGE := fcgi-$(FCGI_VERSION).tar.bz2
+FCGI_SRC_DIR := $(embtk_pkgb)/fcgi-$(FCGI_VERSION)
+FCGI_BUILD_DIR := $(embtk_pkgb)/fcgi-$(FCGI_VERSION)
+
+FCGI_INCLUDES := fastcgi.h fcgiapp.h fcgi_config.h fcgimisc.h fcgio.h
+FCGI_INCLUDES += fcgios.h fcgi_stdio.h
+FCGI_LIBS := libfcgi.*
+
+FCGI_CFALGS := -fno-strict-aliasing
+FCGI_CXXFALGS := $(FCGI_CFALGS)
diff --git a/packages/net/net.kconfig b/packages/net/net.kconfig
index 3960663..4176be5 100644
--- a/packages/net/net.kconfig
+++ b/packages/net/net.kconfig
@@ -1,6 +1,6 @@
################################################################################
# Embtoolkit
-# Copyright(C) 2012 Abdoulaye Walsimou GAYE.
+# Copyright(C) 2012-2013 Abdoulaye Walsimou GAYE.
#
# This program is free software: you can redistribute it and/or modify
# it under the terms of the GNU General Public License as published by
@@ -23,6 +23,9 @@
# \date May 2012
################################################################################
+# fcgi
+source packages/net/fcgi/fcgi.kconfig
+
# Iptables
source packages/net/iptables/iptables.kconfig
diff --git a/packages/net/net.mk b/packages/net/net.mk
index 904f336..8f7af0f 100644
--- a/packages/net/net.mk
+++ b/packages/net/net.mk
@@ -1,6 +1,6 @@
################################################################################
# Embtoolkit
-# Copyright(C) 2012 Abdoulaye Walsimou GAYE.
+# Copyright(C) 2012-2013 Abdoulaye Walsimou GAYE.
#
# This program is free software: you can redistribute it and/or modify
# it under the terms of the GNU General Public License as published by
@@ -23,6 +23,10 @@
# \date May 2012
################################################################################
+# fcgi
+include packages/net/fcgi/fcgi.mk
+ROOTFS_COMPONENTS-$(CONFIG_EMBTK_HAVE_FCGI) += fcgi_install
+
# Iptables
include packages/net/iptables/iptables.mk
ROOTFS_COMPONENTS-$(CONFIG_EMBTK_HAVE_IPTABLES) += iptables_install