summaryrefslogtreecommitdiff
path: root/packages/net
diff options
context:
space:
mode:
authorAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2014-01-31 23:43:00 +0100
committerAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2014-01-31 23:43:53 +0100
commit8314159f7f0bd423163ea5a659495df255c01b68 (patch)
tree694f86cf94a916a08d48e656f9e4f8068b9f52a8 /packages/net
parent5eaaa61ba801661024d0498503ae21b6a37905be (diff)
downloadembtoolkit-8314159f7f0bd423163ea5a659495df255c01b68.tar.gz
embtoolkit-8314159f7f0bd423163ea5a659495df255c01b68.tar.bz2
embtoolkit-8314159f7f0bd423163ea5a659495df255c01b68.tar.xz
Packages: NEW: add librsync-0.9.7
Signed-off-by: Abdoulaye Walsimou Gaye <awg@embtoolkit.org>
Diffstat (limited to 'packages/net')
-rw-r--r--packages/net/librsync/librsync.kconfig55
-rw-r--r--packages/net/librsync/librsync.mk38
-rw-r--r--packages/net/net.kconfig5
-rw-r--r--packages/net/net.mk3
4 files changed, 100 insertions, 1 deletions
diff --git a/packages/net/librsync/librsync.kconfig b/packages/net/librsync/librsync.kconfig
new file mode 100644
index 0000000..f5245ba
--- /dev/null
+++ b/packages/net/librsync/librsync.kconfig
@@ -0,0 +1,55 @@
+################################################################################
+# Embtoolkit
+# Copyright(C) 2014 Abdoulaye Walsimou GAYE.
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+################################################################################
+#
+# \file librsync.kconfig
+# \brief librsync.kconfig of Embtoolkit
+# \author Abdoulaye Walsimou GAYE <awg@embtoolkit.org>
+# \date January 2014
+################################################################################
+
+config EMBTK_HAVE_LIBRSYNC
+ bool "Have librsync"
+ help
+ The librsync library implements network delta-compression of streams
+ and files. The algorithm is similar to that used in the rsync(1) and
+ xdelta(2) programs, but specialized for transfer of arbitrary-length
+ octet streams.
+ Unlike most diff programs, librsync does not require access to both of
+ the files on the same machine, but rather only a short ``signature'' of
+ the old file and the complete contents of the new file.
+ See http://librsync.sourceforge.net
+
+choice
+ prompt "librsync version you wish"
+ depends on EMBTK_HAVE_LIBRSYNC
+ help
+ Here you can choose which version of librsync you want to use.
+
+ config EMBTK_LIBRSYNC_VERSION_0_9_7
+ bool "librsync-0.9.7"
+endchoice
+
+config EMBTK_LIBRSYNC_VERSION_STRING
+ string
+ default "0.9.7" if EMBTK_LIBRSYNC_VERSION_0_9_7
+
+config EMBTK_LIBRSYNC_NEED_PATCH
+ bool
+config EMBTK_LIBRSYNC_NEED_AUTORECONF
+ bool
diff --git a/packages/net/librsync/librsync.mk b/packages/net/librsync/librsync.mk
new file mode 100644
index 0000000..bf066ed
--- /dev/null
+++ b/packages/net/librsync/librsync.mk
@@ -0,0 +1,38 @@
+################################################################################
+# Embtoolkit
+# Copyright(C) 2014 Abdoulaye Walsimou GAYE.
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+################################################################################
+#
+# \file librsync.mk
+# \brief librsync.mk of Embtoolkit
+# \author Abdoulaye Walsimou GAYE <awg@embtoolkit.org>
+# \date January 2014
+################################################################################
+
+LIBRSYNC_NAME := librsync
+LIBRSYNC_VERSION := $(call embtk_get_pkgversion,librsync)
+LIBRSYNC_SITE := http://prdownloads.sourceforge.net/librsync
+LIBRSYNC_PACKAGE := librsync-$(LIBRSYNC_VERSION).tar.gz
+LIBRSYNC_SRC_DIR := $(embtk_pkgb)/librsync-$(LIBRSYNC_VERSION)
+LIBRSYNC_BUILD_DIR := $(embtk_pkgb)/librsync-$(LIBRSYNC_VERSION)
+
+LIBRSYNC_BINS := rdiff
+LIBRSYNC_INCLUDES := librsync-config.h librsync.h
+LIBRSYNC_LIBS := librsync.*
+LIBRSYNC_CONFIGURE_OPTS := --enable-shared --disable-trace
+
+LIBRSYNC_DEPS := popt_install
diff --git a/packages/net/net.kconfig b/packages/net/net.kconfig
index 4176be5..95bba81 100644
--- a/packages/net/net.kconfig
+++ b/packages/net/net.kconfig
@@ -1,6 +1,6 @@
################################################################################
# Embtoolkit
-# Copyright(C) 2012-2013 Abdoulaye Walsimou GAYE.
+# Copyright(C) 2012-2014 Abdoulaye Walsimou GAYE.
#
# This program is free software: you can redistribute it and/or modify
# it under the terms of the GNU General Public License as published by
@@ -35,6 +35,9 @@ source packages/net/libnl/libnl.kconfig
# libpcap
source packages/net/libpcap/libpcap.kconfig
+# librsync
+source packages/net/librsync/librsync.kconfig
+
# libtirpc
source packages/net/libtirpc/libtirpc.kconfig
diff --git a/packages/net/net.mk b/packages/net/net.mk
index 42db5f2..30cce44 100644
--- a/packages/net/net.mk
+++ b/packages/net/net.mk
@@ -37,6 +37,9 @@ $(call embtk_include_pkg,libnl)
# libpcap
$(call embtk_include_pkg,libpcap)
+# librsync
+$(call embtk_include_pkg,librsync)
+
# libtirpc
$(call embtk_include_pkg,libtirpc)