summaryrefslogtreecommitdiff
path: root/packages/net
diff options
context:
space:
mode:
authorAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2012-05-23 22:57:17 +0200
committerAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2012-05-23 22:57:17 +0200
commitbb58e82b386b6b60fe02d0304b5275100987e77d (patch)
treea2b41d9a4062bd333f6d87ea4996278da8af2723 /packages/net
parent6a34c9370c1c16d72c84062f84c163c70d2f4ae0 (diff)
downloadembtoolkit-bb58e82b386b6b60fe02d0304b5275100987e77d.tar.gz
embtoolkit-bb58e82b386b6b60fe02d0304b5275100987e77d.tar.bz2
embtoolkit-bb58e82b386b6b60fe02d0304b5275100987e77d.tar.xz
Packages: Iptables: move it under packages/net
Signed-off-by: Abdoulaye Walsimou Gaye <awg@embtoolkit.org>
Diffstat (limited to 'packages/net')
-rw-r--r--packages/net/iptables/iptables.kconfig61
-rw-r--r--packages/net/iptables/iptables.mk41
-rw-r--r--packages/net/net.kconfig27
-rw-r--r--packages/net/net.mk28
4 files changed, 157 insertions, 0 deletions
diff --git a/packages/net/iptables/iptables.kconfig b/packages/net/iptables/iptables.kconfig
new file mode 100644
index 0000000..1852cf8
--- /dev/null
+++ b/packages/net/iptables/iptables.kconfig
@@ -0,0 +1,61 @@
+################################################################################
+# Embtoolkit
+# Copyright(C) 2012 Averell KINOUANI <a.kinouani@voila.fr>
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+################################################################################
+#
+# \file iptables.kconfig
+# \brief iptables.kconfig of Embtoolkit
+# \author Averell KINOUANI, <a.kinouani@voila.fr>
+# \date May 2012
+################################################################################
+
+config EMBTK_HAVE_IPTABLES
+ bool "Have Iptables"
+ select KEMBTK_UCLIBC_UCLIBC_HAS_FLOATS if EMBTK_CLIB_UCLIBC
+ select KEMBTK_UCLIBC_DO_C99_MATH if EMBTK_CLIB_UCLIBC
+ help
+ iptables is the userspace command line program used to configure
+ the Linux 2.4.x and 2.6.x IPv4 packet filtering ruleset.
+ It is target towards system administrators.
+ Since Network Address Translation is also configured from the
+ packet filter ruleset, iptables is used for Sthis, too.
+
+choice
+ prompt "Iptables version you wish"
+ depends on EMBTK_HAVE_IPTABLES
+ help
+ Here you can choose which version of iptables you want to use.
+ config EMBTK_IPTABLES_VERSION_1_4_13
+ bool "iptables-1.4.13"
+
+endchoice
+
+config EMBTK_IPTABLES_HAVE_LIBIPQ
+ bool "Have Libipq"
+ depends on EMBTK_HAVE_IPTABLES
+ help
+ libipq is a developpement library for iptables userspace packet
+ queuing. libipq provides an API for communicating with ip_queue.
+
+config EMBTK_IPTABLES_VERSION_STRING
+ string
+ default "1.4.13" if EMBTK_IPTABLES_VERSION_1_4_13
+
+config EMBTK_IPTABLES_NEED_PATCH
+ bool
+config EMBTK_IPTABLES_NEED_AUTORECONF
+ bool
diff --git a/packages/net/iptables/iptables.mk b/packages/net/iptables/iptables.mk
new file mode 100644
index 0000000..e42523d
--- /dev/null
+++ b/packages/net/iptables/iptables.mk
@@ -0,0 +1,41 @@
+################################################################################
+# Embtoolkit
+# Copyright(C) 2012 Averell KINOUANI <a.kinouani@voila.fr>
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+################################################################################
+#
+# \file iptables.mk
+# \brief iptables.mk of Embtoolkit
+# \author Averell KINOUANI <a.kinouani@voila.fr>
+# \date May 2012
+################################################################################
+
+IPTABLES_NAME := iptables
+IPTABLES_VERSION := $(call embtk_get_pkgversion,iptables)
+IPTABLES_SITE := ftp://ftp.netfilter.org/pub/iptables
+IPTABLES_PACKAGE := iptables-$(IPTABLES_VERSION).tar.bz2
+IPTABLES_SRC_DIR := $(PACKAGES_BUILD)/iptables-$(IPTABLES_VERSION)
+IPTABLES_BUILD_DIR := $(PACKAGES_BUILD)/iptables-$(IPTABLES_VERSION)
+
+IPTABLES_SBINS := iptables ip6tables ip6tables-restore ip6tables-save
+IPTABLES_SBINS += iptables-restore iptables-save
+IPTABLES_INCLUDES := ipt_kernel_headers.h libip6tc.h libiptc.h
+IPTABLES_INCLUDES += libxtc.h xtables.h xtcshared.h
+IPTABLES_LIBS := libip4tc.so.0 libip4tc.so.0 libxtables.so.7
+
+ifeq ($(CONFIG_EMBTK_IPTABLES_HAVE_LIBIPQ),y)
+IPTABLES_CONFIGURE_OPTS := --enable-libipq
+endif
diff --git a/packages/net/net.kconfig b/packages/net/net.kconfig
new file mode 100644
index 0000000..1b0d79a
--- /dev/null
+++ b/packages/net/net.kconfig
@@ -0,0 +1,27 @@
+################################################################################
+# Embtoolkit
+# Copyright(C) 2012 Abdoulaye Walsimou GAYE.
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+################################################################################
+#
+# \file net.kconfig
+# \brief net.kconfig of Embtoolkit
+# \author Abdoulaye Walsimou GAYE <awg@embtoolkit.org>
+# \date May 2012
+################################################################################
+
+# Iptables
+source packages/net/iptables/iptables.kconfig
diff --git a/packages/net/net.mk b/packages/net/net.mk
new file mode 100644
index 0000000..be74343
--- /dev/null
+++ b/packages/net/net.mk
@@ -0,0 +1,28 @@
+################################################################################
+# Embtoolkit
+# Copyright(C) 2012 Abdoulaye Walsimou GAYE.
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+################################################################################
+#
+# \file net.mk
+# \brief net.mk of Embtoolkit
+# \author Abdoulaye Walsimou GAYE <awg@embtoolkit.org>
+# \date May 2012
+################################################################################
+
+# Iptables
+include $(EMBTK_ROOT)/packages/net/iptables/iptables.mk
+ROOTFS_COMPONENTS-$(CONFIG_EMBTK_HAVE_IPTABLES) += iptables_install