summaryrefslogtreecommitdiff
path: root/packages/scripting-languages
diff options
context:
space:
mode:
authorAbdoulaye Walsimou Gaye <awg@embtoolkit.com>2010-07-03 11:50:54 +0200
committerAbdoulaye Walsimou Gaye <awg@embtoolkit.com>2010-07-03 11:54:23 +0200
commit80eb1eea52b0edbe77fcef35fc980be9c345ceb5 (patch)
treee262d6cbca93cc5896cdcc5a1e727e50ab767ccc /packages/scripting-languages
parent84973bf70cb1cbe39ede8fb783e23f06cbdb36ed (diff)
downloadembtoolkit-80eb1eea52b0edbe77fcef35fc980be9c345ceb5.tar.gz
embtoolkit-80eb1eea52b0edbe77fcef35fc980be9c345ceb5.tar.bz2
embtoolkit-80eb1eea52b0edbe77fcef35fc980be9c345ceb5.tar.xz
Packages: New Lua: add lua-5.1 among scripting languages
Signed-off-by: Abdoulaye Walsimou Gaye <awg@embtoolkit.com>
Diffstat (limited to 'packages/scripting-languages')
-rw-r--r--packages/scripting-languages/scripting-languages.kconfig32
-rw-r--r--packages/scripting-languages/scripting-languages.mk32
2 files changed, 35 insertions, 29 deletions
diff --git a/packages/scripting-languages/scripting-languages.kconfig b/packages/scripting-languages/scripting-languages.kconfig
index f823533..b2d4408 100644
--- a/packages/scripting-languages/scripting-languages.kconfig
+++ b/packages/scripting-languages/scripting-languages.kconfig
@@ -1,28 +1,28 @@
################################################################################
-# GAYE Abdoulaye Walsimou, <walsimou@walsimou.com>
-# Copyright(C) 2010 GAYE Abdoulaye Walsimou. All rights reserved.
-# For Copyrright from linux kernel's build/configure system, see their source
-# code.
+# Abdoulaye Walsimou GAYE <awg@embtoolkit.org>
+# Copyright(C) 2010 Abdoulaye Walsimou GAYE. All rights reserved.
#
-# This program is free software; you can distribute it and/or modify it
-# under the terms of the GNU General Public License
-# (Version 2 or later) published by the Free Software Foundation.
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
#
-# This program is distributed in the hope it will be useful, but WITHOUT
-# ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or
-# FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License
-# for more details.
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
#
-# You should have received a copy of the GNU General Public License along
-# with this program; if not, write to the Free Software Foundation, Inc.,
-# 59 Temple Place - Suite 330, Boston MA 02111-1307, USA.
################################################################################
#
# \file scripting-languages.kconfig
# \brief scripting-languages.kconfig of Embtoolkit
-# \author GAYE Abdoulaye Walsimou, <walsimou@walsimou.com>
+# \author Abdoulaye Walsimou GAYE <awg@embtoolkit.org>
# \date February 2010
################################################################################
-source packages/security/openssl/openssl.kconfig
+source packages/scripting-languages/lua/lua.kconfig
+source packages/scripting-languages/perl/perl.kconfig
diff --git a/packages/scripting-languages/scripting-languages.mk b/packages/scripting-languages/scripting-languages.mk
index e41de7d..fbb35a5 100644
--- a/packages/scripting-languages/scripting-languages.mk
+++ b/packages/scripting-languages/scripting-languages.mk
@@ -1,27 +1,33 @@
################################################################################
-# GAYE Abdoulaye Walsimou, <walsimou@walsimou.com>
-# Copyright(C) 2010 GAYE Abdoulaye Walsimou. All rights reserved.
+# Abdoulaye Walsimou GAYE <awg@embtoolkit.org>
+# Copyright(C) 2010 Abdoulaye Walsimou GAYE. All rights reserved.
#
-# This program is free software; you can distribute it and/or modify it
-# under the terms of the GNU General Public License
-# (Version 2 or later) published by the Free Software Foundation.
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
#
-# This program is distributed in the hope it will be useful, but WITHOUT
-# ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or
-# FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License
-# for more details.
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
#
-# You should have received a copy of the GNU General Public License along
-# with this program; if not, write to the Free Software Foundation, Inc.,
-# 59 Temple Place - Suite 330, Boston MA 02111-1307, USA.
################################################################################
#
# \file scripting-languages.mk
# \brief scripting-languages.mk of Embtoolkit
-# \author GAYE Abdoulaye Walsimou, <walsimou@walsimou.com>
+# \author Abdoulaye Walsimou GAYE <awg@embtoolkit.org>
# \date February 2010
################################################################################
+#lua
+include $(EMBTK_ROOT)/packages/scripting-languages/lua/lua.mk
+ROOTFS_COMPONENTS_CLEAN += lua_clean
+ROOTFS_COMPONENTS-$(CONFIG_EMBTK_HAVE_LUA) += lua_install
+
#microperl
include $(EMBTK_ROOT)/packages/scripting-languages/perl/perl.mk
ROOTFS_COMPONENTS-$(CONFIG_EMBTK_HAVE_MICROPERL) += microperl_install