summaryrefslogtreecommitdiff
path: root/packages/scripting-languages
diff options
context:
space:
mode:
authorAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2012-04-23 00:06:45 +0200
committerAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2012-04-23 00:06:45 +0200
commit898d16bd62f51b3dce905c3238386122963db8ee (patch)
treeda675712ab2c4f65d9cd9f705fb18e28cff5220e /packages/scripting-languages
parentc06cb3db3a88dd617fdd80a56dc9dff3910f7dcf (diff)
downloadembtoolkit-898d16bd62f51b3dce905c3238386122963db8ee.tar.gz
embtoolkit-898d16bd62f51b3dce905c3238386122963db8ee.tar.bz2
embtoolkit-898d16bd62f51b3dce905c3238386122963db8ee.tar.xz
Packages: lua: add luafilesystem-1.5.0 module
Signed-off-by: Abdoulaye Walsimou Gaye <awg@embtoolkit.org>
Diffstat (limited to 'packages/scripting-languages')
-rw-r--r--packages/scripting-languages/lua-modules/luafilesystem/luafilesystem.kconfig52
-rw-r--r--packages/scripting-languages/lua-modules/luafilesystem/luafilesystem.mk50
-rw-r--r--packages/scripting-languages/scripting-languages.kconfig7
-rw-r--r--packages/scripting-languages/scripting-languages.mk5
4 files changed, 113 insertions, 1 deletions
diff --git a/packages/scripting-languages/lua-modules/luafilesystem/luafilesystem.kconfig b/packages/scripting-languages/lua-modules/luafilesystem/luafilesystem.kconfig
new file mode 100644
index 0000000..63a80e5
--- /dev/null
+++ b/packages/scripting-languages/lua-modules/luafilesystem/luafilesystem.kconfig
@@ -0,0 +1,52 @@
+################################################################################
+# Embtoolkit
+# Copyright(C) 2012 Abdoulaye Walsimou GAYE.
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+################################################################################
+#
+# \file luafilesystem.kconfig
+# \brief luafilesystem.kconfig of Embtoolkit
+# \author Abdoulaye Walsimou GAYE <awg@embtoolkit.org>
+# \date April 2012
+################################################################################
+
+config EMBTK_HAVE_LUAFILESYSTEM
+ bool "Have LuaFileSystem module"
+ depends on EMBTK_HAVE_LUA
+ select EMBTK_LUAFILESYSTEM_NEED_PATCH
+ help
+ LuaFileSystem is a Lua library developed to complement the set
+ of functions related to file systems offered by the standard Lua
+ distribution.
+ LuaFileSystem offers a portable way to access the underlying
+ directory structure and file attributes.
+
+choice
+ prompt "LuaFileSystem version you wish"
+ depends on EMBTK_HAVE_LUAFILESYSTEM
+ help
+ Here you can choose which version of LuaFileSystem you want to use.
+
+ config EMBTK_LUAFILESYSTEM_VERSION_1_5_0
+ bool "LuaFileSystem-1.5.0"
+endchoice
+
+config EMBTK_LUAFILESYSTEM_VERSION_STRING
+ string
+ default "1.5.0" if EMBTK_LUAFILESYSTEM_VERSION_1_5_0
+
+config EMBTK_LUAFILESYSTEM_NEED_PATCH
+ bool
diff --git a/packages/scripting-languages/lua-modules/luafilesystem/luafilesystem.mk b/packages/scripting-languages/lua-modules/luafilesystem/luafilesystem.mk
new file mode 100644
index 0000000..ff1d413
--- /dev/null
+++ b/packages/scripting-languages/lua-modules/luafilesystem/luafilesystem.mk
@@ -0,0 +1,50 @@
+################################################################################
+# Embtoolkit
+# Copyright(C) 2012 Abdoulaye Walsimou GAYE.
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+################################################################################
+#
+# \file luafilesystem.mk
+# \brief luafilesystem.mk of Embtoolkit
+# \author Abdoulaye Walsimou GAYE <awg@embtoolkit.org>
+# \date April 2012
+################################################################################
+
+LUAFILESYSTEM_NAME := luafilesystem
+LUAFILESYSTEM_VERSION := $(call embtk_get_pkgversion,luafilesystem)
+LUAFILESYSTEM_SITE := https://github.com/downloads/keplerproject/luafilesystem
+LUAFILESYSTEM_PACKAGE := luafilesystem-$(LUAFILESYSTEM_VERSION).tar.gz
+LUAFILESYSTEM_SRC_DIR := $(PACKAGES_BUILD)/luafilesystem-$(LUAFILESYSTEM_VERSION)
+LUAFILESYSTEM_BUILD_DIR := $(PACKAGES_BUILD)/luafilesystem-$(LUAFILESYSTEM_VERSION)
+
+LUAFILESYSTEM_LIBS =
+
+LUAFILESYSTEM_DEPS = lua_install
+
+LUAFILESYSTEM_MAKE_OPTS = PREFIX=$(SYSROOT)/usr/ LIBDIR=$(LIBDIR)
+LUAFILESYSTEM_MAKE_OPTS += CC=$(TARGETCC_CACHED)
+LUAFILESYSTEM_MAKE_OPTS += LDFLAGS="-L$(SYSROOT)/$(LIBDIR) -L$(SYSROOT)/usr/$(LIBDIR)"
+LUAFILESYSTEM_MAKE_OPTS += CFLAGS="$(TARGET_CFLAGS) -I$(SYSROOT)/usr/include"
+
+luafilesystem_install:
+ $(call embtk_makeinstall_pkg,luafilesystem)
+
+define embtk_postinstall_luafilesystem
+ $(Q)mkdir -p $(ROOTFS)
+ $(Q)mkdir -p $(ROOTFS)/usr
+ $(Q)mkdir -p $(ROOTFS)/usr/$(LIBDIR)
+ $(Q)cp -R $(SYSROOT)/usr/$(LIBDIR)/lua $(ROOTFS)/usr/$(LIBDIR)/
+endef
diff --git a/packages/scripting-languages/scripting-languages.kconfig b/packages/scripting-languages/scripting-languages.kconfig
index 2676a17..3fe0966 100644
--- a/packages/scripting-languages/scripting-languages.kconfig
+++ b/packages/scripting-languages/scripting-languages.kconfig
@@ -23,6 +23,13 @@
# \date February 2010
################################################################################
+# LUA and modules
source packages/scripting-languages/lua/lua.kconfig
+comment "------------------------------------"
+comment "---- Lua Modules"
+comment "------------------------------------"
+source packages/scripting-languages/lua-modules/luafilesystem/luafilesystem.kconfig
+
+# microperl
source packages/scripting-languages/perl/perl.kconfig
diff --git a/packages/scripting-languages/scripting-languages.mk b/packages/scripting-languages/scripting-languages.mk
index f266c4e..a989eaf 100644
--- a/packages/scripting-languages/scripting-languages.mk
+++ b/packages/scripting-languages/scripting-languages.mk
@@ -23,10 +23,13 @@
# \date February 2010
################################################################################
-#lua
+# LUA and modules
include $(EMBTK_ROOT)/packages/scripting-languages/lua/lua.mk
ROOTFS_COMPONENTS-$(CONFIG_EMBTK_HAVE_LUA) += lua_install
+include $(EMBTK_ROOT)/packages/scripting-languages/lua-modules/luafilesystem/luafilesystem.mk
+ROOTFS_COMPONENTS-$(CONFIG_EMBTK_HAVE_LUAFILESYSTEM) += luafilesystem_install
+
#microperl
include $(EMBTK_ROOT)/packages/scripting-languages/perl/perl.mk
ROOTFS_COMPONENTS-$(CONFIG_EMBTK_HAVE_MICROPERL) += microperl_install