summaryrefslogtreecommitdiff
path: root/packages/scripting-languages
diff options
context:
space:
mode:
authorAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2012-04-30 22:43:14 +0200
committerAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2012-04-30 22:43:14 +0200
commitc0515d79a0171f405ace6a7f1cdf155d61783e1f (patch)
tree95e4be95de2bf3aa533d6eb9151e42429c7d51a2 /packages/scripting-languages
parenta7c141e68fa153a6594bbf9891390d2ec417fccc (diff)
downloadembtoolkit-c0515d79a0171f405ace6a7f1cdf155d61783e1f.tar.gz
embtoolkit-c0515d79a0171f405ace6a7f1cdf155d61783e1f.tar.bz2
embtoolkit-c0515d79a0171f405ace6a7f1cdf155d61783e1f.tar.xz
Packages: lua modules: add cgilua-5.1.4 + wsapi parts needed
Signed-off-by: Abdoulaye Walsimou Gaye <awg@embtoolkit.org>
Diffstat (limited to 'packages/scripting-languages')
-rw-r--r--packages/scripting-languages/lua-modules/cgilua/cgilua.kconfig57
-rw-r--r--packages/scripting-languages/lua-modules/cgilua/cgilua.mk47
2 files changed, 104 insertions, 0 deletions
diff --git a/packages/scripting-languages/lua-modules/cgilua/cgilua.kconfig b/packages/scripting-languages/lua-modules/cgilua/cgilua.kconfig
new file mode 100644
index 0000000..43f157a
--- /dev/null
+++ b/packages/scripting-languages/lua-modules/cgilua/cgilua.kconfig
@@ -0,0 +1,57 @@
+################################################################################
+# Embtoolkit
+# Copyright(C) 2012 Abdoulaye Walsimou GAYE.
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+################################################################################
+#
+# \file cgilua.kconfig
+# \brief cgilua.kconfig of Embtoolkit
+# \author Abdoulaye Walsimou GAYE <awg@embtoolkit.org>
+# \date April 2012
+################################################################################
+
+config EMBTK_HAVE_CGILUA
+ bool "Have cgilua module"
+ depends on EMBTK_HAVE_LUA
+ depends on EMBTK_HAVE_RINGS
+ depends on EMBTK_HAVE_LUAFILESYSTEM
+ select EMBTK_CGILUA_NEED_PATCH
+ help
+ CGILua is a tool for creating dynamic Web pages and manipulating
+ input data from Web forms. CGILua allows the separation of logic
+ and data handling from the generation of pages, making it easy
+ to develop web applications with Lua.
+ One of advantages of CGILua is its abstraction of the underlying
+ Web server. CGILua can be used with a variety of Web servers
+ and, for each server, with different launchers. A launcher is
+ responsible for the interaction of CGILua and the Web server.
+
+choice
+ prompt "cgilua version you wish"
+ depends on EMBTK_HAVE_CGILUA
+ help
+ Here you can choose which version of cgilua you want to use.
+
+ config EMBTK_CGILUA_VERSION_5_1_4
+ bool "cgilua-5.1.4"
+endchoice
+
+config EMBTK_CGILUA_VERSION_STRING
+ string
+ default "5.1.4" if EMBTK_CGILUA_VERSION_5_1_4
+
+config EMBTK_CGILUA_NEED_PATCH
+ bool
diff --git a/packages/scripting-languages/lua-modules/cgilua/cgilua.mk b/packages/scripting-languages/lua-modules/cgilua/cgilua.mk
new file mode 100644
index 0000000..003066b
--- /dev/null
+++ b/packages/scripting-languages/lua-modules/cgilua/cgilua.mk
@@ -0,0 +1,47 @@
+################################################################################
+# Embtoolkit
+# Copyright(C) 2012 Abdoulaye Walsimou GAYE.
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+################################################################################
+#
+# \file cgilua.mk
+# \brief cgilua.mk of Embtoolkit
+# \author Abdoulaye Walsimou GAYE <awg@embtoolkit.org>
+# \date April 2012
+################################################################################
+
+CGILUA_NAME := cgilua
+CGILUA_VERSION := $(call embtk_get_pkgversion,cgilua)
+CGILUA_SITE := https://github.com/downloads/keplerproject/cgilua
+CGILUA_PACKAGE := cgilua-$(CGILUA_VERSION).tar.gz
+CGILUA_SRC_DIR := $(PACKAGES_BUILD)/cgilua-$(CGILUA_VERSION)
+CGILUA_BUILD_DIR := $(PACKAGES_BUILD)/cgilua-$(CGILUA_VERSION)
+
+CGILUA_LIBS =
+
+CGILUA_DEPS = lua_install luafilesystem_install rings_install
+
+CGILUA_MAKE_OPTS = PREFIX=$(SYSROOT)/usr/
+
+cgilua_install:
+ $(call embtk_makeinstall_pkg,cgilua)
+
+define embtk_postinstall_cgilua
+ $(Q)mkdir -p $(ROOTFS)
+ $(Q)mkdir -p $(ROOTFS)/usr
+ $(Q)mkdir -p $(ROOTFS)/usr/share
+ $(Q)cp -R $(SYSROOT)/usr/share/lua $(ROOTFS)/usr/share/
+endef