summaryrefslogtreecommitdiff
path: root/packages/security
diff options
context:
space:
mode:
authorAbdoulaye Walsimou Gaye <walsimou@walsimou.com>2010-02-14 23:39:10 +0100
committerAbdoulaye Walsimou Gaye <walsimou@walsimou.com>2010-02-14 23:39:10 +0100
commita16b2770979813e7f1869dda084a82a131f8c734 (patch)
treecbe46762731048d7d0a8b553e90bb4afb2c77647 /packages/security
parent2533274078fbd7a862bb995d627c650c20b06e89 (diff)
downloadembtoolkit-a16b2770979813e7f1869dda084a82a131f8c734.tar.gz
embtoolkit-a16b2770979813e7f1869dda084a82a131f8c734.tar.bz2
embtoolkit-a16b2770979813e7f1869dda084a82a131f8c734.tar.xz
Packages: openssl: fix build for 64 bits systems
Signed-off-by: Abdoulaye Walsimou Gaye <walsimou@walsimou.com>
Diffstat (limited to 'packages/security')
-rw-r--r--packages/security/openssl/openssl.mk11
1 files changed, 10 insertions, 1 deletions
diff --git a/packages/security/openssl/openssl.mk b/packages/security/openssl/openssl.mk
index 3ab493b..aca6544 100644
--- a/packages/security/openssl/openssl.mk
+++ b/packages/security/openssl/openssl.mk
@@ -38,6 +38,14 @@ OPENSSL_LIBS = engines/lib4758cca.so engines/libaep.so engines/libatalla.so \
engines/libubsec.so libcrypto.* libssl.*
OPENSSL_PKGCONFIGS = libcrypto.pc libssl.pc openssl.pc
+ifeq ($(CONFIG_EMBTK_64BITS_FS_COMPAT32),y)
+OPENSSL_LINUX_TARGET := linux-generic32
+else ifeq ($(CONFIG_EMBTK_64BITS_FS),y)
+OPENSSL_LINUX_TARGET := linux-generic64
+else
+OPENSSL_LINUX_TARGET := linux-generic32
+endif
+
openssl_install: $(OPENSSL_BUILD_DIR)/.installed
$(OPENSSL_BUILD_DIR)/.installed: download_openssl \
@@ -81,7 +89,8 @@ endif
$(OPENSSL_BUILD_DIR)/.configured:
$(Q)cd $(OPENSSL_BUILD_DIR); \
- ./Configure linux-generic32 --openssldir=/etc/ssl --prefix=/usr shared
+ ./Configure $(OPENSSL_LINUX_TARGET) \
+ --openssldir=/etc/ssl --prefix=/usr shared
@touch $@
openssl_clean: