summaryrefslogtreecommitdiff
path: root/packages/security
diff options
context:
space:
mode:
authorAverell Kinouani <a.kinouani@voila.fr>2012-05-23 20:50:52 +0200
committerAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2012-05-23 21:34:20 +0200
commitc421f6d63cd8e808247c0681b61b30898b6f7c61 (patch)
tree06367ccd50ed48f4e44eac02996387fa7978781d /packages/security
parent4cb71c2dea85f067f28d2b1bbe5dccf986f0b7fe (diff)
downloadembtoolkit-c421f6d63cd8e808247c0681b61b30898b6f7c61.tar.gz
embtoolkit-c421f6d63cd8e808247c0681b61b30898b6f7c61.tar.bz2
embtoolkit-c421f6d63cd8e808247c0681b61b30898b6f7c61.tar.xz
New package:add iptables
Signed-off-by: Averell Kinouani <a.kinouani@voila.fr>
Diffstat (limited to 'packages/security')
-rw-r--r--packages/security/iptables/iptables.kconfig65
-rw-r--r--packages/security/iptables/iptables.mk48
2 files changed, 113 insertions, 0 deletions
diff --git a/packages/security/iptables/iptables.kconfig b/packages/security/iptables/iptables.kconfig
new file mode 100644
index 0000000..1326eef
--- /dev/null
+++ b/packages/security/iptables/iptables.kconfig
@@ -0,0 +1,65 @@
+################################################################################
+# Embtoolkit
+# Copyright(C)
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+################################################################################
+#
+# \file iptables.kconfig
+# \brief iptables.kconfig of Embtoolkit
+# \author Averell KINOUANI, <a.kinouani@voila.fr>
+# \date May 2012
+################################################################################
+
+config EMBTK_HAVE_IPTABLES
+ bool "Have Iptables"
+ select KEMBTK_UCLIBC_UCLIBC_HAS_FLOATS if EMBTK_CLIB_UCLIBC
+ select KEMBTK_UCLIBC_DO_C99_MATH if EMBTK_CLIB_UCLIBC
+ help
+ iptables is the userspace command line program used to configure
+ the Linux 2.4.x and 2.6.x IPv4 packet filtering ruleset. It is
+ target towards system administrators. Since Network Address Translation
+ is also configured from the packet filter ruleset, iptables is used for
+ this, too.
+choice
+ prompt "Iptables version you wish"
+ depends on EMBTK_HAVE_IPTABLES
+ help
+ Here you can choose which version of iptables you want to use.
+ config EMBTK_IPTABLES_VERSION_1_4_13
+ bool "iptables-1.4.13"
+
+endchoice
+
+
+config EMBTK_IPTABLES_HAVE_LIBIPQ
+ bool "Have Libipq"
+ select EMBTK_HAVE_IPTABLES
+ help
+ libipq is a developpement library for iptables userspace packet queuing.
+ libipq provides an API for communicating with ip_queue.
+
+config EMBTK_IPTABLES_VERSION_STRING
+ string
+ default "1.4.13" if EMBTK_IPTABLES_VERSION_1_4_13
+
+config EMBTK_IPTABLES_NEED_PATCH
+ bool
+config EMBTK_IPTABLES_NEED_AUTORECONF
+ bool
+config EMBTK_IPTABLES_PKG_IS_TARGZ
+ bool
+config EMBTK_IPTABLES_PKG_IS_TARBZ2
+ bool
diff --git a/packages/security/iptables/iptables.mk b/packages/security/iptables/iptables.mk
new file mode 100644
index 0000000..f5efe6e
--- /dev/null
+++ b/packages/security/iptables/iptables.mk
@@ -0,0 +1,48 @@
+################################################################################
+# Embtoolkit
+# Copyright(C) 2009-2011 Abdoulaye Walsimou GAYE.
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+################################################################################
+#
+# \file iptables.mk
+# \brief iptables.mk of Embtoolkit
+# \author Averell KINOUANI <a.kinouani@voila.fr>
+# \date May 2012
+################################################################################
+
+IPTABLES_NAME := iptables
+IPTABLES_VERSION := $(call embtk_get_pkgversion,iptables)
+IPTABLES_SITE := ftp://ftp.netfilter.org/pub/iptables/
+#IPTABLES_SITE_MIRROR3 := ftp://ftp.embtoolkit.org/embtoolkit.org/packages-mirror
+IPTABLES_PACKAGE := iptables-$(IPTABLES_VERSION).tar.bz2
+IPTABLES_SRC_DIR := $(PACKAGES_BUILD)/iptables-$(IPTABLES_VERSION)
+IPTABLES_BUILD_DIR := $(PACKAGES_BUILD)/iptables-$(IPTABLES_VERSION)
+
+IPTABLES_BINS :=
+IPTABLES_SBINS := iptables ip6tables ip6tables-restore ip6tables-save iptables-restore iptables-save
+IPTABLES_INCLUDES := ipt_kernel_headers.h libip6tc.h libiptc.h libxtc.h xtables.h xtcshared.h
+IPTABLES_LIBS := libip4tc.so.0 libip4tc.so.0 libxtables.so.7
+IPTABLES_LIBEXECS :=
+IPTABLES_PKGCONFIGS :=
+
+IPTABLES_CONFIGURE_ENV :=
+ifeq ($(CONFIG_EMBTK_IPTABLES_HAVE_LIBIPQ),y)
+IPTABLES_CONFIGURE_OPTS := --enable-libipq
+endif
+IPTABLES_MAKE_OPTS :=
+IPTABLES_MAKE_DIRS :=
+
+IPTABLES_DEPS :=