summaryrefslogtreecommitdiff
path: root/packages/security
diff options
context:
space:
mode:
authorAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2011-02-03 22:51:34 +0100
committerAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2011-02-03 22:51:34 +0100
commitc90904878fa5716b429a7f1c916c3052b9cd5073 (patch)
treed20c4ad12a2a698622a2ce3bc7f79c69b1ecd380 /packages/security
parent6c315af823ecda0af638ec317140c95dfc56ee28 (diff)
downloadembtoolkit-c90904878fa5716b429a7f1c916c3052b9cd5073.tar.gz
embtoolkit-c90904878fa5716b429a7f1c916c3052b9cd5073.tar.bz2
embtoolkit-c90904878fa5716b429a7f1c916c3052b9cd5073.tar.xz
Packages: openssl: add openssl-0.9.8q
Signed-off-by: Abdoulaye Walsimou Gaye <awg@embtoolkit.org>
Diffstat (limited to 'packages/security')
-rw-r--r--packages/security/openssl/openssl.kconfig12
-rw-r--r--packages/security/openssl/openssl.mk36
2 files changed, 19 insertions, 29 deletions
diff --git a/packages/security/openssl/openssl.kconfig b/packages/security/openssl/openssl.kconfig
index 675838c..079d376 100644
--- a/packages/security/openssl/openssl.kconfig
+++ b/packages/security/openssl/openssl.kconfig
@@ -25,6 +25,7 @@
config EMBTK_HAVE_OPENSSL
bool "Have OpenSSL"
+ select EMBTK_OPENSSL_PKG_IS_TARGZ
help
The OpenSSL Project is a collaborative effort to develop a
robust, commercial-grade, full-featured, and Open Source toolkit
@@ -36,6 +37,9 @@ choice
depends on EMBTK_HAVE_OPENSSL
help
Here you can choose which version of openssl you want to use.
+
+ config EMBTK_OPENSSL_VERSION_0_9_8Q
+ bool "openssl-0.9.8q"
config EMBTK_OPENSSL_VERSION_0_9_8O
bool "openssl-0.9.8o"
select EMBTK_OPENSSL_NEED_PATCH
@@ -49,10 +53,16 @@ endchoice
config EMBTK_OPENSSL_VERSION_STRING
string
+ default "0.9.8q" if EMBTK_OPENSSL_VERSION_0_9_8Q
default "0.9.8o" if EMBTK_OPENSSL_VERSION_0_9_8O
default "0.9.8n" if EMBTK_OPENSSL_VERSION_0_9_8N
default "0.9.8l" if EMBTK_OPENSSL_VERSION_0_9_8L
config EMBTK_OPENSSL_NEED_PATCH
bool
-
+config EMBTK_OPENSSL_NEED_AUTORECONF
+ bool
+config EMBTK_OPENSSL_PKG_IS_TARGZ
+ bool
+config EMBTK_OPENSSL_PKG_IS_TARBZ2
+ bool
diff --git a/packages/security/openssl/openssl.mk b/packages/security/openssl/openssl.mk
index aae7196..af83f57 100644
--- a/packages/security/openssl/openssl.mk
+++ b/packages/security/openssl/openssl.mk
@@ -23,10 +23,13 @@
# \date February 2010
################################################################################
-OPENSSL_VERSION := $(subst ",,$(strip $(CONFIG_EMBTK_OPENSSL_VERSION_STRING)))
+OPENSSL_NAME := openssl
+OPENSSL_VERSION := $(call EMBTK_GET_PKG_VERSION,OPENSSL)
OPENSSL_SITE := ftp://ftp.openssl.org/source
+OPENSSL_SITE_MIRROR3 := ftp://ftp.embtoolkit.org/embtoolkit.org/packages-mirror
OPENSSL_PATCH_SITE := ftp://ftp.embtoolkit.org/embtoolkit.org/openssl/$(OPENSSL_VERSION)
OPENSSL_PACKAGE := openssl-$(OPENSSL_VERSION).tar.gz
+OPENSSL_SRC_DIR := $(PACKAGES_BUILD)/openssl-$(OPENSSL_VERSION)
OPENSSL_BUILD_DIR := $(PACKAGES_BUILD)/openssl-$(OPENSSL_VERSION)
OPENSSL_ETC = ssl
@@ -62,33 +65,17 @@ ifeq ($(CONFIG_EMBTK_64BITS_FS_COMPAT32),y)
INSTALL_PREFIX=$(SYSROOT)/ LIBDIR=lib32 MANDIR=/usr/share/man install
else
$(Q)$(MAKE) -C $(OPENSSL_BUILD_DIR) \
- INSTALL_PREFIX=$(SYSROOT)/ LIBDIR=lib MANDIR=/usr/share/man install
+ INSTALL_PREFIX=$(SYSROOT) LIBDIR=lib MANDIR=/usr/share/man install
endif
$(Q)$(MAKE) libtool_files_adapt
$(Q)$(MAKE) pkgconfig_files_adapt
@touch $@
download_openssl:
- $(call EMBTK_GENERIC_MESSAGE,"Downloading $(OPENSSL_PACKAGE) \
- if necessary...")
- @test -e $(DOWNLOAD_DIR)/$(OPENSSL_PACKAGE) || \
- wget -O $(DOWNLOAD_DIR)/$(OPENSSL_PACKAGE) \
- $(OPENSSL_SITE)/$(OPENSSL_PACKAGE)
-ifeq ($(CONFIG_EMBTK_OPENSSL_NEED_PATCH),y)
- @test -e $(DOWNLOAD_DIR)/openssl-$(OPENSSL_VERSION).patch || \
- wget $(OPENSSL_PATCH_SITE)/openssl-$(OPENSSL_VERSION)-*.patch \
- -O $(DOWNLOAD_DIR)/openssl-$(OPENSSL_VERSION).patch
-endif
-
+ $(call EMBTK_DOWNLOAD_PKG,OPENSSL)
$(OPENSSL_BUILD_DIR)/.decompressed:
- $(call EMBTK_GENERIC_MESSAGE,"Decompressing $(OPENSSL_PACKAGE) ...")
- @tar -C $(PACKAGES_BUILD) -xzf $(DOWNLOAD_DIR)/$(OPENSSL_PACKAGE)
-ifeq ($(CONFIG_EMBTK_OPENSSL_NEED_PATCH),y)
- cd $(OPENSSL_BUILD_DIR); \
- patch -p1 < $(DOWNLOAD_DIR)/openssl-$(OPENSSL_VERSION).patch
-endif
- @touch $@
+ $(call EMBTK_DECOMPRESS_PKG,OPENSSL)
$(OPENSSL_BUILD_DIR)/.configured:
$(Q)cd $(OPENSSL_BUILD_DIR); \
@@ -97,14 +84,7 @@ $(OPENSSL_BUILD_DIR)/.configured:
@touch $@
openssl_clean:
- $(call EMBTK_GENERIC_MESSAGE,"cleanup openssl-$(OPENSSL_VERSION)...")
- $(Q)-cd $(SYSROOT)/usr/bin; rm -rf $(OPENSSL_BINS)
- $(Q)-cd $(SYSROOT)/usr/sbin; rm -rf $(OPENSSL_SBINS)
- $(Q)-cd $(SYSROOT)/usr/include; rm -rf $(OPENSSL_INCLUDES)
- $(Q)-cd $(SYSROOT)/usr/$(LIBDIR); rm -rf $(OPENSSL_LIBS)
- $(Q)-cd $(SYSROOT)/usr/$(LIBDIR)/pkgconfig; rm -rf $(OPENSSL_PKGCONFIGS)
- $(Q)-cd $(SYSROOT)/etc; rm -rf $(OPENSSL_ETC)
- $(Q)-rm -rf $(OPENSSL_BUILD_DIR)*
+ $(call EMBTK_CLEANUP_PKG,OPENSSL)
.PHONY: $(OPENSSL_BUILD_DIR)/.special