summaryrefslogtreecommitdiff
path: root/packages/security
diff options
context:
space:
mode:
authorAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2010-07-07 23:43:20 +0200
committerAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2010-07-07 23:43:20 +0200
commitf3db899a539e6070260a1e45176721bd0fac6cb7 (patch)
treec0e51880a2adf1040a2711f5ff6297ab452d3468 /packages/security
parentc61a1a262318a0c76ae5a5096427cbc5fd56d196 (diff)
downloadembtoolkit-f3db899a539e6070260a1e45176721bd0fac6cb7.tar.gz
embtoolkit-f3db899a539e6070260a1e45176721bd0fac6cb7.tar.bz2
embtoolkit-f3db899a539e6070260a1e45176721bd0fac6cb7.tar.xz
Packages: openssl: add openssl-0.9.8o
Signed-off-by: Abdoulaye Walsimou Gaye <awg@embtoolkit.org>
Diffstat (limited to 'packages/security')
-rw-r--r--packages/security/openssl/openssl.kconfig27
-rw-r--r--packages/security/openssl/openssl.mk27
2 files changed, 30 insertions, 24 deletions
diff --git a/packages/security/openssl/openssl.kconfig b/packages/security/openssl/openssl.kconfig
index 01c588b..833a16b 100644
--- a/packages/security/openssl/openssl.kconfig
+++ b/packages/security/openssl/openssl.kconfig
@@ -1,19 +1,20 @@
################################################################################
-# GAYE Abdoulaye Walsimou, <walsimou@walsimou.com>
+# Abdoulaye Walsimou GAYE <awg@embtoolkit.org>
# Copyright(C) 2010 GAYE Abdoulaye Walsimou. All rights reserved.
#
-# This program is free software; you can distribute it and/or modify it
-# under the terms of the GNU General Public License
-# (Version 2 or later) published by the Free Software Foundation.
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
#
-# This program is distributed in the hope it will be useful, but WITHOUT
-# ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or
-# FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License
-# for more details.
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
#
-# You should have received a copy of the GNU General Public License along
-# with this program; if not, write to the Free Software Foundation, Inc.,
-# 59 Temple Place - Suite 330, Boston MA 02111-1307, USA.
################################################################################
#
# \file openssl.kconfig
@@ -35,6 +36,9 @@ choice
depends on EMBTK_HAVE_OPENSSL
help
Here you can choose which version of openssl you want to use.
+ config EMBTK_OPENSSL_VERSION_0_9_8O
+ bool "openssl-0.9.8o"
+ select EMBTK_OPENSSL_NEED_PATCH
config EMBTK_OPENSSL_VERSION_0_9_8N
bool "openssl-0.9.8n"
select EMBTK_OPENSSL_NEED_PATCH
@@ -45,6 +49,7 @@ endchoice
config EMBTK_OPENSSL_VERSION_STRING
string
+ default "0.9.8o" if EMBTK_OPENSSL_VERSION_0_9_8O
default "0.9.8n" if EMBTK_OPENSSL_VERSION_0_9_8N
default "0.9.8l" if EMBTK_OPENSSL_VERSION_0_9_8L
diff --git a/packages/security/openssl/openssl.mk b/packages/security/openssl/openssl.mk
index aca6544..2eb6a26 100644
--- a/packages/security/openssl/openssl.mk
+++ b/packages/security/openssl/openssl.mk
@@ -1,24 +1,25 @@
################################################################################
-# GAYE Abdoulaye Walsimou, <walsimou@walsimou.com>
-# Copyright(C) 2010 GAYE Abdoulaye Walsimou. All rights reserved.
+# Abdoulaye Walsimou GAYE <awg@embtoolkit.org>
+# Copyright(C) 2009-2010 GAYE Abdoulaye Walsimou. All rights reserved.
#
-# This program is free software; you can distribute it and/or modify it
-# under the terms of the GNU General Public License
-# (Version 2 or later) published by the Free Software Foundation.
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
#
-# This program is distributed in the hope it will be useful, but WITHOUT
-# ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or
-# FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License
-# for more details.
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
#
-# You should have received a copy of the GNU General Public License along
-# with this program; if not, write to the Free Software Foundation, Inc.,
-# 59 Temple Place - Suite 330, Boston MA 02111-1307, USA.
################################################################################
#
# \file openssl.mk
# \brief openssl.mk of Embtoolkit
-# \author GAYE Abdoulaye Walsimou, <walsimou@walsimou.com>
+# \author Abdoulaye Walsimou GAYE <awg@embtoolkit.org>
# \date February 2010
################################################################################