summaryrefslogtreecommitdiff
path: root/packages/system/initng/initng.mk
diff options
context:
space:
mode:
authorAverell Kinouani <averell.kinouani@embtoolkit.org>2015-08-02 12:44:38 +0200
committerAverell Kinouani <averell.kinouani@embtoolkit.org>2015-08-02 12:44:38 +0200
commite5c2fe16de0e67f5f60c5c49c59d501964b8b5d0 (patch)
treef7cfd6fd95335db9d83643739709db69856f0cad /packages/system/initng/initng.mk
parent97ce55e333ddf83c11c524d84724e774183600f3 (diff)
downloadembtoolkit-e5c2fe16de0e67f5f60c5c49c59d501964b8b5d0.tar.gz
embtoolkit-e5c2fe16de0e67f5f60c5c49c59d501964b8b5d0.tar.bz2
embtoolkit-e5c2fe16de0e67f5f60c5c49c59d501964b8b5d0.tar.xz
Packages: system: add new package initng
Diffstat (limited to 'packages/system/initng/initng.mk')
-rw-r--r--packages/system/initng/initng.mk51
1 files changed, 51 insertions, 0 deletions
diff --git a/packages/system/initng/initng.mk b/packages/system/initng/initng.mk
new file mode 100644
index 0000000..0df25bf
--- /dev/null
+++ b/packages/system/initng/initng.mk
@@ -0,0 +1,51 @@
+################################################################################
+# Embtoolkit
+# Copyright(C) 2009-2012 Abdoulaye Walsimou GAYE.
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+################################################################################
+#
+# \file initng.mk
+# \brief initng.mk of Embtoolkit
+# \author Averell KINOUANI <averell.kinouani@embtoolkit.org>
+# \date July 2015
+################################################################################
+
+INITNG_NAME := initng
+INITNG_VERSION := $(call embtk_get_pkgversion,initng)
+INITNG_SITE := http://sourceforge.net/projects/initng/files/initng/v0.6/
+INITNG_PACKAGE := initng-$(INITNG_VERSION).tar.bz2
+INITNG_SRC_DIR := $(embtk_pkgb)/initng-$(INITNG_VERSION)
+INITNG_BUILD_DIR := $(embtk_pkgb)/initng-$(INITNG_VERSION)
+
+INITNG_BINS := initng
+INITNG_LIBS := libinitng.*
+
+INITNG_CMAKE_OPTS := "SET(CMAKE_SYSTEM_NAME Linux)\n\
+ SET(CMAKE_C_COMPILER $(TARGETCC))\n\
+ SET(CMAKE_CXX_COMPILER $(TARGETCXX))\n\
+ SET(CMAKE_FIND_ROOT_PATH $(embtk_tools))\n\
+ SET(CMAKE_FIND_ROOT_PATH_MODE_PROGRAM NEVER)\n\
+ SET(CMAKE_FIND_ROOT_PATH_MODE_LIBRARY $(embtk_sysroot)/usr/lib)\n\
+ SET(CMAKE_FIND_ROOT_PATH_MODE_INCLUDE $(embtk_sysroot)/usr/include)\n\
+ SET(CMAKE_INSTALL_PREFIX $(embtk_sysroot))\n"
+
+
+define embtk_install_initng
+ printf $(INITNG_CMAKE_OPTS) >> $(INITNG_BUILD_DIR)/CMakeLists.txt;
+ (cd $(INITNG_BUILD_DIR) && cmake . && make && make install)
+endef
+
+