summaryrefslogtreecommitdiff
path: root/packages/system
diff options
context:
space:
mode:
authorAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2014-01-11 22:16:49 +0100
committerAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2014-01-11 22:16:49 +0100
commitf0108e8bfa0fcb7b3bec515e95109856757efe6a (patch)
treeb14b466160f93a2e3f86ea0daf714c5ea29c9f34 /packages/system
parent725691eab26e1fcd0eaf332e80ddd578024280b6 (diff)
downloadembtoolkit-f0108e8bfa0fcb7b3bec515e95109856757efe6a.tar.gz
embtoolkit-f0108e8bfa0fcb7b3bec515e95109856757efe6a.tar.bz2
embtoolkit-f0108e8bfa0fcb7b3bec515e95109856757efe6a.tar.xz
Packages: remove upstart
Signed-off-by: Abdoulaye Walsimou Gaye <awg@embtoolkit.org>
Diffstat (limited to 'packages/system')
-rw-r--r--packages/system/system.kconfig5
-rw-r--r--packages/system/system.mk11
-rw-r--r--packages/system/upstart/upstart.kconfig76
-rw-r--r--packages/system/upstart/upstart.mk112
4 files changed, 4 insertions, 200 deletions
diff --git a/packages/system/system.kconfig b/packages/system/system.kconfig
index 07eba17..78cb175 100644
--- a/packages/system/system.kconfig
+++ b/packages/system/system.kconfig
@@ -1,6 +1,6 @@
################################################################################
# Embtoolkit
-# Copyright(C) 2010-2011 Abdoulaye Walsimou GAYE.
+# Copyright(C) 2010-2014 Abdoulaye Walsimou GAYE.
#
# This program is free software: you can redistribute it and/or modify
# it under the terms of the GNU General Public License as published by
@@ -28,6 +28,3 @@ source packages/system/dbus/dbus.kconfig
# e2fsprogs
source packages/system/e2fsprogs/e2fsprogs.kconfig
-
-#upstart
-source packages/system/upstart/upstart.kconfig
diff --git a/packages/system/system.mk b/packages/system/system.mk
index 6db9fe7..be5aa4d 100644
--- a/packages/system/system.mk
+++ b/packages/system/system.mk
@@ -1,6 +1,6 @@
################################################################################
# Embtoolkit
-# Copyright(C) 2010-2011 Abdoulaye Walsimou GAYE.
+# Copyright(C) 2010-2014 Abdoulaye Walsimou GAYE.
#
# This program is free software: you can redistribute it and/or modify
# it under the terms of the GNU General Public License as published by
@@ -23,15 +23,10 @@
# \date July 2010
################################################################################
-#dbus
-include packages/system/dbus/dbus.mk
-ROOTFS_COMPONENTS-$(CONFIG_EMBTK_HAVE_DBUS) += dbus_install
+# dbus
+$(call embtk_include_pkg,dbus)
# e2fsprogs
include packages/system/e2fsprogs/e2fsprogs.mk
ROOTFS_COMPONENTS-$(CONFIG_EMBTK_HAVE_E2FSPROGS) += e2fsprogs_install
HOSTTOOLS_COMPONENTS-$(CONFIG_EMBTK_HOST_HAVE_E2FSPROGS) += e2fsprogs_host_install
-
-#upstart
-include packages/system/upstart/upstart.mk
-ROOTFS_COMPONENTS-$(CONFIG_EMBTK_HAVE_UPSTART) += upstart_install
diff --git a/packages/system/upstart/upstart.kconfig b/packages/system/upstart/upstart.kconfig
deleted file mode 100644
index 48feb06..0000000
--- a/packages/system/upstart/upstart.kconfig
+++ /dev/null
@@ -1,76 +0,0 @@
-################################################################################
-# Embtoolkit
-# Copyright(C) 2010-2011 Abdoulaye Walsimou GAYE.
-#
-# This program is free software: you can redistribute it and/or modify
-# it under the terms of the GNU General Public License as published by
-# the Free Software Foundation, either version 2 of the License, or
-# (at your option) any later version.
-#
-# This program is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-# GNU General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License
-# along with this program. If not, see <http://www.gnu.org/licenses/>.
-#
-################################################################################
-#
-# \file upstart.kconfig
-# \brief upstart.kconfig of Embtoolkit
-# \author Abdoulaye Walsimou GAYE <awg@embtoolkit.org>
-# \date October 2010
-################################################################################
-
-config EMBTK_HAVE_UPSTART
- bool "Have upstart (please see the note about busybox)"
- select KEMBTK_EGLIBC_OPTION_EGLIBC_UTMPX if EMBTK_CLIB_EGLIBC
- select KEMBTK_UCLIBC_UCLIBC_HAS_UTMPX if EMBTK_CLIB_UCLIBC
- select EMBTK_HAVE_LIBNIH
- help
- Upstart is an event-based replacement for the /sbin/init daemon
- which handles starting of tasks and services during boot,
- stopping them during shutdown and supervising them while the
- system is running.
-
- It was originally developed for the Ubuntu distribution, but is
- intended to be suitable for deployment in all Linux
- distributions as a replacement for the venerable System-V init.
-
- Feature are:
- * Tasks and Services are started and stopped by events
- * Events are generated as tasks and services are started and
- stopped
- * Events may be received from any other process on the system
- * Services may be respawned if they die unexpectedly
- * Supervision and respawning of daemons which separate from
- their parent process
- * Communication with the init daemon over D-Bus
-
- NOTE: WARNING!!!
- If you use busybox beside upstart, you need to disable busybox
- init facilities.
-
-choice
- prompt "upstart version you wish"
- depends on EMBTK_HAVE_UPSTART
- help
- Here you can choose which version of upstart you want to use.
-
- config EMBTK_UPSTART_VERSION_0_6_6
- bool "upstart-0.6.6"
-endchoice
-
-config EMBTK_UPSTART_MAJOR_VERSION_STRING
- string
- default "0.6" if EMBTK_UPSTART_VERSION_0_6_6
-
-config EMBTK_UPSTART_VERSION_STRING
- string
- default "0.6.6" if EMBTK_UPSTART_VERSION_0_6_6
-
-config EMBTK_UPSTART_NEED_PATCH
- bool
-
-
diff --git a/packages/system/upstart/upstart.mk b/packages/system/upstart/upstart.mk
deleted file mode 100644
index 7ee66a2..0000000
--- a/packages/system/upstart/upstart.mk
+++ /dev/null
@@ -1,112 +0,0 @@
-################################################################################
-# Embtoolkit
-# Copyright(C) 2010-2011 Abdoulaye Walsimou GAYE.
-#
-# This program is free software: you can redistribute it and/or modify
-# it under the terms of the GNU General Public License as published by
-# the Free Software Foundation, either version 2 of the License, or
-# (at your option) any later version.
-#
-# This program is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-# GNU General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License
-# along with this program. If not, see <http://www.gnu.org/licenses/>.
-#
-################################################################################
-#
-# \file upstart.mk
-# \brief upstart.mk of Embtoolkit
-# \author Abdoulaye Walsimou GAYE <awg@embtoolkit.org>
-# \date October 2010
-################################################################################
-
-UPSTART_VERSION := $(subst ",,$(strip $(CONFIG_EMBTK_UPSTART_VERSION_STRING)))
-UPSTART_MAJOR_VERSION := $(subst ",,$(strip $(CONFIG_EMBTK_UPSTART_MAJOR_VERSION_STRING)))
-UPSTART_SITE := http://upstart.ubuntu.com/download/$(UPSTART_MAJOR_VERSION)
-UPSTART_PATCH_SITE := ftp://ftp.embtoolkit.org/embtoolkit.org/upstart/$(UPSTART_VERSION)
-UPSTART_PACKAGE := upstart-$(UPSTART_VERSION).tar.gz
-UPSTART_BUILD_DIR := $(embtk_pkgb)/upstart-$(UPSTART_VERSION)
-
-UPSTART_BINS =
-UPSTART_SBINS =
-UPSTART_INCLUDES =
-UPSTART_LIBS =
-UPSTART_PKGCONFIGS =
-
-UPSTART_DEPS := libnih_install
-
-upstart_install: $(UPSTART_BUILD_DIR)/.installed
-
-$(UPSTART_BUILD_DIR)/.installed: $(UPSTART_DEPS) download_upstart \
- $(UPSTART_BUILD_DIR)/.decompressed $(UPSTART_BUILD_DIR)/.configured
- $(call embtk_pinfo,"Compiling and installing \
- upstart-$(UPSTART_VERSION) in your root filesystem...")
- $(call __embtk_kill_lt_rpath,$(UPSTART_BUILD_DIR))
- $(Q)$(MAKE) -C $(UPSTART_BUILD_DIR) $(J)
- $(Q)$(MAKE) -C $(UPSTART_BUILD_DIR) DESTDIR=$(embtk_rootfs)/ install
- $(Q)-rm -rf $(embtk_rootfs)/share
- @touch $@
-
-download_upstart:
- $(call embtk_pinfo,"Downloading $(UPSTART_PACKAGE) \
- if necessary...")
- @test -e $(embtk_dldir)/$(UPSTART_PACKAGE) || \
- wget -O $(embtk_dldir)/$(UPSTART_PACKAGE) \
- $(UPSTART_SITE)/$(UPSTART_PACKAGE)
-ifeq ($(CONFIG_EMBTK_UPSTART_NEED_PATCH),y)
- @test -e $(embtk_dldir)/upstart-$(UPSTART_VERSION).patch || \
- wget -O $(embtk_dldir)/upstart-$(UPSTART_VERSION).patch \
- $(UPSTART_PATCH_SITE)/upstart-$(UPSTART_VERSION)-*.patch
-endif
-
-$(UPSTART_BUILD_DIR)/.decompressed:
- $(call embtk_pinfo,"Decompressing $(UPSTART_PACKAGE) ...")
- @tar -C $(embtk_pkgb) -xzf $(embtk_dldir)/$(UPSTART_PACKAGE)
-ifeq ($(CONFIG_EMBTK_UPSTART_NEED_PATCH),y)
- @cd $(UPSTART_BUILD_DIR); \
- patch -p1 < $(embtk_dldir)/upstart-$(UPSTART_VERSION).patch
-endif
- @touch $@
-
-$(UPSTART_BUILD_DIR)/.configured:
- $(Q)cd $(UPSTART_BUILD_DIR); \
- CC=$(TARGETCC_CACHED) \
- CXX=$(TARGETCXX_CACHED) \
- AR=$(TARGETAR) \
- RANLIB=$(TARGETRANLIB) \
- AS=$(CROSS_COMPILE)as \
- LD=$(TARGETLD) \
- NM=$(TARGETNM) \
- STRIP=$(TARGETSTRIP) \
- OBJDUMP=$(TARGETOBJDUMP) \
- OBJCOPY=$(TARGETOBJCOPY) \
- CFLAGS="$(TARGET_CFLAGS)" \
- CXXFLAGS="$(TARGET_CFLAGS)" \
- LDFLAGS="-L$(embtk_sysroot)/$(LIBDIR) -L$(embtk_sysroot)/usr/$(LIBDIR)" \
- CPPFLAGS="-I$(embtk_sysroot)/usr/include" \
- PKG_CONFIG=$(PKGCONFIG_BIN) \
- PKG_CONFIG_PATH=$(EMBTK_PKG_CONFIG_PATH) \
- ./configure --build=$(HOST_BUILD) --host=$(STRICT_GNU_TARGET) \
- --target=$(STRICT_GNU_TARGET) --libdir=/usr/$(LIBDIR) --disable-rpath \
- --prefix=/ --exec-prefix= --sysconfdir=/etc
- @touch $@
-
-upstart_clean:
- $(call embtk_pinfo,"cleanup upstart...")
- $(Q)-cd $(embtk_sysroot)/usr/bin; rm -rf $(UPSTART_BINS)
- $(Q)-cd $(embtk_sysroot)/usr/sbin; rm -rf $(UPSTART_SBINS)
- $(Q)-cd $(embtk_sysroot)/usr/include; rm -rf $(UPSTART_INCLUDES)
- $(Q)-cd $(embtk_sysroot)/usr/$(LIBDIR); rm -rf $(UPSTART_LIBS)
- $(Q)-cd $(embtk_sysroot)/usr/$(LIBDIR)/pkgconfig; rm -rf $(UPSTART_PKGCONFIGS)
- $(Q)-rm -rf $(UPSTART_BUILD_DIR)*
-
-$(UPSTART_BUILD_DIR)/.special:
- $(Q)-mkdir -p $(embtk_rootfs)/etc
- $(Q)-mkdir -p $(embtk_rootfs)/etc/dbus-1
- $(Q)-mkdir -p $(embtk_rootfs)/etc/dbus-1/system.d
- $(Q)-cp $(embtk_sysroot)/etc/dbus-1/system.d/Upstart.conf \
- $(embtk_rootfs)/etc/dbus-1/system.d
- $(Q)-cp -R $(embtk_sysroot)/etc/init $(embtk_rootfs)/etc/