summaryrefslogtreecommitdiff
path: root/packages/textproc
diff options
context:
space:
mode:
authorAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2014-07-16 21:52:54 +0200
committerAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2014-07-16 21:52:54 +0200
commit9d8f19059692bba549f79050ba6cca4088ccf6e0 (patch)
tree588da8d9182f575b5561aea5e7dad748c7649066 /packages/textproc
parentef47bdb3181d757347325b66304cc1c4f969c67d (diff)
downloadembtoolkit-9d8f19059692bba549f79050ba6cca4088ccf6e0.tar.gz
embtoolkit-9d8f19059692bba549f79050ba6cca4088ccf6e0.tar.bz2
embtoolkit-9d8f19059692bba549f79050ba6cca4088ccf6e0.tar.xz
Packages/textproc: add missing .kconfig and .mk files
Signed-off-by: Abdoulaye Walsimou Gaye <awg@embtoolkit.org>
Diffstat (limited to 'packages/textproc')
-rw-r--r--packages/textproc/textproc.kconfig30
-rw-r--r--packages/textproc/textproc.mk32
2 files changed, 62 insertions, 0 deletions
diff --git a/packages/textproc/textproc.kconfig b/packages/textproc/textproc.kconfig
new file mode 100644
index 0000000..033f6b9
--- /dev/null
+++ b/packages/textproc/textproc.kconfig
@@ -0,0 +1,30 @@
+################################################################################
+# Embtoolkit
+# Copyright(C) 2014 GAYE Abdoulaye Walsimou.
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+################################################################################
+#
+# \file textproc.kconfig
+# \brief text processing packages and libraries
+# \author GAYE Abdoulaye Walsimou, <walsimou@walsimou.com>
+# \date July 2014
+################################################################################
+
+# libxml2
+source packages/textproc/libxml2/libxml2.kconfig
+
+# raptor
+source packages/misc/raptor/raptor.kconfig
diff --git a/packages/textproc/textproc.mk b/packages/textproc/textproc.mk
new file mode 100644
index 0000000..c6e6b33
--- /dev/null
+++ b/packages/textproc/textproc.mk
@@ -0,0 +1,32 @@
+################################################################################
+# Embtoolkit
+# Copyright(C) 2014 GAYE Abdoulaye Walsimou.
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+################################################################################
+#
+# \file textproc.kconfig
+# \brief text processing packages and libraries
+# \author GAYE Abdoulaye Walsimou, <walsimou@walsimou.com>
+# \date July 2014
+################################################################################
+
+embtk_pkgincdir := packages/textproc
+
+# libxml2
+$(call embtk_include_pkg,libxml2)
+
+# raptor
+$(call embtk_include_pkg,raptor)